Conflict between Stryd and KickR Core 2018

Hi there Zwift!

Using Zwift, AppleTv4k, KickR Core, Stryd - all with latest software updates and firmware updates.

I do runs and rides in Zwift. For the runs I have Stryd, and for the rides I have a KickR Core 2018 (brand new).
When I try to ride, it always selects the Stryd as power-source (under “ride”! not run) instead of the KickR Core and I cannot switch it to the KickR Core!
It opens up the pairing dialog for like 10mseconds and selects the Stryd, so there’s nothing I can do to select the KickR Core for power source, the power-source dialog closes immiediately without me having the option to select anything.

The only way I can select the KickR Core is to remove the shoe with the attached Stryd from my garage, so it cannot find it, so the run-mode is unpaired (orange instead of blue). Then I can switch to “ride” and select the power-source as the KickR Core. Then this dialog does not close itself in 10msec and I can choose whatever power-source is available (namely the KickR Core)

Please fix this Zwift. Thank you

Sorry to hear this Eiki! So you’re unable to unpair the Stryd at all at the pairing screen correct? And when you start your “ride” can you unpair it from the menu?

Hi Vincent,

Not able to unpair it, no … I have to move the Stryd from the garage so there’s no signal coming from it, to the AppleTv 4k, to be able to use the KickR Core instead of the Stryd. You’ll see this the moment you guys set this up yourself, Stryd + Wahoo KickR Core.

Of course I have this workaround … moving the Stryd from the garage, but that should not be needed … the Stryd is not even active, in a the sense that I haven’t “woken it up”, by moving the shoe it’s placed on. This wouldn’t be a problem if the power-source pairing screen would just stay where it says “searching” for devices … but I never get the change to select power-sources like I said before, the window just closes right away, if Stryd is connected to it, and I try to change to “ride” instead of the run.

Please have a look at this, since the Stryd is the “de facto” standard for running … and the Wahoo KickR Core is a really good product, and very popular among riders, so this combo is something lots of people will have, or already have installed … connected to their AppleTv 4k.

I understand. Our QA team is investigating! If it wasn’t Apple TV you may have been able to edit the prefs file but this makes it a little more difficult. For Run mode can you try unpairing your Stryd, then switch to Ride and see if it auto pairs?

Hi again and thanx for your quick replies … I really appriciate the fast response time you guys have.

I just tried this again in my garage … is it possible that this has been fixed in the updated version ( I just downloaded it now! ) just released today ? I cannot make this bug appear any more :smile:

I don’t even have to unpair the Stryd anymore it seems … it’s selected when I go to the run ( on the right ) and when I switch to the ride ( on the left ) now I’m able to get into the “power source” without the window closing right away, so I’m actually able to pick the KickR Core now !!! :slight_smile:

I’ll let you guys know if I run into this problem, in the new version of Zwift - but you can close this issue for now.

I only have two complaints about Zwift now. The first one, is the same a lot of people also seem to have … and that is this one, which I see you’ve marked as “investigating” which is excellent:

  • I would think this is in high priority where loads of people are using AppleTv 4k with your app

The second one is this, I’d really like to be able to enroll in 1 running program, and 1 ride program:

Thank for you for an EXCELLENT app, and the NY track is brilliant!!! :slight_smile:

I have the same issue with my milestone. I have raised this with support previously so it’s not unknown. I have to leave my shoe downstairs from my gym and reboot the AppleTV to get it to switch.

Vincent, please don’t close this thread.

Steve, yes, I had similar problems while I was working out today … I could not change to the Stryd, the power-source screen just opened and closed again and again … very fast so I could not choose anything. There seems to be some conflict when you do both running and riding.

I still have the same problem.

@Steven Copeland, then upvote this thread :slight_smile:

Just as an aside, I had the exact same issue with Stryd and the bluetooth on my treadmill. The treadmill (Matrix, touchscreen so you can see what is going on) would always try to pair Stryd as a HRM. It would not let go, and would not let me pair with a real HRM. For now, I am doing what you suggested above, putting the stryd in the garage, then pairing with the real HRM, then bringing the running shoes back downstairs. Makes me wonder if the issue is more with Stryd than with Zwift of my treadmill.

Here’s a video of the conflict … and the KickR Core is not even connected ( I pulled the plug on it, so it has no power at all ). Trying to do a running exercise.

The only way to fix this, in this case is switch to RIDE tab and there I select the power sensor, to get it disconnected/unpaired. Then I switch back to the Run tab, and select the Stryd.

More detailed “fix” / workaround:
Select your power source on the appropriate screen (be it the riding-pair-screen or the running-pair-screen on the opposite screen of the sport you want to do), and select your power-source there to get it DISCONNECTED. Then you can use the Ride/Run screen without this flicker bug.

I have same issue, can’t unpair Stryd in order to pair Kickr when switching from running to cycling

I am having the same problem on iPhone app. I just got a stryd and ever since I paired it and did a Zwift run, I can no longer Zwift ride. It picks stryd for default power source in ride and won’t let me change it. Please help!!

Zwift is doing a great job in balancing both cycling and running, including the establishment of their Triathlete academy. I hope they look at these niggles for multisport members.

As i triathlete, i use the auto option to change from bike to run and visa versa for my brick sessions. The auto save works well when changing through the menu pairing screen, but have come across this bluetooth issue a couple of times which interrupts my training flow!

I realise one issue resides with the limited Bluetooth Channels available on my Apple TV 4k, and i’m unsure why Apple doesn’t update and allow a couple channels; as i’m lead to believe up to 7 slaves with one master (Apple TV) can be available under the BT protocol on its piconet.

I had this very same issue tonight and ended up scrapping my ride altogether. This happens sometimes but not always. I even restarted my Apple TV several times with zero result. Frustrating.

Any solution here… BLE can not find the Kicker Core just the stryd power

I have this same issue with my Stryd (for running on my treadmill) and my Tacx trainer (obv for biking). I have found a simple workaround - if you double click the pairing box it actually lets you go in and pair the trainer rather than the Stryd. Without double clicking it seems to only give me a nanosecond to try override the ‘default’ pairing which seems to be the Stryd even for setting up a bike ride!

I have this same issue. It is very frustrating. I am unable to ride as zwift keeps wanting to pair my stryd for rides. I unselect it for both cadence and power under the run screen and when I move over to the ride screen it auto-selects the stryd again and tells me I am unable to pair devices.

Please fix this! When you enter zwift can you not select run/ride and then choose your default power. The current setup is hit and miss and rather annoying - I have now missed 3 rides with pairing issues.

@Lyle_Davies read my post above in this thread … under
More detailed “fix” / workaround


Zwift needs to stop recognizing STRYD as a valid powermeter for cycling!

I have a dumb trainer setup, and Zwift keeps trying to select the STRYD as the biking power source (which makes my avatar sit still since power=0).

1 Like