Zwift Play Controllers disconnect and do not reconnect from Samsung Galaxy S6 Lite tablet [October 2023]

I have pc, controllers work mostly perfect before and they still do. My wife is Android. They always worked before. Now they will connect, shortly after they disconnect and start flashing until they shut off. It has done that every ride since 1.2.1 update. @Rowdy

2 Likes

I run Zwift and Companion on Android so using Companion as a bridge isn’t an option for me. Still waiting for a response from Support after being escalated higher so at this moment they are unusable.

1 Like

Hi @Rowdy,

I do have exactly the same issue after upgrading to firmware 1.2.1. Before it worked absolutely fine. After applying the update it disconnects after araound 2 minutes. My hardware setup is an Android Samsung Galaxy tab s6 lite - already applied the very latest Zwift app version and even tried to use the charging cable connected. No luck at all. Could you please offer to revert to an oder firmware version on Android? With that it worked perfectly.

Regards Frank

3 Likes

Hello folks,

I’ve received a few reports of the Zwift Play disconnecting shortly after dropping into an activity and not reconnecting. I’ve split this issue off into its own thread to help focus the conversation and make sure I get the most relevant feedback to report back to Zwift engineers.

All of these reports so far have been from Zwifters who run the Zwift app on a Galaxy S6 Lite tablet, but it’s a small enough group of reports that I’m not positive the hardware is the cause. If you have the option to pair your Play to a different device running Zwift, please let us know whether the issue persists.

Yes.yes yes. @Rowdy
My wife has the S6 lite. I’ve reported to you before, but she has the exact problem you described.
I used her play controller’s. Connected to my Laptop, and they worked perfect (like they used to for her).
She used my controllers, and the same problem. They connected, and worked briefly. They disconnected, started flashing and then shut off after about 30 seconds. Very frustrating for her. They used to work perfect. I wish that I didn’t update her controllers.
So to recap. It’s not the controllers. They work perfect with my laptop, and my controllers don’t work with her S6 lite, either.

As already commented, I have the S6 Lite. Support exchanged the controllers but the most recent Play update causes them to disconnect again every 1:30-2:00 minutes.

1 Like

@Rowdy Hi @Rowdy, that’s exactly the case for me - if I am running it on a Samsung Galaxy tab s6 lite it disconnects after araound 2 minutes. If I do run it on my Samsung galaxy phone S22 ultra it runs without any problems. Tried already several times and re-installed, re-connected… always the same issue. Before applying the firmware update version 1.2.1 everything worked well on the tablet as well. After applying the update - disconnects after araound 2 minutes.

Regards Frank

3 posts were merged into an existing topic: Zwift Play Controller connection issues

A post was merged into an existing topic: Heart rate monitor not connecting [November 2023]

A post was merged into an existing topic: Heart rate monitor not connecting [November 2023]

A post was merged into an existing topic: Zwift Play Controller connection issues

I have an S6 Lite and have the same experience. While the blame is being put on the Samsung Tablet I need to remind them that it was working reliably BEFORE the update, so how is this actually an S6 lite problem?

1 Like

I have the same issue as noted in this thread. And yes they were working correct on the previous software version of the controllers and they work correctly on other devices (Samsung S20 & Dell Laptop).

Exactly the same issue running samsung tab s6 lite. Have been in touch with “support” who told me 10 days ago that my case “was being forwarded to the relevant team” I have heard nothing since. I am now attempting to return the hub. Having experienced zwift levels of “support” i’m sure i don’t want to enter an on-going contract with them.

It is not a issue with the tab s6 lite. The issue is with your software. I have proved this with support. They assured me they would get back to me 10 days ago. My patience has now run out. Can I just remind anyone reading this of their legal rights if a product is “not fit for purpose or as described” These legal rights supersede any “30 day returns policy”

Support kept offering me replacements saying a new one “could be better” but I have had consistant issues since purchase. Too many people handled my complaint so was alot of back and forth and repeating myself. My current replacement disconnects because I updated it. It is the current software not our tablets.
You are by law entitled to a full refund, Support emailed me prepaid courier labels to send back.

1 Like

Same here. As you say “alot of back and forth” with no real solution gets very frustrating. I’m happy to hear you finally found a solution which worked for you and appreciate your input to this thread and the reminder to others of our rights.

I don’t have a solution, I’m waiting (im)patiently for Support to release an update. :rofl: I would suggest if you are fortunate to be offered a replacement, do not update it until it is rectified.

I’m sorry to hear that you’ve still not had a solution Emma, I hope they manage to “work on it” soon. Thank you very much for the suggestion. Luckily for me I have legal protection which allows me to return the whole hub and forfeit my free year for a refund of both items. In my experience during the month I have used zwift for no cost. It has still “cost me” way more in time and frustration than it’s worth. I am currently using my payment provider to try and reclaim the money as despite the tracking number showing the hub as being delivered to the warehouse some time ago, I’ve heard nothing from zwift regarding a refund. I’m just glad I experienced how bad Zwift’s service is whilst I still had consumer laws to protect me. I feel very sorry for those that don’t.