Zwift Play Controller connection issues

Update: connecting power to the play controller (right side) helps a lot, reducing the reconnects to 1-2 per hour.

Hi all,

We’re still working on the frequent disconnect/reconnect issue that some Zwifters are still experiencing. That should already be happening less in Zwift version 1.46.0, but Zwift Play firmware version 1.2.0 will address this even more. FW 1.2.0 is currently in phased rollout (Zwift Play Firmware Release Notes), so please update when you have the chance.

Thank you for your patience and feedback.

1 Like

Hi Rowdy.
Thanks for the update.

Update to my original post.

I cycled for over 1½ hours without any issues once I moved my pc tower closer to the bike. I think I’m using that latest firmware. Bluetooth strength still jumps around a lot on the connection screen though.

its a mess. updated the firmware and the play controllers keep getting disconnected after 10 seconds and I have to pair them again, only to be gone after 10 seconds again

Hi @Peter_Twigt_BEAT , that’s definitely not an ideal experience. I’ve updated our investigation to reflect your report. Here are some options I can recommend that may improve your experience, or help narrow down the root of the problem:

These are fairly universal troubleshooting steps I can share here on the forums. Depending on the results, it may be worth opening up a Support ticket in order for me or colleagues to troubleshoot with you more directly.

Hi @Rowdy
Tried it again this morning. Note, I had no issues at all with the play controllers prior to the firmware update.

I can pair them perfectly and as long as I am in the garage it stays connected as you can see in the screenshot. The moment I started a group ride the disappair after about 10 seconds. I get a controllers disconnected message in the top field, where after that they arent shown anymore.

Fun part is, on the field on the right, where all the riders are theyn are still shown as working as you can see on the 2nd screenshot.

Here is what is and isnt working. I can still steer, can use the powerup button, can acces the menu.

But … I can not brake and I can not give any rideons through the play controllers.

So it looks like the problem is somewhere there.


Edit : Just noticed something on the first screenshot so I took it for another spin. When I did the groupride event there was no backlight showing and I could not brake.

So I just did a free rode on Richmond and everything worked like it should. So the problem for me is when I join an event they stop working.

Hope this helps you guys solving the issue.

I seem to be able to get them to connect reliably to Windows now but there are still other issues.

  • It’s incredibly difficult to get my Tickr to pair with Zwift on Windows when the Play controllers are connected. The Tickr was always slow to pair with Zwift (it’s fine with Rouvy, TR, etc) but with the Play controllers it’s even worse.
  • There is still massive audio interference with my Pixel Buds Pro when my Play controllers are paired to the extent that I’d still rather use the Companion app. I can recreate it in two ways:
    • Even while simply idling at a spawn point if I press the “menu” button and then the “back” button it will cause interference for 2-3 seconds.
    • When I teleport to a Robopacer and it will cause 5-20 seconds of interference.

Note how similar the interference when teleporting paired with Windows is to the all devices dropping out when teleporting paired to the Companion app. They are surely the same underlying bug?

2 Likes

The problem was also not fixed for me with version 1.2.

I get the message that the steering device has been disconnected after some time (> 10 minutes) both in events and during free driving. After this, Zwift Play is no longer shown in the list of paired devices. However, steering and all buttons still work, only braking no longer works. Sometimes the controllers still vibrate when the brake is applied, but no brake light appears and the speed is not reduced.

However, due to the software update, the Left Controller no longer vibrates at irregular intervals.

Setup:

  • Windows 10 with current drivers

  • Bluetooth card: Intel AX210

  • All other Bluetooth devices (Airpods Pro, Polar H10) work without problems; Kickr V is connected via Direct-Connect.

I have noticed, like others, that the reception quality display in the connection screen fluctuates greatly. I have also tried with an Asus USB Bluetooth adapter, but the problem occurred there as well. It works better when I use ZC as a bridge; here, connection interruptions occur much less frequently.

Quick update after one more ride: Did not stop the left controller from randomly vibrating.

As others have replied, I have had similar drop out issues with the left controller. The signal strength on the left controller is poor; one red bar. No problems with the right. Adding a BLE+ extension to bring the BLE+ dongle close to the handle bars improved the single strength to the left controller and the dropouts quit. To me it appears that left controller has poor signal strength? I am working with support on the issue. Pairing with my Android shows improved signal strength as well. However, moving the phone away from the controllers shows a much quicker drop in signal strength to the left controller while the right one is much better. To me, it appears more of a quality issue of the hardware.

1 Like

@Peter_Twigt_BEAT Thank you very much for the details and those screenshots. We’re tracking an issue where steering and braking can remain disabled (although arrows and face buttons continue to work) in the event that the Play controllers unexpectedly disconnect and reconnect. This is also the explanation for why steering no longer appears enabled in the HUD, but the steering icon is still visible next to your nameplate in the Zwifters Nearby List.

1 Like

As I have posted on this thread a couple of times, I’d thought I’d give an update in my Zwift Play controller experience. Since my last post (v1.46 & FW 1.19), the play controllers got a firmware update to v1.2 & just today, the Zwift software was updated to v1.47.

I updated the play controller FW to v1.2 & zwift v1.46 (today 1.47) and unplugged the controllers to see how they would respond. To my surprise, I did a 90 min ride and both controllers stayed connected. However, the next day, did another ride and the right controller started dropping again. Not as often but still often enough to be frustrating. Tried again on the 3rd day and still right controller drops. Like others, the buttons seem to work but with no onscreen notifications and unchecked box in the devices menu. So back to plugging in the power to the controller for the next few rides & that stopped the right controller drops.

Another forum user suggested using a usb extension cable even though my BT dongle is 52" away from the center of the handlebars and has direct line of sight. So, what the heck, thought I might as well give that a try. Now the BT dongle is 22" inches away from the center of the handlebars and has direct line of sight. Well, looks like that worked. In the last two days of rides without plugging into power, the right controller hasn’t dropped once.

Given that info, either the play controllers need more power to broadcast or the BT receiver needs to be much closer as the transmitters are only broadcasting for a short distance. At least, that’s been my experience so far. Hope this will help others with their play controller connection issues.

5 Likes

Left Zwift Play controller not connecting - it’s getting worser with every update.

3 Likes

With Firmware 1.2.0 Zwift Play is unusable for me. BT connection dropouts after ~1 Minute connection time. Independent if using PC or Companion App. ZP interrupts HR and Cadence Sensor to zero.

4 Likes

Any news on the issue with brake’s permanently applied @Rowdy? As tested earlier and still not able to pair the controllers as the brakes are applied permanently.

Between that and stuck going left, they have been unusable for the best part of 4 weeks now.

I have integrated BT to my Wifi Card and my PC is 2meters away and i haven’t had any problems with Zwift Play dropping. My view of the problem is that USB Dongle for BT are not good and that’s why most have problems.

I do also have an integrated BT with an external antenna. Until FW 1.2.0 it worked fine. Now it is broken, even if I use CA as a bridge. All BT devices are working fine within a radius of ~10m except when ZP are active/on. Then communication is disturbed: Trek cadence sensor disappears, sennheiser BT headset dropouts, polar sense HR disappears.
E.g. HR unvisible in Zwift (PC) and CA but still connected to wahoo Headwind.
It (ZP) is also disturbing when the debives are connected via ANT…
The distance from all devices to PC are within 1m.

Will try again with 1.47.

But that is not a good experience, because you never know if you could have a good ride once there is an update in zwift universe.

You are right, a stable BT is needed, but you should not get in trouble once the setup is initiated. There is no indicator like the FPS showing actual issues.

Hello @Lee_H , that sounds like a really rough experience. If you’re having issues with getting the brakes stuck on and getting stuck steering in one direction, this sounds like it should be solved by calibrating your Play controllers. If you’ve already done so, and the problem is still happening afterwards, feel free to reach out to Support and we can see if there’s a hardware issue occurring.

Updated pc zwift to 1.47 and did a ride. No failure so far.

Looks like I have a similar issue since updating to the latest zwift version last night, the steering and braking on the left controller suddenly became disable, forcing my avatar to automatically steer to the left, arrow keys are working suggesting the controller is connected to zwift. The controller failed last night on the last few km NYC KOM after party ride so thought it was just bug in the game, however after reading the forum it seem to be the same issue everyone else is experiencing.

The issue re occurred when connecting tonight permanently steered into the left hand lane arrow keys working.

Right controller working as expected and allows me to steer and brake but once you realise automatically steered back to the left hand lane.

Set up is ios on an iPad