Zwift Play Controller connection issues

Ok here is my problem with the new zwift play controllers.
My Left controller will not connect by bluetooth on my pc running windows 11.
During the start up of zwift it will see my wahoo kicker, heartrate monitor just fine.
Then I try to connect my play controllers in the steering section and it sees both controllers but will only connect to the right one. The Z on the controller will go from flashing blue to steady blue on the right one but the left one will continue to flash.
The steering section shows both controllers and the battery levels and I can check the boxes to select both controllers but it will just keep showing connecting.
I wanted to know if the bluetooth was a problem with the controller so I closed the zwift program on my laptop and opened the companion app on my table and was able to connect both controllers to the companion right away and could see that both controllers were up to date with firmware.
SO back to the zwift on the pc, still would not connect the left controller. I even went all the way to uninstall zwift from my PC and reinstall zwift again. Still same issue, left controller would not connect.
If it is a distance issue I do not believe it as right now I have both controllers sitting RIGHT NEXT to the PC.
Both controllers worked fine the first 3 times that I used them and it was with the last version of zwift as today I just got the new update zwift, so the problem is with the most current and the last version.
Kind of at a loss right now with these controller, loved them the 3 rides that I did get to use them but kind of a big disappointment now, and if I can not figure this out soon they are going back!

This is just a question more than anything. Why don’t you want to use the companion app as a bridge to your pc??
When I started zwifting in 2020, the only way that I could figure out how to connect my trainer to my pc was through the companion app. Now my kickr has direct connect, but I still use the companion app for hr monitor.
I just received the play controller and will be trying this weekend. I plan on bridging it through my companion app

I just tried that and there is one heck of a lag time around 2-3 seconds from when I pressed a button and something happened.
But yes I was able to connect both controllers by using my tablet as a bridge but just not usable.
As soon as I went back to bluetooth thru the PC the problem came right back, the left controller will not connect and the Z just keeps flashing.
It is just odd that it will not connect thru the PC but I can see the battery level and the controller it self? I mean if I turn off the left controller the controller on the list of devices in the steering section will go away? So the PC and zwift is seeing the left controller it just will not finish the connecting process.

I guess I may be contacting zwift directly tomorrow.

I remember watching a YouTube video. Not sure who it was. Maybe DC rainmaker (just a guess). I thought that he said that the left controller connected to the right one, but the right one was the one that connects to your pc or whatever he was using. Maybe I’m totally wrong with that, might have been a dream. Lol
I wish you luck, hopefully you can figure it out.
I’m not feeling so confident that mine will work now :pleading_face:

My recent race I notice my left steering died mid race. Unable to steer left. So I turned off steering.

Turn it back on later in the race and I notice a right analogy drift. Not touching the controller my avatar drifts right slowly.

Another update on another try to get the play controllers working.
The left controller still will not connect using Bluetooth on the PC.
So I tried once more using my tablet as a “hub” to connect the play controllers thru, Worked, at first.
As soon as I started using the buttons BOTH controllers dropped out and did not matter what I did I could not get them to reconnect thru the my tablet as a hub.
So ran an got my android phone and gave that a try, with my phone I could not get either controller to connect thru the companion app.
SO shut down zwift on my PC and went into zwift hardware in the companion app and as soon as I selected zwift hardware both controllers went from blinking Z to steady Z.
Shut down my phone and grabbed the tablet and opened zwift companion and went to zwift hardware and as soon as I selected zwift hardware both controllers went from blinking Z to Steady Z.
SO this is telling me that the Bluetooth from the controllers and the tablet and phone work just fine it is just the software, it will not connect to the game.
I then shut down both my tablet and phone and went back to my PC this time before I started zwift I went into windows settings and looked for bluetooth devices and sure enough I was able to see both controllers, so again I do not think this is a bluetooth issue it is a zwift software issue.
Again while in zwift on the PC when I try to connect the 2 controllers I see them both and I can select them both but left controller will never “connect” to the game. The Z keeps Blinking.

Well that is what I have to report for today. I know that I am not any further ahead than I was yesterday but I am more sure that the controllers are working and that there is no problems with them, it is with the software. I guess I have to be sort of OK with it as these things are still being sold as “BETA”.

1 Like

It’s acknowledged that there’s an issue with the game app causing the Play to not work with Windows.

A fix is on route, bide your time and it’ll be sorted soon.


Speak to Zwift support. There’s a calibration procedure that they can get you to do on the controllers.

wondering if we need to start listing specs etc for these as it might be something with the native windows bluetooth driver

Sounds like a good idea to me.

Zwift have acknowledged it’s a game related issue and not anything to do with the Play it other hardware/software issues.

I’m sure a fix is on the way for the next update or even sooner.

If it was the game it should be happening to everyone

1 Like

I have a Bluetooth adapter 5.3 on a Windows 10 PC.
Did at least 50 Zwift workouts/races with it. Everything OK.
Other software like MyWhoosh currently still work perfectly with it.
Now with the Zwift Play Controller and current Zwift, he finds all sources (power, cadence, etc.) even the Play Controller. But then the battery indicator controller is gone, right away in the pairing screen.
Then the controller, shortly after Bluetooth, no connection to the KICKR etc. And Zwift crashes. In order to reactivate Bluetooth, the PC must be restarted, since Bluetooth is no longer available with other software, such as MyWhoosh.
With my old Bluetooth adapter 5.1 is everything o.k.
I tested it 3x with each adapter, always the same result.
Does the current Zwift no longer work with Bluetooth 5.3? But only with 5.1? - Because of the controller…?

I had a similar issue where the left controller would not connect. Contacted Zwift help and they sent me an article relating to calibrating the play controllers. Note the article only says to calibrate if told to do so by Zwift. Anyhow, this seems to have fixed the connection issue I was having. Suggest you contact Zwift help for support.

1 Like

I wrote the same text to Zwift Support…

What is this “calibration” exactly. How do you do it?

This is how to do it but take note that you should only do this if advised to by Zwift support.

Same issue with left controller on Windows 10 PC. All firmware is current. I’ve cleared the known device file and restarted Zwift but have the exact same problem. It appears the right controller does keep its connection.

I have not messaged Zwift Support since I cannot yet find the link to do that.

Marked as a solution to raise visibility on workarounds. Please feel free to update thread with questions and comments

Hi folks,

We’re investigating issues with Zwift Play appearing connected on the pairing screen, but not fully connecting and communicating with Zwift otherwise, as well as an issue with the Play disconnecting and reconnecting rapidly. Some of these have been addressed in Game Update 1.45.0, and more will be fixed in upcoming game versions, but there are two workarounds that have been successful in preventing these issues:

  • If your Play controller/controllers seem paired, but button presses aren’t working first, relaunch Zwift with both Play controllers turned off. Then pair them one at a time on the pairing screen, allowing the battery level indication to appear before pairing the next controller or continuing to the next device or screen.

  • If your Play controllers communicate with Zwift, but are intermittently disconnecting and reconnecting plug your Play controllers into a power source while you Zwift.

In addition to these workarounds, it’s also best to make sure that your device’s OS and bluetooth drivers are up to date.

If you’ve already tried these steps and are still having issues, please don’t hesitate to reach out to Support and/or follow up here.


I am currently having the same issues with the same symptoms as D Hardy. I have updated the firmware on the controllers. I have purchased a new USB hub and dongle to move the dongle closer to the controllers. I have tried both Windows 11 and Windows 10 versions on 2 different computers still without success. I have turned controllers on after Zwift program has booted without success. Initially, I had intermittent connection issues, then with the new USB hub, it seems to connect just like D Hardy describes in his email. The Zwift Play controllers show they are connected on the computer screen, the lights on the controller are both solid blue. I see the icon showing connection when I ride, but the controllers do not function. I am at a loss on what to do now for they simply will not work even though they show they are connected on either PC computer running WII or W10.