Zwift Play Controller connection issues

Well I tried your options and still my left controller will not pair.

One unique thing that I did notice is that when I turn the left controller on by pressing the Z button on the controller and it goes to blinking blue Z I will see the left controller show up in the steering screen of zwift, it will show the bluetooth symbol and the battery symbol/bars and the box that you check. Any way when I check the box to get it to connect it will not the controller will just keep blinking until the controller turns off. I will turn it back on and the controller will just blink blue Z.
But here is the thing that I found, if I press the Z button to turn it off and it powers down The steering section will keep showing the left controller.
I then tried the right controller and when I power on the right controller the steering section will then show the right controller but it will keep showing the left controller even though I powered it off. ANyway the right controller will then connect and I feel the buzz of the right controller. Now if I power off the right controller the steering section in zwift will then remove the right controller from the list but it will keep showing the left controller even though it has been powered off the entire time that I was connecting the right controller.

It is just odd that the first few rides once I received my play they worked just fine, this is even with the last zwift software version. It even worked just fine once with the current software version. I believe that the last time they worked I also had the most current firmware version installed in the controllers. Then the next time I went to do a ride the left controller just stopped connecting.

Support emailed me this procedure. I did it twice. Neither worked.

The first time the power, cadence and controllable all worked fine, but the steering on repack rush was intermittent. It worked initially, then the right failed and I could only steer left. There were numerous vibrations from the Zwift Play devices, which I imagine was it connecting/disconnecting. When I went to the pairing screen and tried to re-connect the steering Zwift app became unresponsive and crashed.

After the second time through the procedure the reverse happened. The steering stayed connected, but the power source, cadence and controllable said no signal. The avatar never moved of course. When I played with the pairing screen to try and fix the power/cadence/control zwift again crashed.

Its a Windows 10 computer about 3 feet away from the bike/zwift play. Very, very rarely have problems with Zwift & connections until trying to connect to Zwift Play. After the second crash, I left Zwift Play off and restarted Zwift app. It still said no signal on all my connections and couldn’t get it to connect. So I restarted the computer (again leaving Zwift Play off) and then power/cadence/control/HR connected and I was able to ride no problem.

Hi folks, I’m sorry to hear some of you are still having connectivity issues even with the workaround. I’ll escalate internally that the workaround is not proving effective for everyone.

The crashing issue should be solved very soon on your PC as 1.43.3 rolls out. More details on that are described in this thread: Zwift Play connection and crashes - PC, Android [June 2023] - #94 by Local_TimePlease

1 Like

Hi @D_Hardy , I’ve reached out to you directly via email to better analyze your setup and address the issue. The fix for this game issue should address your pairing issues, but I’d like to make sure that you’re not experiencing a different, but similar issue.

could it be a Bluetooth driver issue? Apart from one time where the right hand controller didn’t connect mine have been rock solid

2 days old 2 failed attempts !! followed the connection instructions above and still no good. Bike is approx 1m away from PC max.
Yesterday I got 15 mins before issues started today It disconnected 1m before race so just took them off.
was hoping new update would of made these more stable

1 Like

Can you clarify what version of Zwift you’re running?

I’m using the latest update1.43.3 on PC

It should be fixed now. 100% of users have the fix enabled.

This did not fix the connection issue for me. I am on pc

The rollout has only just been completed in the last few hours so perhaps next time you ride?

I am on 1.43.3 tried today to connect a few different ways and had no success. I did get a couple different work arounds from zwift of course tried those first.
Does seem to be a Bluetooth issue and zwift emails acknowledged as much directly and said they were working on a solution for the issue. So it is a known issue that they are trying to resolve but thanks for your input.

I did complete a small ride today and it is improved somewhat. At least the game doesn’t crash. The Play controllers do connect but constantly disconnect and reconnect. With that said they are working and not crashing the game so I feel with a little more time they should be able to fix the connection issues that are still causing problems.

Update on my problem.

Rowdy from zwift figured that I must have had an issue with the firmware update because my problem started right around when I did the firmware update 1.1.0

So he told me that a new firmware update for the controllers was ot or coming out very shorty and that it should fix it. The new version is 1.1.1

SO I updated the controllers and it fixed my problem with the left controller not connecting.

When I got zwift up and running on my PC and I selected both controllers both controllers connected and the flashing blue Z went to steady blue Z and both controllers did their little vibrate thing.

I do not have my bike on the trainer at the minute but I did start a ride to see if the would still work and they did the various buttons did their thing. So for whatever reason my left controller needed a new firmware version and firmware re-pushed out to it.

That would be a cool feature to have, the ability to re-push firmware out even if it is the same version. It would allow to go back to a starting point if you start to have wacky issues with the controllers and not having to wait till a new firmware version comes out.

But I have to give Rowdy at Zwift a big Thanks for helping with my problem.

4 Likes

I tried to use them again yesterday. They will not stay connected to Zwift on my Windows 10 PC. All other sensors work properly. I’ve tried holding power button for 30 seconds and connecting them one-at-a-time and letting the battery level become visible. I still have non-responsive action buttons and they continue to disconnect.

I’ve messaged Zwift Support and and am waiting on their reply.

Did you see that there is a new firmware update for the play controllers, 1.1.1
That update to the firmware fixed my problem.

I’m also windows 10 on PC.
I registered for the Tiny races today, at first I connected them and rode a few minutes in a random world with no issues but I had to reload Zwift as screen was unresponsive traveling to my race world. First race warming up no issues fully connected but as soon as the race started both started flashing etc so switched them off.
Race 2 reconnected them and was warming up for 5 mins again solid blue lights but once the race started both disconnected very quickly, again turned them off.
Race 3 decided to use only the left controller, worked perfect and light never flickered once.
Race 4 light never flickered again but it felt unresponsive so again I turned the left one off.

Will try them connected to my phone next time. Never used Bluetooth on my phone so hopefully it’s not to difficult

I am having the same left controller issues on AppleTV. Just updated to Firmware 1.1.1 and problem persists. How do I re-push the firmware? thanks! ride on

Don’t think there’s a way. If you’ve got it, you’ve got it.

Zwift Play firmware updated today, connects fine, but all buttons and steering and braking do nothing. Zwift Support says it’s a known issue. Not sure why I have Zwift Play if it doesn’t do anything (it previously worked).

1 Like