Zwift Play Controller connection issues

if this happens try this.

go to the pairing screen and unpair both controllers so the blue light on the controllers flashes.
then pair one and not the other, wait for the haptic feedback buzz and then tick the other and wait for the buzz. then exit the pairing screen.

I find this works every time for me

I second @Chris_Holton 's workaround below, but I’m also seeing that you’re experiencing the disconnect/reconnect issue that is yet to be fixed, which may be playing a role in what you’re seeing. We’ll be happy to do 1:1 support based on your setup and make sure there’s no other variables affecting your Play experience if you’d like to open a support ticket.

Chiming in. I’m running a Mac Mini M2 Pro w/ Zwift & Zwift Play on the latest greatest updates all the way around.

After the last update, for the very first time, my Zwift Play controllers connected quickly and worked wonderfully - not just once, but a couple of times - using native bluetooth connections.

Fast forward to this morning - I launched Zwift, and it said “preparing to update”. I got to the pairing screen and the play controllers weren’t connecting nicely as they had previously. This time they wouldn’t connect at all! The UI would show the R-controller unchecked, and quickly disappear, then reappear, etc. I was able to catch and click the checkbox, but that did not establish the connection before the list item would disappear once more.

Irritated, I checked for announced updates and saw there were none!

I was able to pair the Zwift Play controllers through my Android device using the Companion App.

Seems like there’s been a regression for some reason, and I don’t know why! :upside_down_face:

I still can’t get a 100% reliable connection.

Bluetooth 4 on Windows = the controllers rapidly appear and disappear on the pairing screen, it’s impossible to actually pair them for more than half a second.

Bluetooth 5 on Windows = the controllers appear and disappear more slowly and can actually be paired for a few seconds but are still unusable. I’ve also noticed that while connecting they interfere massively with Bluetooth headphones so I’m guessing they use a huge amount of Bluetooth bandwidth to connect and that’s possibly the root cause for many of these problems and why connecting one at a time works for some people (this workaround doesn’t work for me).

Companion app on Android = works great but often drops ALL Bluetooth connections when changing worlds or teleporting. Everything has to be unpaired and the controllers power cycled to make things work again. This means I always need my phone and keyboard nearby to fix the issue when it arises which defeats some of the purpose of the controllers.

Though this thread has been marked solved, but looks like people are still posting zwift play issues to it. I’ll add mine to the list.

I’m seeing all the same problems as others have discussed: 1) right controller continuously drops within minutes/seconds 2) haptic feedback buzzes randomly (thought thinking this is a warning that it is no longer connected) 3) right play controller would allow me to use the Z button but no on screen notification is displayed 4) Right controller seems to be connected but in devices menu, box is not checked

The controllers were connecting well & staying connected in v1.44.2 but before that and now in v1.45, lots of connection problems. I’ve tried some of the suggestions to keep them connected but so far nothing has been solid enough to work consistently.

Game-Zwift v1.45
OS-Win 10
Bluetooth-5.0 usb dongle
Play Controller-FW 1.1 (connecting via bluetooth when they do connect)
Bike-Wahoo Kickr Bike V2 (connecting via wifi)
HRM-Wahoo Tickr X (connecting via bluetooth)

1 Like

I am seeing some similar issues. Random buzzing (even when no other avatars near.)

The connection sometimes drops on one of them. Especially when changing worlds.

Yesterday the Zwift application actually crashed (can’t remember the last time Zwift actually crashed on me and I’ve been zwifting since 2016!!) This was on Windows 11.

The last few lines in the log file:

[18:06:36] [INFO] Auxiliary Controller attempting to connect to phone at: 192.168.40.86:21588 (secure)^M
[18:06:36] BLE : Sending DEVICE - BLE DISCONNECT ERROR [ UUID: 256272924377134 ]^M

And from other messages earlier in the log it seems that is zwift Play-R:

[17:53:42] BLE : Sending DEVICE - BLE RECONNECT [ UUID: 256272924377134 ]^M
[17:53:42] BLE : Component on “Zwift Play-R 802E” changed state from 0 to 0^M
[17:53:42] BLE : Component on “Zwift Play-R 802E” changed state from 0 to 1^M

Update for the Android users in this thread with multiple issues being reported.

Zwift v 1.46 addresses the issue noted below. Over the next few days, we’ll roll out v1.46 to everyone on Android. Please update when it’s available to you.

Same symptoms here on Windows laptop with Plays. 1.45, garmin HR strap via Bluetooth, Plays via Bluetooth, Kickr v6 power/control/cadence via wifi.

Sorry to say, but v1.46 did not fix this issue. Got the latest version today & was hopeful that the fix for this would finally work. It was promising at first as both play controllers appeared in the connection window quickly and were able to be ticked.

Went to Watopia, had two drops of the right controller in less than 1km. Each time, going back to the devices menu and rechecking the right controller box. By 5km, the right controller had dropped out 8 times. Each time it disconnects, I get the haptic feedback and a truncated message in the top menu display. I can power the right controller off then back on, it does reconnect but then drops quickly thereafter. I gave up & turned it off for the rest of the ride. The left controller stayed connected the whole time. Right before finishing, I turned the right controller back on and exited back to the home screen. It remained connected and I went into another world. Within 1km, it dropped again. Still in the devices menu but unchecked. Rechecked the right controller box & back to the game, drops quickly thereafter. Just for testing sake, I turned off the Wahoo Kickr Bike steering (connected via wifi) to see if that made a difference. Nope, right controller still drops.

Zwift-V1.46
OS-Win 10
Zwift Play FW-1.1
Bluetooth-V5.0 usb dongle
Bike-Wahoo Smart Bike V2 (connected via wifi)
HRM-Wahoo Tickr X (connected via bluetooth)

This sounds like an issue for Zwift support. Have you raised it with them?

Good news, I’m no longer pinned to the left hand side of the road…

Controllers won’t connect now and drop in & out on the pairing screen…

Lucky the price was only £100 and not £150 for them… I’d be feeling a bit miffed paying all that money for them.

You should work through this with Zwift support directly. Doing so would potentially help other users, as well as you, and it’s a beta product after all.

Thanks for the advice, but il add my post to thread dedicated to this issue, otherwise what’s the point of a support forum…

More voices, should mean more focus…

youtube-video-gif 2

1 Like

Going through it directly with support would let them suggest things and you can quickly feed back how that goes, in a much more direct and speedy manner than various people reporting slightly different problems here with Zwift not being able to engage as well with those reporting such problems.

Sure, post it up here, but also work it back and forth with Zwift support directly too.

With this many people reporting a fault, it’s very unlikely to be a single user issue.
I’d rather zwift fixed it on their accord, without using my time - I’m doubtful they are going to recompense me for me time or effort and frankly, im done on the bike now for the day.

Try this on PC:
Before start Zwift app, Power up PC and Zwift Play Controller.
Add both Zwift Play controller using the PC’s add Bluetooth devices.
Power up Zwift and add both Zwift Play controller in the app.
Worked for me.

I will contact Zwift support but wanted to see if others were experiencing the continued right controller connection issue after the update. It appears that others are still having the same connection issues with Zwift Play as they were prior to v1.44.2 and after (v1.45 & v1.46).

Given the issues are exactly the same in v1.46 as they were in v1.45, I doubt that they have been adequately resolved. I’m hopeful that in some future version, they will get fixed and stay that way and therefore be the easier & fun devices I expect them to be.

I continue to try different things to help Zwift isolate the issue. Things like changing the order of bluetooth connections, only connecting specific bluetooth devices, etc.

As far as I can tell, the current workarounds are to use the companion app to connect the play controllers. I tried another workaround today suggested by another user during V1.45. That is to connect power charging cable to the controllers so that they are charging, then use them in the game. I did two rides today, on the 1st one, the right controller dropped in under 2km and continued to drop until I turned them off. On the second ride, I turned on the controllers, plugged them into power/charging, then connected them as usual to the game. This worked and neither controller dropped the entire time during my ride. To me, that indicates some relationship between power and the ability to maintain a bluetooth connection.

1 Like

I’m having the same issue with the right controller.
Latest software / firmware versions of Zwift, Zwift Hub, Zwift Play Controller
I’m using a PC, Win 10
Play Controller connected via Bluetooth 5.0
Zwift Hub connected via Ant+
HR-sensor connected via Zwift Hub’s Bluetooth bridge

Right controller keeps disconnecting and reconnecting rapidly.
Left controller seems to work fine during a ride, but in the connection tab it also does fancy reconnecting rapidly.

Will try the charger hack during the weekend.

Why @Rowdy aren’t you using / offering to connect the Play Controllers via the Zwift Hub Bluetooth Bridge in the first place?!

1 Like

Hi all. Pc user. Bluetooth connection via usb dongle.
Same problem with my right controller always connecting and disconnecting.
All drivers and software up to date. Running w11.
I did notice the the Bluetooth strength on the controllers was jumping around on the controller connection screen on zwift.
I moved my pc tower next to the front wheel and the strength signal did improve.
I’ll ride again over the weekend see if it improves. Another option I’d try would be a USB extension lead, so I can have my usb dongle next to the controllers.
Regards.

My controllers have been acting pretty weird for a few weeks now (since the 1.45 update)

the pairing is a bit more flaky than it initially was, sometimes they pair automatically, sometimes one does but not the other. this is usually easily solved by unpairing them both then slowly pairing one after the other.

then in game everything works fine, i have the steering logo next to my name in the rider list and at the top banner. But every ride now about 30 minutes to an hour in i’ll get a message saying steering device deactivated (or something similar, the text is usually cropped as it won’t fit on the HUD) but everything still works fine, steering works, the buttons and arrows work. the only thing is the steering logo on the HUD isn’t there (weirdly it is still there in the rider list) and when i press the buttons the visual triggers don’t work. For example, when skipping a block in the work out the Y with the circle filling as you hold isn’t there or the Z for a ride on bomb doesn’t appear. if I hold it down long enough it still works but the visuals don’t appear.

this happens pretty much every ride now.