Zwift Play Controller connection issues

Also having many zwift play disconnects and reconnects during a ride with Win10 and Bluetooth dongle.
Long time no update for Zwift Play?!

Hello All,

Zwift Play firmware 1.3.0 is now in a phased rollout. At your convenience, please update your Play controllers to the latest firmware version using the Zwift Companion app (directions available here). Feel free to update this thread with any changes you notice after updating to 1.3.0

2 Likes

Courtesy of a big thunderstorm today I used a Macbook Air 15" M2 running on battery power positioned just about 40cm away from the controllers and the connection to them was very stable. Not a single drop out.

The Mac Pro desktop (a 5,1 model) with bluetooth antenna at the back of the case always doesn’t have the best signal strength so it seems. That’s my guess anyway.

I wonder what your scenario is like in terms of distance?

I use a windows 11 laptop, about 30 cm in front of my handlebars and using the internal bluetooth the controllers drop out every 30 seconds. Using a dongle I don’t get any.

I got the firmware update today.
I tried using the internal bluetooth on my laptop for the first time in ages (i gave up and use a dongle due to constant drop outs)
I got two drop outs in the first two minutes but then after that none at all. Worked perfectly, maybe the first minute or two were due to other thing waking up/going to sleep or something but either way seems to have made a big difference for me.

2 Likes

Just tried to update firmware on game controllers, says up to date but 1.2.0 shown

it is being rolled out over the next couple of days, you should get it soon

Just updated controllers and I get dead controllers to my pc, W11. They say trying to connect but it ends there. Can I roll back the update…

First one hour ride with 1.3.0 no disconnects and reconnects so far. Never had this since i got the play controllers. Good job

1 Like

It’s much much better but does still dropout.
Win11, b550 mb with intel bt
Prior to 1.3.0 it would drop out every 2-5 minutes and take 10-30 seconds to reconnect.
Since 1.3.0 I’ve gone on 3 rides.
Ride 1 - 2 hours 40 minutes, single dropout at 75 minutes, reconnected in ~3 seconds
Ride 2 - 1 hour 30 minutes, no dropouts detected
Ride 3 - 2 hours 15 minutes. Noticed 5 dropouts spread out. 2 of them I got the “steering disconnected” notice in the game, the other 3 I noticed the controller light blinking and loss of steering. In all cases reconnected in <3 seconds.

1 Like

Hello @Mr.Ferdinand, were your controllers still paired to your Zwift Companion device when you were attempting to pair them to Zwift? If this issue is still occurring, please reach out to us in Support and we’ll be happy to help.

I did end up getting them paired. I turn off and turn on my Bluetooth and rest my computer and unplugged and replugged in my Bluetooth tooth dongle and after all that they connected. Thanks for reaching out to me. I didn’t have one drop out for my 1:45 training ride…

1 Like

Zwift Play controllers arrived this week - updated firmware on Kickr Core but experienced at least one disconnect in my Zwift sessions. Updated controllers to 1.3 on its release date - using Apple TV and bridging via the Zwift Companion app on a Samsung S7 android tablet. Competed in the Tiny race series this morning and lost connection between the trainer and Zwift in 3 of the 4 races for up to 40 seconds (back to pairing screen and lots of clicking and SHOUTING). I am old and not wise about the tech but I was wondering if the quality of Bluetooth bridging was device dependant - about to borrow my wife’s iPad, try my android phone, etc or should I be looking at another underlying issue?

PS the virtual gear change is brilliant

Well, updated to 1.3.0, and connection issues got worse. I couldn’t pair the right controller at all, it just didn’t show up. The left one paired okay, and could navigate the menus with the D-pad, that was all I could do :-/

Did you recheck if the UPDATE was finished on the right controller?

I had to run 2 updates.

Update on Zwift Play with Apple TV using the Companion app to bridge the Bluetooth connections, oldish Kickr Core with updated firmware. Finally (maybe) starting to get to the underlying cause of the frequent trainer drop outs and instant stops . I was looking at the Bluetooth signal strength on the Wahoo app when the trainer was paired to it. At 1.5 -2 metres from the trainer electronics (on the handlebars or monitor shelf), the Bluetooth signal strength on an Android phone and on an Android tablet fluctuated between 4 bars and nearly no bars over a couple of minutes which may partly explain the trainer disconnects from Zwift. I have parked the tablet beside the trainer electronics and now see a steady 4 bar signal. No dropouts in a 45 minute ride this morning. Still a work in progress but the virtual gearing is so good that I am keen to persevere. I won’t be able to type messages during rides given the position of the companion app but I never ever have much to say!

I’ve been pairing with the companion app since the controllers would frequently disconnect/reconnect when pairing through my PC. I just updated to 1.3.0 and did a 1hr30min ride, trying to connect through the PC again. At first, it was a struggle to pair to both controllers, but eventually I got it. Then in the ride, the right controller would frequently disconnect and reconnect. I’m not sure if the left one had any issues at all. At one point I clicked the right shifter to shift up after it reconnected and it kept shifting all the way to the top gear. I fought against it with the left and eventually it stopped doing that, possibly when it disconnected next. After about an hour of riding, the whole bluetooth system stopped working, including the trainer and cadence sensor. I disabled and re-enabled bluetooth through the windows settings app and everything reconnected okay and I could finish the ride.

So for me, the 1.3.0 update didn’t seem to really make anything better. I’ll have to go back to pairing through the companion app to get a solid ride.

I got that too - i find if you unpair them both, then pair one, wait for it to properly connect (get the haptic feedback buzz if you have that or just wait a long time after it looks like it connects) and then pair the other and again wait for a while before exiting the pairing tile.