Zwift Play Controller connection issues

I might have jumped the gun here a bit.

Last couple of rides i’ve had loads of drop outs again. Might have to go back to using the bluetooth dongle which is a bit annoying.

Zwift Play controllers on the latest firmware, Kicker Core on the latest firmware. Everything has been working for about a month. Last night, after I finished a workout where the intensity adjustment worked, I had no shifting or gear display.

Today, while just riding around I also have no shifting. I’ve tried with the companion app and bluetooth and neither works. Also tried restarting and rebooting. Steering, menu, braking and ride bombs all work. If I start a workout, the intensity adjustment works. It’s just shifting that’s absent. Luckily I left my cassette on, so I could at least do my ride.

Disregard, unplugged and rebooted everything…again and shifting works now. Who knows. :man_shrugging:

Yesterday I had another issue that I’ve experienced before. The power was registering super low, so much so that I switched to the highest, 24th, gear, stomping on the pedals and still only registering like 150 watts when it probably should have been 400-600 watts. Finally, unplugging the Zwift Hub and powering it back on came back online registering the power correctly. I think I’ve seen this one other time but I can’t remember if it ever happened before getting the Play controllers.

Zwift Play Controllers will not connect after controller update to 1.3

When in the search screen both controllers show up with bluetooth strength at 5 bars. After closing the “search” screen and returning to the pairing screen, the controller section stays orange and says “connecting”. It never connects and turns blue. I have restarted the computer a couple times, the controllers are fully charged, and even hooked up to a power source. Very frustrating

I recently purchased the Play Controllers and posting here because things didn’t go as smoothly as I had hoped. The first issue (at least I think it was an issue) was the older BlueTooth USB adapter struggled connecting to multiple devices so I replaced with a new TP Link device that supports 5.3 and put it on an extender attached to the bottom of my Wahoo desk, placing it within a few feet of the Play Controllers. This appears to have helped, but I found that it takes 3-5 minutes for them to actually connect and stay connected. In the pairing screen, the controllers would bounce back and forth between the orange connecting and the blue connected box. Then after several minutes, they would settle down and I’d be OK. I saw here that there’s been a new firmware which I did just install and they now connect right away. Fingers cross that the connection is more stable. I’ll post back letting all know today’s ride goes.

… Update … 3/15/2024 …
For today’s ride, pairing was almost immediate. The controllers connected right away and stayed connected throughout the 90 minute ride. I’m happy to report that there were no issues during the ride.

On a side note, in the companion app, one must wait between ride-on bombs. Holding the z button on the controller drops ride-on bombs. I can now drop 2x the ride-on bombs than before :smiley:

A solution that works for me (a Windows user of Zwift)… perhaps similar to Glen’s

I had terrible frequent disconnection issues with my play controllers but I wondered if the USB receiver in my computer might not as capable as what the Play controllers use. I purchased the following and after installing and many rides and miles later I have not had a single disconnect since. I had Bluetooth 4.x in the PC at it came from the manufacturer but now with this I have Bluetooth 5.3. It says it’s for Windows so I don’t have a similar answer for Mac users.

TP-Link USB Bluetooth Adapter Bluetooth 5.0/5.3 Dongle Receiver (UB500)
Follow installation instructions and disable existing internal Bluetooth function before attaching and installing UB500 and downloading/installing their driver software for the device.

I can’t insert url’s but it seems you can go to Amazon and search for: B09DMP6T22

Hope this is helpful for others.

David

For Mac the addon dongles for Bluetooth won’t work. You can only use the MacOS supported ones, which are limited to what Apple builds into their machines.

This is Apple being intentionally nasty, just as they refuse to support newer than RX6900 GPUs for Intel Macs.

The latest @zwiftalizer video explains how to get macOS to prefer the dongle

1 Like

this also explains what you need to do to use the dongle on MacOS

Excellent - I will try that.

I successfully updated to version 1.3.0 last week. Now both controllers do not work. Zwift recognizes them (recognizable also by the symbol while riding) and the controllers also light up blue. Even after switching the controllers off and on several times, they do not work. I use Win 10 and internal BT-Connection.

Hello @Ge_Ka, welcome to the forums. Are you still experiencing this issue on the latest version of Zwift? Your most recent activity appears to show recorded button presses on the Zwift Play. If you are still having issues, could you confirm what the Controls tile in the Paired Devices screen shows for your Play controllers? (e.g. Does it show battery level for each device? Does it say “Connected”?)

Now it seems to work. I unpaired both controllers from my Win10-device and paired it again (in Win system settings). But sometimes it takes a long time for the controllers to be found/connected within the app.