Zwift crashes after Let's Go

Hello, been having major frustrations for a while with not being able to load up Zwift. Using admittedly a fairly old PC, but it worked, albeit with slow frame rate (10-15 fps) - decided to upgrade GPU to get quicker frame speeds, so installed a 1050ti, which required also upgrading the PSU, and while at it installed an SSD with Windows and Zwift moved onto it to speed things up - no problems, works fine great on everything, no probs shown on DxDiag or online GPU testers. But on opening Zwift, I get to the ‘Lets Go’ screen, press the button, it brings up the Blue loading screen with the messages for about 25 seconds, then closes. I’ve tried reinstalling gpu drivers, rolling back to old ones, reinstalling Zwift, allsorts, but nothing. Opened a support ticket, but nothing suggested works yet. Even reinstalled the old gpu card, and that still works, and tried another (fairly mediocre but above minimum standard) gpu, and that had the same problem. Seen a few mentions of similar problems on various forums, but no solutions that worked…
CPU: AMD A8-5500
Memory: 24576MB RAM
Card: NVIDIA GeForce GTX 1050 Ti

Any suggestions? Thanks in advance!
Dave

You’d be best posting your launcher_log.txt file to see what it says.

Thanks Dave - I hadn’t seen this previously - what’s the best way of posting the file here - it’s pretty big (and forum will only let me upload image files), presumably not pasting the text onto here…?
Cheers,
Dave.

Might be better with a regular log.txt file actually, rather than the launcher logfile. Anyway, stick it in an unlisted Pastebin and post the link.

Thanks Dave - not used that before, hope this works:

Not sure how these link - does it matter if not embedded properly? I know very little about coding, just pushing pedals…

[Link]()

Not embedded but the link can be used.

Is that the full thing? Based on a comparison with my own logs it appears to cut off right before the game resizes to your monitor’s native display. There’s also a mention of a preferred monitor with weird coordinates. Have you got a second monitor set up on this computer that Zwift is being confused by?

Also, when you say you’ve reinstalled the GPU drivers have you done that manually with a download from Nvidia’s website, making a clean install? The log file suggests you’ve got a very old driver installed, from 2017.

Hi Dave,
For some reason it missed the last line, but no more:

[19:06:29] ThreadedLevelLoadDoneCB()

You’re right, there is a second screen - is this likely to be an issue? It didn’t cause problems with the ancient card I was using…

I’ve reinstalled the drivers a number of times - mainly by tracking them down manually on Nvidia’s website, using the DDU removal software then a clean install. There were issues with an Error 43 on the newest set of drivers, so I rolled back to an older driver, but updated with the latest Gameready driver, as someone had recommended, and that seems to work fine now for everything except Zwift…

1 Like

In theory the second screen shouldn’t cause a problem at all (I did an endurance event a whole back with Zwift on duplicate to a monitor and a TV) but there could be something weird going on there. What are the resolutions of the two displays?

I still don’t really get why it thinks you’re on a 2017 driver though.

No, its odd if that card is causing problems with two screens - the old one even let me two sessions/accounts of Zwift simultaneously a couple of times when my wife’s races clashed with mine. I’ll check the monitor sizes shortly - its in the garage, and I’m juggling virtual meetings this morning in the house…

1 Like

When you reinstalled Zwift did you bin the folder in Documents? If not it’ll preserve your prefs.xml file. In there are flags for your resolution settings and preferred monitor. Maybe that’s why putting the old GPU back in works fine, because the old driver marries up with what Zwift thinks you want to do but the new one does not.

Almost certain it’s that based on what’s missing from your log file versus mine.

3 Likes

From left to right: your file, my main PC, my laptop. Can clearly see your resolution preference isn’t being set after the profile adjustments are made by the game based on graphics card etc.

Then after your last line (and crash), mine are resizing the game to the native resolution of the display:

2 Likes

That’s interesting - so do you think I should uninstall Zwift again, then delete the folder and reinstall?
Thanks very much for your help on this, it’s much appreciated - sorry for the slow responses, quite busy working today…

Try just moving prefs.xml to your desktop to begin with. The game should recreate it when it notices it’s missing. You’ll start back up in windowed mode etc. See what happens.

Sorry Dave, that didn’t seem to work (and the file was called prefs.xml.invalid?), So I uninstalled, deleted every possible trace of zwift I could find, and reinstalled, with fresh gpu drivers just for good measure- still nothing…:see_no_evil:

How about setting Zwift to windowed mode?

you can toggle Fullscreen in the prefs file, try 0 or 1

0

Huh, where was this? It shouldn’t be called that.

Looking around it’s apparent that this prefs thing is still the problem. The game is unable to create a prefs.xml file on install/first run. Do you have any cloud sync installed on the PC, such as OneDrive that syncs your Documents folders?

Uninstall Zwift, delete the entire Zwift folder within Documents, reboot the PC to check the folder is actually gone and then start over with installing Zwift. Is that what you did?


1 Like