Perfs.xml file can't be created during startup

Hi
I used to run zwift on win10 which was working fine previously. I have recently changed my SSD and installed all the software after the upgrade and not able to start zwift afterwards. After a bit of research, checking the logs, I have realized that the problem could be prefs.xml file. Zwift can’t create a new file nor update the existing file during the start-up and logs clearly showing that the software can’t find the file. Following past advises from the forum, I uninstalled and deleted all related content including the zwift folder under documents and re-installing, I couldn’t succeed. Running the zwift-preferences isn’t solving the problem either. If there is an existing file, zwift simply renames the file to ‘prefs.xml.INVALID’ and returns to the start-up screen, expecting me to click ‘Let’s Go’ as if it will be able to.

Any help appreciated, Thanks

Do you have OneDrive or similar synchronising your Documents folder? If Zwift cannot create prefs.xml or read an existing file it could be something external to Zwift blocking it. Try pausing OneDrive in that case before you launch Zwift.

Also, have you tried running Zwift as Administrator to see if that makes a difference?

As you write zwift-preferences won’t help you in this case - it just reads the file if it’s there and lets you make changes to it.

1 Like

Hi Jesper,

Thanks for the reply.
No, I don’t have any synchronizing folders and OneDrive is disabled from the start-up applications. I tried starting up as an administrator but that didn’t help either.

Thank you