Zwift Crashing / Won't Open

So I’m about to hit week 4 on my “Build Me Up” plan, and I have been using Zwift for a few months now with no issue. Today, the second I hit let’s ride, it starts to load, and then nothing, blank back to windows.

It worked yesterday, I turned the Laptop off, I turned the Laptop back on, now it won’t work.

PC runs Doom 2016 so it shouldn’t be a minimum specs issue, and I’m seeing other posters with a similar issues but no satisfying responses. I’ve already uninstalled and reinstalled with no luck.

Does anyone have any hints? Was there an update I just didn’t see today or something?

Edit - Some details as recommended by the FAQ:
Playing on PC, OS Windows 10
Version of Zwift: It should be the latest, the launcher handles this for me
Companion version or location not relevant, it’s working on another PC, just not my Zwift PC
Trainer is Cycleops connected through ANT.

Hi @Waffles_McGregor, welcome to the forums!

There was a windows update recently. Something must have changed, did you get the new version of the Microsoft edge browser, I believe the launcher runs off of it.

1 Like

Perhaps, some of those updates go without me realizing, but usually I know because I hit “update and shut down”. Regardless, I would think the latest version of edge should be compatible with Zwift, right?

could be the issues with GPU drivers? @Gerrie_Delport maybe this is why you had a crash recently?

1 Like

Anything is possible. :thinking:

So it looks like no, I did not get those updates. Upon checking for updates I was presented with a few major new updates, which I have now applied. Still crashing.

I suppose I could check for new nvidia drivers… I’ll try and check back.

Ok, so I updated to new GeForce drivers and it works now. So bizarre. None of the updates that were allegedly the problem I actually installed.


Thanks for the ideas.