Zwift Companion app on iOS16 won't connect [September 2022] [SOLVED]


Recently upgraded to an iPhone 14 pro which included a reinstalled of apps used. Since this, the latest version of the Zwift companion app won’t connect when zwift is running on the Apple TV… My old iPad running iOS 16.1 beta’s connects just fine.

The only difference I have been able to find is iOS permission for local network access. On the iPad, this option appears for the companion app and is enabled, BUT on the new iPhone install, there is no permission option for local network access…

To test my theory, I turned off local network access permission setting on the iPad, and using the companion app on there iPad, it wont connect to Zwift… Turn the permission setting on, and it’ll work.

Would seem the companion app when started is Not directly requesting the permission, so have no option to approve/deny.

Zwift companion app is v3.39.1 on iOS 16.0.2


Make sure your iPhone is on the same wireless network as your AppleTV.

The only permissions the Companion app might need is Bluetooth but only if you are bridging devices through it vs connecting directly to the AppleTV.

They are one the same wifi network and even tried with airplane mode (and wifi on) just to make sure…

Other interesting thing, in the companion app setting, under device connection, you need to toggle the device connection setting on/off to get the permission popped to allow bluetooth access, even if it’s on by default. Again, the companion app should ask for this permission when starting if enabled

On my phone the Bluetooth toggle for the Companion app is off/disabled: Settings > Privacy & Security > Bluetooth. However, within the Companion app: More > Settings > Device Connection it is on/enabled (didn’t know this existed).

As is, Companion app connects w/out issue. I shut everything down, disabled the Device Connection setting in the Companion app. Restarted Zwift and the Companion app still connected w/out issue as I expected since I believe both the aformentioned iOS and Companion app settings only matter if bridging sensors via the Companion app.

1 Like

In iOS 16.x under Settings > Privacy & Security > Local Network do you have an option for companion app?


There is one for Zwift and it is enabled, but that is because on rare occasions I run Zwift on my iPhone.

Exists on my iPad (under OS 16.1betas). Also, on my wife’s iPhone, its also there and her’s connects with out issue same as my iPad… Yet my clean installed iPhone, its missing and won’t connect to Zwift on local networks

Your iPad is likely running iPad OS and not iOS, as such there are likely to be differences.

My iPhone is a 12 running iOS 16.0.2.

as a developer, I’m well aware in the differences between the two, however, this particular setting is across both platforms. My wife’s iOS 16.0.2 install on an iPhone XR has the setting enabled… Disable the setting and IT WONT connect to Zwift… Enable, and connects fine

I have the same issue. The companion app on iOS 16.0.2 on iPhone 14 doesn’t connect to the game.

An iPad running iOS 15 worked fine.
I too do not have the companion app in the local network list.

1 Like

+1 for problems connecting when using Companion on an iPhone running iOS16. My iPad Pro is still on iOS15 and connects without issue. BTW, adjusting bluetooth settings in the app makes no difference for me.

Hey all - thanks for flagging this up. We’re looking into this issue.


Thanks. Hopefully you can resolve this very very quickly

The only very quick solution within your control is to downgrade the device to iOS 15.

Curious… Is this problem limited to iPhone 14 w/iOS 16.0.x?

I have yet to have any Companion app issues w/my iPhone 12 and iOS 16.0.2

< Must be… I did a clean install on my old iPhone 12, and connected fine… No dice on iPhone 14

Companion hasn’t connected for me in weeks. Using iPhone SE (2nd gen) on iOS 16.0.2 currently. I can’t recall whether it was iOS 16 or zwift 1.29 when the issue first popped up.

1 Like

Double check you’re on the expected/correct Wifi network.

Have the same issue on iOS 16.0.2/iPhone 12 Pro Max - the option to use ZCA is grayed out on my PC (started after the iOS/iPhone updated to 16), and ZCA doesn’t show up in the local network settings page on the phone. Everything else is working fine and both PC/Phone are all on the same network/channel/frequency. Tech support flagged my account as having this issue as well. Thanks and hope for a quick fix/update for this.

1 Like