Zwift Companion app on iOS16 won't connect [September 2022] [SOLVED]

iOS 16.0.2 on iPhone SE 2020 + AppleTV: CA connected as always and worked fine during the ride, but towards the end it got stuck (I was still moving but on CA I wasn’t). Wanted to take a final screenshot, but CA didn’t respond to anything. Force-quit CA, restarted it, it didnt connect. Tried several times, no connection. Logged out of CA and back in, no connection. Restarted the iPhone, no connection. Saved my ride on AppleTV, force-closed, started a new session on AppleTV - and CA connected instantly.

Fwiw, logged into app tonight with iPad (Pro 3rd Gen)/OS v.15.7, and have the same issue. No love from the PC setting to use ZCA…still grayed out.

Feature request: let us plug in the IP addresses of our devices as a worst-case manual override. Seems like there is a lot of gimmickry for auto-discover or whatever to work. I know this feature request isn’t for everyone but at some point, being able to plugin the IPs for my companion phone & apple watch into my ipad would at least rule out ‘discovery’.

My watch disconnected five times on my ride today and yes, my iphone, ipad and apple watch are all on the same AP, SSID, layer-2 broadcast domain and IP subnet.

Hey all - we’ve been having problems reproducing this issue consistenly here at HQ. l us

Some of you have been good enough to note which specific Apple device model number and the specific iOS version you’re using. Moving forward - we’d like to ask you to tell us those two bits of information please. Thank you.


@Mark_Hulskamp @Kaz_Sam @Adrian_Ward1 @Logan_Rupard @KurtF @Kerstin_K_C2rower

Looping back to something in the first post upstream. There’s an iOS 16 bug being reported in the Apple developer’s forum where the local network access toggle in iOS Settings isn’t working as expected. Would you try this workaround to see if the local network toggle appears works after you reboot the phone?

Turn off your iPhone, turn it back on again, and launch the existing app, and you will see the local network permissions dialog.

Nothing changed for me. Followed instructions to turn off phone (which I’ve done several times prior), relaunched app (also turned off cell service so only on wifi), and didn’t see anything new for the Companion app in settings (no network toggle, nor did it ask for it). I also tried resetting the network connection on my phone w/o success. :frowning:

No go for me. I also tried to install companion on my iPad running iPadOS 15.7 with it not working either. It does not prompt for local network access on new install.

Nothing changed for me… Also running latest iOS 16.1 beta to see if made any difference. I also didi a clean install on my older iPhone 12, running 16.0.2 and the app connected BUT is also missing the use local network permission

Didn’t work for me either.

I have this same problem with my Android Galaxy Note 8 and cannot seem to fix it.

1 Like

iPhone 13 running 16.02.
Going settings → companion → doesn’t have a local network option.

Rebooted phone and it didn’t prompt/ask for local network access when I re-launched.

This is sporadic though too: 30% of the time this works AND it’s not just the iPhone app, it’s the watch app too for me. Unless I have it up in front of me for like a minute, the watch app will disconnect.

I reported this issue about 10 days ago and I still can’t get the Companion app to load into ride mode.

iPad mini (5th Gen) on iPadOS 15.7
iPhone XS on iOS 16.0.2 (I was also having trouble on iOS15 which is why I updated to the latest version).

I hope you are able to fix this soon.

1 Like

@shooj Any progress on this?

Same issue here, have tried all recommended fixes and still nothing.

iPhone 14 Pro Max - 16.0.2

Not sure this is implied by @shooj comment that they haven’t always been able to replicate, but question is, does anyone who has ios16+ installed NOT have this problem? ie. odds of having an issue if I upgrade my phone’s os ?

As mentioned above I had the problem only once (iPhone SE 2020, latest iOS, AppleTV 4k 3rd gen). Logged out of Zwift and started a new ride - no problems ever since.

1 Like

iPhone 12 mini here and no issues w/iOS 16.0.x connecting to Zwift on AppleTV 4K (1gen).

I’ve tried connecting to my Apple TV 4K (1st gen) with both an iPad and my iPhone 13 Pro Max - all running ios16 and it’s not connecting. It had previously (just put my bike back on the trainer now that the cold weather has returned). Tried reinstalling Zwift on the Apple TV as well as reinstalling Zwift Companion on the iPad and iPhone. Still no go.

Still trying to connect Z Companion to my iPhone 14 Pro Max, now running 16.0.3 while running Z on Apple TV 4K 1st Gen. This is beyond frustrating.