Zwift Companion app on iOS16 won't connect [September 2022] [SOLVED]

Same issue. Mid ride, connection drops out often. Quit and restart and then it works again for a bit before dropping. Never had this issue in the past. New phone/OS is only change.

Zwift Companion 3.40.3 (1329)
IPhone 14 Pro - iOS 16.0.2

Still no love here after another iOS update and several Win10 updates. I think this is a combo issue with iOS 16 and Zwift, even though the phone restart doesn’t invoke the network access dialogue.

As noted in the link above to the Apple’s dev site, this is a known issue, and seems to also be a Zwift issue as other hardware/software I’ve installed since updating to iOS 16 shows up in the ‘local network’ page on phone. It seems that Zwift thinks it’s already asked for permission once and gained it (prior to the update), but won’t ask again as it thinks it’s already there, but it’s not. Anything Zwift? Good/bad/ or otherwise?

1 Like

I’m sure your devs are working this bug out, but I did run through the FAQ here to determine if it was something on my end at a lower level, and having reset the location/privacy setting, reinstall/restart, etc., I still don’t the get the prompt to give local network access to the Companion app. In my research, this also affect some other apps and larger companies. Is there anything that gets shared by Zwift with another app that would mimic the trigger to request network permission? Netgear had two apps and once their older one was uninstalled the more current one would work correctly (many had both apps installed).

Something broke in the code running on iOS 16 and I wonder if it has something to do with multicast code settings, that were apparently not always strictly enforced prior, but are in 16. Odd that it also doesn’t affect everyone, which makes it harder to hunt down. Just thinking out loud here as a former software tester. I’m now on 16.0.3 with no changes.

h t t p s://developer.apple.com/forums/thread/663875 (remove spaces)

h t t p s://developer.apple.com/forums/thread/663858 (remove spaces)

1 Like

Still broken on iOS 16.1 RC which comes out on Monday. So definitely points to an issue with the companion app not validating that it has access permissions to the local network. It shouldn’t work without that setting present which is what we are seeing

1 Like

Got the issue here:
iPhone 12 (MGJA3B/A)
IOS 16.0
Latest version of ZC.
Latest version of Z on PC.
Same network confirmed.
Phone will not connect to the game running on PC. Worked fine before upgrading to IOS 16.
Do we have any more workarounds?

Maybe not everyone’s favorite, but… (assuming not iPhone 14)

May be an option, but don’t want to deal with the backup/restore, and losing important apps/data used for work if something goes wrong.

OTH, I was thinking about buying an older, unlocked iPhone on eBay using 15 or older iOS just for Zwift. Come to think of it, I may have an old Droid phone laying around here that I can use just for that. Mmmm…

Requires Android 9.0 or higher

Cheers Paul. It does seem the only option.

I also have this problem on IOS 16 and Windows 10 can we get an estimate for a fix for Zwift developers? Thanks

1 Like

But actually…I’m on day 26 of not being able to connect my CA to Zwift. I’ve even tried to set it up with my Apple TV. There is an option in the pairing screen to connect Companion app but when I do, it just shows an error. Never mind that Apple TV doesn’t seem to pick up my Kickr Core.

I’m losing my joy for Zwift.

Running companion on iOS 15 (or anything but 16) seems like the only option at this point. Probably only an option if your device is older than an iPhone 14. Try asking support for a refund or try some free trials of other services.

I was actually on iOS 15 when it stopped working. I upgraded to see if that was the problem.

Good idea about asking for some kind of compensation. I’ll definitely ask when I follow up with them.

Problems with Companion on iOS 15 are likely unrelated to problems on iOS 16. When running iOS 15 the problems may be resolvable with some troubleshooting; when running iOS 16, you may be stuck until a fix is released by Zwift.

I had to borrow an iPhone xr for a bit and companion game wasn’t working when riding. iOS 16.3

Went back to my s21 ultra and the game doesn’t load anymore when riding. It was working before on my s21 before trying the iPhone companion

BeN

@shooj Can we get an update on this issue? A new companion app was release today on iOS, and issue still exists… Again, looks like Zwift can’t be bothered to address bugs!

2 Likes

I’m using an old Apple SE iPhone without a Sim to communicate from my devices to an Apple TV via the Companion app leaving it on OS 16

Sorry that should be iOS 15

1 Like

Hello everyone,

This issue has proven to be much deeper than surface level. It is not affecting all Zwifters with the Companion app on iOS 16 or iPhone 14, but this does seem to be a common thread amongst the reports we are receiving. We are still working on rectifying this for all affected Zwifters. Thank you for your patience.

2 Likes

Quick update: installed iOS 16.1 update on iPhone 12 Pro Max and no changes w/ respect to Zwift connectivity. Restarted, uninstalled/reinstalled Zwift with same issue still present.