Zwift Companion app on iOS16 won't connect [September 2022] [SOLVED]

Had no connection between Zwift and my IPad using the Wahoo direct connect dongle. First thought, that is an problem with by rooter.
But it seems to be a problem with IOS.
On my Phone I have IOS 16.1 and on the IPad IOS 16.1 first, now 16.2 beta and always the same problem, that I do not find the direct connection dongle.


I installed the app "Discovery - DNS-SD Browser

After opening the app on the IPhone, the direct connection dongle is shown on the IPad.
Now I have to open the app prior open Zwift and have no problem. Perhaps this will help you too.

Magically my iPhone connection with Zwift started working again. Oddly enough, the Companion app doesn’t show up in the Local Network settings and didn’t request access. Go figure. Nothing has changed since my last post.

Just started having the same issue this week using an iPhone XS Max iOS 15.6.1- have checked all the various Bluetooth settings but companion starts and hangs on loading the map screen and shows “no devices connected”. I can still connect to all devices (wahoo kickr and garmin 945) on the same phone in the Zwift app as well as the wahoo app but for some reason companion stopped picking everything up

1 Like

I have the same issue since i switched to my new iphone 14 pro max / ios 16 (recently updated to 16.1 and issue persists). Worked fine on my previous iphone 11 pro max

1 Like

Any movement yet? It’s been over 30days since this issue was raised and no resolution yet. How not to treat your paying customers…

I was just about to write the exact same thing. I’m so frustrated not being able to see a full map, not being able to connect my HR and not being able to talk/interact with the game.

I last emailed them on Oct 25th. Got a very cheery message from one of their reps who said they are still working on a solution and to come here for help. Lol.

A couple of things to try if you haven’t already, and if you have, try them again, maybe more than once. I had the same issues since the 16.0 Apple/iPhone update, and then one day, it started working again, for reasons unknown.

  1. Uninstall the app on your iPhone
  2. Turn off Cell and only use Wifi
  3. Restart phone, confirm Wifi is only connected
  4. Reinstall app
  5. Restart phone again (Wifi should still be your only connection)
  6. Load/run Zwift Companion with Game on PC - see if it connects
  7. If not, repeat above steps again (tedious, I know…)
  8. Also check your Wireless Router’s firmware and also try restarting your home network (modem and/or router)

The steps above are the only thing I did between it not working and working, and probably shouldn’t be working as ZCA still doesn’t show up in my iPhone’s ‘local network’. Report back if anything’s changed.

I appreciate your efforts.

I have tried doing the uninstall/install trick again with no success. I had already tried to connect my phone to AppleTV app where there is actually a button option to connect the ZCA. Just got the error image (phone crossed out) so it isn’t connecting. I’ve disconnected and reconnected my wifi/routers.

This seems to be something on Zwift’s end. iOS16.1 has already come out. I’m not going risk losing my whole phone to downgrade. Zwift needs to figure this out already.

Agree - Zwift has dropped the ball on this one. I’ve had several apps that broke with the 16.0 update, and all have released updates to fix a similar hardware connectivity issue. One of the apps hadn’t been updated in 3 years and they still managed a timely update/fix.

1 Like

I wish people would stop offering that advice… It doesn’t work on an iPhone 14!

1 Like

Another Zwift update, another Zwift companion update, another iOS update and another day and still not fixed

@shooj @Rowdy

1 Like

Hi all,

Just in case this helps anyone else…

I got ZC working on my iPhone 12 running IOS 16 this evening.

First, I tried disabling Cellular, switch off phone, switch back on, no difference.

I then uninstalled Zwift (the main Zwift app, not ZC). This made no difference either.

I then uninstalled ZC, switched off phone, switched back on, reinstalled ZC and boom, it’s working.

Switched cellular back on and it still works fine. Switched Wifi networks and back again and all good.

I think the secret sauce was to uninstall, switch phone off/on (not 100% sure this step is necessary), reinstall app. Maybe the fact that I uninstalled the main Zwift app from my phone helped? I don’t know.

Good luck!

Doesn’t work on iPhone 14…

1 Like

Tried all those things again tonight. Because who knows? Maybe it would work…

Still doesn’t work. It’s almost been TWO MONTHS without ZA. This is so unacceptable.

Ok I finally got ZCA working!!!

I had some time this morning to troubleshoot. Here are some of the things I did.

  1. Uninstalled and reinstalled both Zwift and ZCA/restarted my phone/iPad multiple times
  2. Downloaded that Discovery app (I really don’t think that did much tbh)
  3. Unplugged and plugged in my modem and router
  4. Upgraded to iOS 16.1.1

I’m not really sure what actually made it work in the end but the last thing I did was upgrade the iOS.

What a gong show.


I spoke too soon. Couldn’t get it to work again this morning! Grrrrrrrr!

I’m having the same issue and have been going crazy since getting my new iPhone 14.

iPhone 14 Pro
iOS 16.0.3

I’ve tried all the steps outlined in this thread before I finally found this thread today. Guess I just had to fine tune my Google search to include “iPhone 14 Zwift companion”.

Hopefully Zwift will address this soon!!!

Same issue with:
Latest Z on PC
PC up to date
iPhone 13 Pro
Latest iOS 16.1.1
Latest version ZC

PC connect to network via Ethernet cable
iPhone on same network via Wi-Fi

Oddly, if I run z on my iPad and open ZC, it connects without issue.

Same issue the others are reporting, and it’s been about a month for me. I have an iPhone 13 Pro Max and just installed iOS 16.1.1 this am, but Zwift Companion hasn’t been working for at least a month (I hadn’t tried it before because I was riding outside).
If I connect with Zwift directly, it connects with my kickr and climb, but if I try to connect with Zwift Companion, it says on Zwift that the phone is connected, Zwift Companion will give me a “loading maps” icon on my phone, but nothing ever happens beyond that, and the orange/red bluetooth icon on the upper right says no devices are connected. I have tried using airplane mode, tried restarting, deleting and reinstalling, etc. My bluetooth on my phone says it’s connected to the devices … please help.

1 Like

I was worried a bit about this but upgraded my SE ios to 16.1.1. No issues really, but I’ve always found that it is hit or miss connecting CA with the PC game. The trick that always worked was to disable and then re-enable Wifi on the phone (of course making sure computer and phone are on same network).

1 Like