iOS Companion app 3.29.0 (1158) issues [SOLVED]

Hi, is anybody on iOS having trouble with the latest companion app release 3.29.0?

After updating I had trouble launching the app on an iPhone 12 and iPad Pro. Both devices had a white screen on app launch, when closing and re opening the app went to the main page but I couldn’t get it to go into the event I was doing, so no chat or ride on giving etc.

Both devices on the correct Wi-Fi with 50/20mbps + connection speed test result.

Anyone else seeing similar?


I get this if I’m using Apple TV Zwift a lot.

But it always works if I use Mac OS Zwift.

The only other thing I can think of is too many connections to wifi? It’s hard for me to troubleshoot.

I only use Apple TV to zwift on, so have to use the companion app just for the chat/ride ons
I don’t have any Bluetooth devices bridged by the companion.

Up until this last update , the worst it’s ever done was drop out during an activity requiring me to either close and reopen the app or leave it alone ( usually that’s if I’m in a tough block) and it returns.

Tonight 2 different devices were showing the same symptoms, I ended up having the live stream of the event I was riding in playing on the iPad along side me so I could keep up to date on the comms.

Hi, I run Zwift on Apple TV and use the companion app on my 3rd Generation iPad Air but the last few days since updating the software the companion app on my iPad is unable to open up the map when doing a work out. It tries for a few seconds before disappearing. Otherwise the companion app seems to be fine. I managed to get the map to appear tonight on my iPhone companion app but its has since updated to 3.29.0


I have seen the bug with the map on iPadOS. The map shows up for a couple of seconds until the ride-on circle completes. Then the map disappears. The laptop still shows the companion app as connected. This doesn’t happen on my iPhone (iOS)… the bug looks like it only affects the iPad.


Having the same problem with the map disappearing on iOS.


Same here, too. Multiple iPads, no map after a brief flicker. Works on my iPhone and my Google Pixel. Definite appears to be a bug with the iOS app. Running Zwift on Apple TV , haven’t had an issue, ever, with the game running on that device.


I tried putting my iPad into airplane mode and using my iPhone 12 and that behaved the same as the iPad ( it’s also on this update)

If the Apple TV is off or I’m not zwifting the companion appears to work normally and I can view upcoming events and friends/followers activities etc.

Similar issues with ZCA, struggling to launch at times but just holds on blue screen?

1 Like

Similar issue here with my iPad mini. Map appears for a second on companion app and then disappears, since update. Yet, on my iphone, companion app works fine. I use apple tv for zwift and ipad mini for companion app.


My exact same config, with the same problem.


Same problem here with Companion on iPad Pro and AppleTV 4k. Map appears briefly, then disappears off the bottom of the screen. Same setup worked fine earlier this week, and same iPad performs fine on other platforms. Latest Companion on iPhone works fine too, even on same AppleTV.


Was getting white screen when doing workout (erg). Now app launches, then when map begins to load it quickly switches to workout page then the workout page crashes taking me back to the home page. I use to be able to toggle BT and the app would work but this no longer is true.

I’m running the CA on latest IOS on an iPad while Zwifting on Win11.


I’m having the same problem on an Ipad Air, map disappears after a couple of seconds. Never happened until very recently.

1 Like

I’m having the same problem - Apple TV tries to pair with zc. It blinks and appears to connect then blasts back to home page on zc. This started yesterday 11/4.


Same for me, too. Apple TV, iOS on a current iPad for companion app. Worked fine since I started using the combination, well over a year ago. Problems started 11/4.

1 Like

Yes. I had this problem today with my iPad. Redrum.

Thanks for the reports everyone. We’re investigating. Questions:

  1. Is anyone on this thread not using AppleTV to run the Zwift game app? Please let us know what OS platform if not ATV.

  2. Would someone kindly screenshot the white screen / missing minimap? Are we talking about the same thing, or two different symptoms?

  3. We had a report that the Companion app returns to normal if you’re logged out of the game app. Would someone else corroborate? Thank you!

  4. Is anyone running the Companion app on something other than an iPad? How about iPhone or Android devices?

  5. On that white screen on launch symptom: does it recover once you choose a world (on the game app) and drop in to that world?


On iPhone with the latest companion update, I have not had any issues so far. Not sure about iPad though.