iOS Companion app 3.29.0 (1158) issues [SOLVED]

As mentioned in my original post:

a). Launch Zwift on win11. Log in. Tickr HRM, KICKR BIKE pair up via Ant+. Choose world, course, and workout. Begin pedaling.
b). Launch CA on iPad running latest IOS. CA opens to Home Screen, after a few moments the Map screen shows briefly before the Workout Screen appears momentarily then closes reverting to an active Home Screen.
c). Wearing Apple Watch recording Indoor Cycle activity but only paired to iPhone which is not powered on.
d). Applet TV connected to local network but not in use.
e). Wahoo Headwind in use paired to Tickr.

Last week the behavior was different:
a). Launch Zwift on win11. Log in. Tickr HRM, KICKR BIKE pair up via Ant+. Choose world, course, and workout. Begin pedaling.
b). Launch CA on iPad running latest IOS. CA opens to Home Screen then the Workout Page would appear as a white screen and stay that way.
c). Toggle BT on my iPad and relaunch CA which behaved normally for rest of ride.
d). Didn’t own Apple Watch at this time.
e). Apple TV connected to local network but not in use.
f). Wahoo Headwind in use paired to Tickr.

The only difference in set up between the 2 scenarios noted above is that I started wearing an Apple Watch 7 paired only to my iPhone. The iPhone is never powered on.

@brumohr
Thanks for taking time to fill in more details!

Everyone else: is an Apple Watch a factor in your setup?

Hello.
Same issue as others described: map loads and then disappears. Today CA worked on iPhone but not on iPad or iPad Air. iPad was V15 so I updated to V15.1 - still didn’t work. No issues yesterday.
I am running Windows 10 with an Nvidia GPU card.

I have also seen “blank” activities when scrolling through my co-Zwifters’ activities on CA for last couple of days.

Thanks
Maggie

1 Like
  1. I’m only using ATV.
  2. I have not experienced any white screen or missing mini map since I can’t pair with zc.
  3. Companion app connects briefly to game app when pairing is clicked on game app. You see the map screen briefly with red Bluetooth symbol in upper right on zc. Then the screen blinks and returns to home page on zc.
  4. Only using iPad with zc
    5 n/a I don’t get white screen. At least not yet
2 Likes

No Apple Watch

No Apple Watch. Companion app works with Apple TV when using Android, also when using iPhone. Tried three different iPads with the Apple TV and the companion app won’t display the in game map on any of them. The app launches, the map displays a short moment, and then the app returns to the home screen.

I am running Win 11, CA on iOS15 paired to a first gen Wahoo KICKR and Wahoo TICKR X hr strap and have issues. The issue I am seeing is no BT pairing or registration of those devices through the CA.

I do have an Apple Watch and it does show up as a HRM though I don’t use that as I use the strap for HR and cadence.

I have tried a different iphone and my iPad running the CA there and see the same issues of not being able to see BT devices.

I can also run Zwift from my iPad and all BT devices pair there.

This tells me the CA is the least common denominator here.

Yes I too can run Zwift on the the iPad itself with all BT connections- trainer, HRM and Sterzo without problem.

1 Like

Still problems with the companion app. Running game on a desktop with win 10 and companion on a Ipad pro. Today i thougt it was fixed, everything looked normal (for 1/2 minute) then the map switched off again in the companion app.

1 Like

In my situation I have Apple TV running Zwift and was using IPad for the companion app. That is where the trouble began after this latest update of the companion app. The map in the companion app would appear briefly and then disappear. Reinstalled all apps but no change. Used both Ipad 12.9 pro with M1 chip and IPad Air. Both failed. Ironically the companion app does behave when I use it on my iPhone 13 pro. So I don’t think it is related to my WiFi.

No apple watch.

No Apple Watch

Had exact same experience on iphone12 mini as my iPad Pro. Both devices are on 15.1 with the same CA level.

If the zwift app isn’t open both devices run the CA as normal

Apple TV is also fully updated

My iPad also not responding and as of this morning 6/11/21 the zc app has completely packed up the logo icon not even coming up and every time I attempt to uninstall it reappears upon restarting my iPad image
See attached image this is all that appears and only on my homepage and not in the list of apps in my settings.

Was working fine on Wednesday evening but then from Thursday morning my ,map refused to open

Companion app map disappearing on multiple set-ups.

  1. Windows 11 CA on iPad latest iOS, Wahoo Kickr Polar OH1 both over ANT
  2. Windows 10 CA on iPhone latest iOS, Elite Turbo Muin B+ and Polar OH1 over ANT

Same problem on both set ups when running Zwift on latest Apple TV and prior generation.

Same problem here.

No problems prior to update.

No Apple Watch.

iPhone works but not iPad…

Please fix…

2 Likes

Had the same issue this morning on my iPad. Very frustrating. And went through all checks - same network, did a reboot of my iPad. Didn’t fix the problem. Then opened Companion app on my iPhone XS and it worked fine. But screen is too small to have same experience as on an iPad.

2 Likes

Same issue for me - no map, and when I’m doing a structured workout, the workout and map pop up for about 1 second and then disappear.

I tried both iPad and iPhone - same issue. Map pops up for a second, then disappears. On zwift, it shows companion app as connected.

1 Like

The problems with companion app all started straight after I did the update on Thursday Nov 4th. My iPad Pro or my iPhone 10 would not move from Home Screen to game. I deleted Zwift and companion app and reinstated, Apple TV is up to date. Interesting that today the iPhone decided to show me maps after an hour of riding in a group event. !!!

Having the same issue. Starting November 4 iPad companion app will not show map while on Zwift on Apple TV. The map flashes up then disappears and home page appears. Have deleted companion app and reinstalled on iPad no change. Deleted Zwift app on Apple TV reinstalled no change. Apple TV, iPad are all up to date. All running on same Wi-Fi network. For some reason iPhone companion app works! Reported issue to Erin at Zwift support and could not help. Said issue had not been reported which is NOT true as I see on this forum.

2 Likes