iOS Companion app 3.29.0 (1158) issues [SOLVED]

  1. Mac OS - 10.15.7 - No Apple watch. Wahoo Kicker 17, Wahoo tickr x, Wahoo cadence sensor - all connected via bluetooth directly (not through iPad or iPhone)

  2. Unable to screen shot - disappearing map. The Companion App on iPadOS looks like the map minimizes and then the Companion App returns to the non-workout screen with Home, Events, Activities, Goals, and More at the bottom.

  3. I have tried to logout of the Companion app and Zwift app on the Mac. This does not resolve the issue.

  4. Yes I have run the Companion App on iOS (iPhone 11) v15.1 — Works normal. The iPad is on iPadOS 15.1 as well (Broken)

  5. On that white screen on launch symptom: No!!!

  6. Toggling Bluetooth on the iPad does not fix the issue for me.

FYI, this is more than a maps issue. The workout screens do not show on iPadOS.

I prefer to run the Zwift Companion App on the iPad because the screen size is a lot bigger. I wish you had an iPad native supported app instead of having to run the Companion App in zoom mode.

This issue started with the Companion App update to 3.29.0.

Thanks,

Chad

My issue sounds very similar. Tried to ride this morning but was unable to get the connections to my tacx smart bike to work or be stable. Apple TV and iPad Companion app are the latest. I went through the trouble of removing them and reinstalling them to clear any cache’s.

I tried directly from Apple TV to the trainer with no companion app. Didn’t work.

I tried Apple TV + iPad Companion app with the devices connecting to the companion app. Didn’t work.

Finally got it to work with Apple TV + Android Companion app and it was solid for the whole ride.

Need this to work with just Apple TV. Wasting to much time this morning just trying to get a stable connection that’s worked in the past. All Bluetooth signals were strong.

Companion app works normally apart from the map during a workout as previously stated. I am using the companion app on my iPhone and the map does eventually show up however tonight i noted i was unable to do a u-turn. Pressed several times, nothing so it appears the companion app on iPhone isnt working 100% either.

Here is what it is doing for me.

Example-CA-Map

15 Likes

Exactly the same for me!

2 Likes

Same! Suddenly last week THur/Fri

1 Like

Same. Sometimes I glimpse the map before it disappears. Since the last update. Apple TV for Zwift & the Companion App on an iPad.

1 Like

Same here. Apple tv will not pair with companion. Driving me nuts! Only started a couple of days ago. I cannot monitor my speedometer etc when doing a workout. Come on Zwift, fix it!!!

Same here.

Same here

Pc + ipad (companion)

Exactly the same issue for me.

Zwift support indicated they are aware of the issue, but have no timeline for a fix.

They suggested using iPhone instead of iPad. If needed, delete the app from the phone and reinstall.

It works, but now I’m all squinty eyed from trying to follow the chat on a tiny screen :laughing:

What works for me: Zwift App on the iPad or the apple TV. Zwift App on the Apple TV plus companion App in iPhone. I can channel the controls through companion App on iPhone.
What doesn’t work: Zwift App on Apple TV and the companion is on iPad (M1 version).

Agree that the chat on the iPhone is a bit small for an old guy like me. Also agree that it would be nice to have a native companion app for iPad.

1 Like

Same here… Zwift running on an iPhone and Companion running on an iPad… both have just been updated to IOS 15.1…. Coincidence or the root cause???

My iPhone does exactly the same, so can’t even use that.

Both devices were ok on 15.1, it seems to be the CA update that’s died.

2 Likes

Same with me.


1 Like

After many many months of trouble-free operation my companion app suddenly can’t connect to an active ride. When I start a ride it switches over and starts to display the map and then bounces back to the non-ride mode. Both my iPad and my Apple TV are on the same Wi-Fi network and there are no other instances of Zwift running anywhere on the network.

4 Likes

Happened to me on the WEDU Wednesday ride on my Android Companion App while riding on PC.

Ride was active but ZCA was in a non-connected state and all text messaging never reached Zwift. It was weird as it never happened before and after that. Not really sure what asteroid hit my ZCA that day.

I run zwift through my AppleTV box and like to run the sensors through another device using companion to allow real cadence meter. I can run sensors through companion app on iPhone (same iOS version), but not iPad Pro (M1). Curiously will sometimes see the sensors on Zwift, but tell me there is no signal.
This only started in the last week. Main Zwift app is fine on the same iPad. Have rebooted the AppleTV and the iPad as well as turned the pair through companion on and off. Small issue, but mildly annoying. Has anyone else seen this?

1 Like

Maybe easier to start with what actually works 100%. Can only get on the actual payment part. :joy:

2 Likes