Companion app does switch to map

For the last several days when starting a ride (I only race) the companion app doesn’t switch to map mode. That means no chat and no selection of boosts through the phone. Doing these through the laptop keyboard is not viable.

Anyone else with this issue? I deleted the app and reinstalled but no change.

There have been no changes to my settings that I know of. Issue started before the update a day or two ago.

That’s a classic symptom of your companion app and game app being on different WiFi networks.

1 Like

Hi Mike,
I haven’t come across this for a while (have just double-checked on both PC and iPad).
The most common cause for this is when the device running Companion doesn’t connect to the same data network (usually Wi-Fi) as the one that the device running the main Zwift app is on.
What Companion device do you use? If it’s an iPhone, it could be switching to cellular data (the “Wi-Fi Assist” function, that can be turned off in the iPhone settings).
It can also be to do with the Wi-Fi router settings. Sometimes, power cycling it can resolve the issue.

Also, if you’re connected to VPN on either the Zwift device or your phone, they won’t connect properly.
It happens every time I forget to disconnect my computer from VPN before the ride.

1 Like

Thanks all. No VPN. Wrong network would be my guess too. However, my ISP provides the router, which automatically handles connections and can’t be modified (seriously, the firm/software is app only and can’t be accessed). I could install a separate router that can be managed, but the days of screwing around with goofy tech are behind me. It should just work. It’s been working fine for a year or more and suddenly not…??? B/S. I’ll try rebooting it tomorrow if it still doesn’t work.

It shouldn’t be overly complicated.

The router should be broadcasting a WiFi connection off which you’ve simply got to make sure both are connected to the same one.

Like you say it was working so chances are a quick reset and check should sort it.

Well, I did nothing (outside of complaining here) and it’s fine today. Meh.

Ah, but the network gods were listening and evidently worked their mysterious magic! :grin:

Chances are your phone has reconnected to the correct network.