Companion not displaying ride

Hi all! I’m having trouble with Zwift companion. It has stopped connecting to a ride. In other words, as I’m doing a ride (free-ride, not a training ride), it’s not pulling up my ride stats, live map, etc.

I’ve tried restarting, logging out & back in, deleting & re-downloading. Can’t think of anything else to try.

Has anyone else had this problem? I’d really like to use the clean screen on Zwift & have companion available to monitor stats (HR, etc).


I had this for the first time yesterday. Apparently the app struggles if the other machine isn’t on the same wifi network and the same band? May be difficult to tell if they’re both called the same thing, though.

Still happening and I’m on the same band and network, and my computer can see my phone on bluetooth too…

Same, Chris. Same WiFi network, though next time I’ll check to see it’s on the same router.

Try restarting your router to see if that helps.

This issue isn’t within Zwift’s control. Your Zwift Companion device and your Zwift app device need to be able to see each other on the local network. So that’s down to how your local network is setup, e.g. if your router is preventing devices from seeing each other.

Unfortunately, both devices can see each other just fine, in my case, anyway.

Thank you, Steve. I made sure my devices were seeing each other (iPad & iPhone) & it worked today. I hadn’t checked that before so I’m not sure if that was the issue last time.

Any luck Chris? Mine worked today. :woman_shrugging:t2:

Nope, sadly not. I’ve gone through reinstalling both several times now - I think I had similar issues getting Companion to play nice the first time I used it, so I’ll put it down to that for now…

The router reset trick helped me out, here. Thanks to Zwift support!

1 Like