Zwift Companion App not connecting

Hey all, I’m looking for some advice.

I’m running Zwift on Apple TV and have recently found that I can’t get the companion app to connect. It opens fine but just won’t connect when I am zwifting.

Does anyone have any advice?

Thanks

Mark

Here are some suggestions:

  • Turn off the mobile data aka put your phone in airplane mode. Wifi on, but cellular service off.
  • Make sure your Companion app is updated.
  • Make sure your phone is on the same network as your Apple TV.

Make sure you don’t have the companion app open on another device. Only one device seems to connect to the in game mode.

I had this situation once where my tablet on my smart bike would not connect to my workout… Turned out it was running on my phone… As soon as I closed the companion app on my phone the tablet connected :slight_smile:

1 Like

Cheers dudes, I’ll give them a try next time I’m Zwifting.

Thanks for the tips.

Mark

Hi - have you managed to resolve this issue? I have exactly the same problem and the companion app just will NEVER connect in game - it’s driving me up the wall

Hey,

Kinda yes and kinda no unfortunately. I went though all the tips above and I think resetting my router seemed to make the most difference (simply turned off then on).

A few updates came and went and all was good. But this week it dropped out twice, thankfully connected automatically pretty quickly.

Give the router reset and go and see how you get on.

Good luck

Mark

If you’re on an iPhone then turn off Wifi Assist. That can often stop Zwift Companion connecting properly.