Companion app dropping out endlessly

I saw the topic on companion app:

But my issues are slightly different- the app will randomly connect and function but it will then randomly drop back to the companion app Home Screen. No ability to control Zwift or chat.

I’ve tried everything, disable mobile data, turn off/on Bluetooth and wifi, airplane mode on the off, I even deleted the companion app mid ride and Install it again. I also restarted the phone too. Also see blank white screens too.

Apple TV 4K and iOS are the latest versions.

Phone and Apple TV are both within 1m of the WIFI router. It’s impossible and frustrating - I’m almost ready to cancel my subscription. I want to ride without having to also fix technical glitches.

Is there some workaround to solve this issue that I missed?

Hi @Chris_Denton_LACC

this could be router settings.

Turn off Wifi Assist: Go to Settings > Cellular or Settings > Mobile Data. Then scroll down and tap the slider for Wi-Fi Assist

3 Likes

That didn’t work, it broke again.

Cannot reconnect the companion app. What do you suggest now?

Edit:

Tried it with iPad - that worked better. It doesn’t have mobile connection though, just wifi

I started having trouble with the Companion App running on my iPad. Problems started after the latest IOS update for me. Sometimes I just a get a white screen when the map attempts to load. Other times the Companion App will not load or show the workout screen. I’m pretty sure it is a BT issue.

Have used the iPad without issue for 2 years until now. Only changes to setup are: a) now running WIN 11 on desktop which is used to run zwift on big screen, and b) latest IOS on iPad to use in game for workouts. I run both simultaneously as I have always done in the past.

No problems with zwift on Win 11. I can recover the Companion app by toggling BT but it is not stable.

Any relation with amount of devices connected to the WIFI hotspot?

Yesterday the app on the phone behaved itself properly for 30km.

It still happens on iPhone.

My workaround is to close off all connections and data, close the app, start it and get the error message - click retry a few times then enable Bluetooth and wifi then tap retry in companion app again.

All while trying to push 4w/kg.

This never used to be an issue before.