Zwift Click not connecting

I just received my zwift click and one and wanted to jump in straight away.
Everything is installed correctly however my zwift click controls are not found.
Here is what is already done:

  • Updated both the hub & click through the companion app
  • It’s able to see the click in the companion app
  • Turn on the click a few times, always waiting till the blue light is flashing
  • Tried multiple devices like Ipad pro & my mac (both are running on the latest update)
  • Restarted my mac and went through the Bluetooth troubleshooting guide.

Zwift Click Firmware 1.1.0
Hardware A.0

So the problem is that it’s not found by my other devices apart from my phone.
What can I do to resolve this?

I have the same problem I think.

I’m trying to find out how to fix a problem I have.

I’ve just received my Zwift Cog in the post today and have installed it on my Zwift Hub.

I’m a bit stuck now as the wireless shifters aren’t recognised by Zwift and I’m not sure where and how to get to calibration so the cog is recognised!

Is there a step by step guide I can follow please?

Thank you!



I do not have the “Controls” option in the pairing screen on the windows client on my laptop. I can connect it on my iphone as the controls options shows there but I only have “steering” on the windows app…

How can I resolve?

Same here!

Do you have the latest Zwift update (1.50)?

I don’t think so - but I don’t know how to get it. I actually uninstalled zwift completely and downloaded zwift from the zwift site and installed and it still seems to be version 1.49 I think…

I did the same, tried to see if there is an update but it does not seem so. Still on 1.49 and for now no way to force it.

By the end of today, you both should have the game release. May be tomorrow depending on the time zone.

Yeah, you’ll need to wait until Zwift schedules your 1.50. Should happen within the next 24 hours.

It’s pretty crazy that hardware is already sold while the software is not fully released yet. Normally the software should already be out for a few weeks then it should not have early adopters any issue. Or what should be possible is to have a early software release available like the testers on youtube just to unblock.

Is there any way you could share the release manually with us? Via email for example?

I’ve been pissing about with this for hours! This is madness that Zwift has released the hardware before the software is ready but I suppose it’s what we have come to expect when all they are interested in is our money.

1 Like

Release is now live for all


FFS folks. Calm down. It’s unfortunate that the phased upgrade means that a few very adopters have the hardware before they got the 1.50 upgrade but nobody is disadvantaged by it.

1 Like

Yes, apart from spending several frustrating hours trying to sort out their problem!

1 Like

Not for me in Blighty Oliver!!

I’m in the UK and have just downloaded the latest version. Thank you Zwift. It all seems to work fine!

Do I have to do a calibration ride so the software can detect how many gears my bike has? That option didn’t seem to be available.

Thank you!

1 Like

Well I’m in the UK and no Android update as yet. In the words of Diana Ross, “I’m Still Waiting”

Working now and first impressions are great.

1 Like

Does not work for me. Got 1.50 installed and it still can’t seem to find the Click on Windows…