Zwift click not appearing after app update

I’ve spent the last two hours trying to troubleshoot after installing the latest update on my PC. Initially, my issue was that my zwift hub wouldn’t stay connected through bluetooth (it would connect, then every 30 seconds or so lose connection then reconnect 30 seconds or so later. The LEDs would just switch between blue and all of the flashing colors repeatedly). I broke out a Ant+ dongle and the hub connection issue has been resolved but the zwift click still won’t connect to the app on my PC.

I tried pairing through my phone and that also doesn’t work. When closed out of the PC app, I can see the click in the companion app and it connects and shows the firmware is up to date. Seems like the issue has something to do with the PC app update and bluetooth connections, whether direct or through the companion app.

I uninstalled and reinstalled bluetooth drivers on my PC. I uninstalled and reinstalled zwift. Restarted my PC everytime I uninstalled and reinstalled something. Everything that could possibly be interfering has been powered down/unplugged/thrown out the window.

Nothing. Zwift click still doesn’t appear at all.

What am I missing? I’d love to get my FTP test in but it’s going to wait until tomorrow at this point. :upside_down_face:

Hi @Kate_Keller, thank you for reaching out to us on the forums.

When you’re updating in the Companion app, sometimes devices will stay paired to your phone.

Try force closing the Companion app on your phone by following the steps in our Force Closing Zwift steps. Although the steps are for Zwift, they also work for any app.

If you’re still having issues, turn off Bluetooth on your phone and any other devices (e.g. tablets, other computers, bike computers, etc.) and try connecting on your PC.

Hi Sam. Tried that earlier and just tried again. No luck. I have also tried everything in the connection interference support article.

Hi @Kate_Keller

Shuji at Zwift HQ here. A couple of things you should know:

I know the thing that triggered all this is your pairing over Bluetooth wasn’t great, but Virtual Shifting does not work over ANT+. Would you unplug your ANT USB dongle to simplify the troubleshooting?

When you are trying to pair to the Click - are you seeing the Connecting... icon hanging like this?

Or does it get past that and show the Connected state w/ the Click’s battery level icon showing, like this? If this - how much battery is left?

Because you’re on PC - try this:

  1. Exit Zwift by saving and closing your open session (or trashing and closing).
  2. Open Windows Explorer, and go to the Documents\Zwift folder.
  3. Delete the knowndevices.xml file. This is the list of the devices that Zwift has paired to in the past, including if those devices were paired over Bluetooth or ANT. Deleting the file is like starting fresh.
  4. Restart Zwift.


Does that make any difference?

Thank you for this! I had tried this to no avail but I did get in contact with support and what ultimately ended up working was deleting pref.xml in addition to knowndevices.xml!