Companion app connection or should I say not connecting


(Doug) #1

Since this past week when there was an update to both Zwift and companion app I have not been able to connect.
Worked fine Tuesday’s ride, then hasn’t connected since.

Doug


(Lin) #2

I assume you updated both Zwift and the Companion app. You might want to manually double check. Auto-update does not always happen immediately.

After Tuesday’s ride, did you completely shutdown (force quit if using app) Zwift and force quit the Companion app? If not, I recommend doing so after every session.


(Doug) #3

I have un-installed and force quit the companion app still not connecting.

connection between trainer and PC connection is working fine

Everything was working before update!!! This is very annoying.


(Lin) #4

Any changes to your house wifi? Your phone on the same wifi network as your PC?


(Doug) #5

No Changes in the last week
Phone and PC on same wifi


(Doug) #6

Lin,

I did a group ride yesterday, still no companion app.

Doug Blades


(Lin) #7

That is rather strange. You said PC, so I am assuming Windows. Perhaps try disabling Windows firewall. Also, any chance that the modem/box/router has some firewall settings enabled?

Here you go:

<snip>
ZC listens on TCP port 21587. Your router firewall should also allow all incoming/outgoing Zwift TCP traffic on ports 80 and 443 and all Zwift incoming UDP traffic on port 3022.

If you have port blocking enabled, you may need to either turn it off, or port forward to those specific ports, for ZC to work properly.
</snip>

Source: Issues With Zwift Companion App Pairing Before a Ride


(Doug) #8

I have not touched any setting with the computer firewall or router. App was working a week ago.

Doug Blades


(Lin) #9

Well at this point I would open a support ticket with Zwift. Something changed somewhere if it suddenly stopped working. While the forums are a good start for self-help, a formal support ticket cannot hurt. Zwift can check their side. They can also check and see if anyone else has reported the same issue since the last update. Etc…

Please update this thread when you get this sorted. “Enquiring minds want to know!” :grin:


(Doug) #10

Good news!!!
It worked this morning! :+1::grin:

Doug Blades