Zwift Companion - No Connection to Zwift

Evening Folks,

Do hope you could provide some assistance. Issues formatted (hopefully clearly) below.

Issue: My companion app will no longer pair with zwift when trying to start a ride. As such I cannot interact with my ride in any way, including features such as seeing the Map or giving Ride Ons, etc. This issue has been ongoing for about a month, I expected an App update may fix it, however such a fix has never arrived hence the time to raise a bug ticket/issue on here.

Expected Behaviour: I am able to start Zwift on my PC and run the Companion App on my phone and have the two recognize and pair with one another, such that I can interact with my ride via the Companion App in real time. This has been the behaviour to date, prior to this issue.

Attempted Fixes:

  • Force closed the app - No Fix

  • Running phone with companion app on Air Plane mode - No Fix

  • Checked and confirmed I am using the most recent releases and updates of both instances - No Fix

  • Confirmed that both devices are on the same network and there are no nuances around different GHz bands being used by mistake - No Fix

  • Tried different combinations of GHz bands and wired vs wireless internet on both devices - No Fix

  • Ensured all firewall, VPN, and other potentially conflicting settings have been turned off - No Fix

  • Uninstalled and re-installed Zwift on the PC - No Fix

  • Used a different phone with a fresh installation of the companion app - No Fix

  • Combination of all the above and also in various sensible permutations too - No Fix

Extra info: So as you can hopefully see, I’ve tried my level best prior to coming here for help, but I seem to really not be able to resolve this alone and required some guidance from here if possible. Should you have any specific questions please do let me know otherwise thanks in advance for reading and look forward to hearing you thoughts on a resolution!

Thanks Folks!

What a great description!
Just as a matter of brainstorming… on Dec 28, 2020 there was an update to Companion app. After that, there were a couple of updates to Zwift. While Zwift on a PC forces an update, companion app on a phone might require a manual installation of the update. Are you confident that you are on the latest version of companion app?

  • never mind, I missed it, you wrote you did.

BTW, discussing it on Zwift forum would not raise a ticket with Zwift. It has been a long time since a Zwift employee has wrote anything on this forum. I am not sure if they even ever come here. If they do, they leave no evidence of this.

You may have missed that Shuji, a Zwift employee, posts regularly on the forum.

The only thing I can think of that I do t see listed is that perhaps at some point you opened the Companion app on another device and it has not been closed out. The Companion app will only connect to the game on one device at a time.

Also, airplane mode won’t work, since that turns off the WiFi, but you might try either turning off the cellular signal, or at least turning off WiFi assist.

Keep us posted on your progress. I’m sure someone will figure out the issue.

Nigel, thank you. Nice to hear that. I will pay more attention to that.

Ben, in case it may help, Zwift talks to the phone within your home network. Your local router creates a local area network. If you open a program which manages your router, it will show you internal IP addresses and what devices they are assigned to. In my case, 192.168.0.1 is the IP address of the router on internal LAN, and then every device connected to it gets addresses like 192.168.0.15, the last number being increased by 1 for every device.

Your modem/router should show you all devices connected to the local area network, and this should include your PC and your phone. In most cases, router is able to list them by meaningful names, like, device type.

If you have a firewall on your PC, it should show you TCP data packets transmitted between ZwiftApp.exe on your PC and another device on your LAN. That other device would be your phone.

If you do not have a firewall on your PC, the same level of analysis can be done with a freeware program called Wireshark.

You will be looking for TCP communications between, using the LAN addresses of my home system, 192.168.0.xx and 192.168.0.yy. This will be a conversation between Zwift and your phone.

This is what I would do to check if this connection takes place.

Also, did you make sure that your wireless network reaches your phone at the location of your trainer? In my home, not every corner is created equal, when it comes to Wi-Fi signal strength. There are programs for phones to measure wi-fi signal level (WiFi Analyzer is a great program for Android). It will show you how strong the signal is by your trainer.

The last but not the least… You are not running companion app on multiple devices, by any chance? Like, on several phones or on a tablet? I doubt Zwift would be able to talk to several instances of it, and I wonder if it could connect to your other device before you open it on your primary phone. With portable devices, it is crazy how they work - an app oftentimes goes into the background when you think you closed it, and it may still be connected to the network even when your device is sleeping. A good way to check for that is to competely shut down all your other mobile devices and tablets.

These were my two cents… Usually, it is always a lack of connectivity on the local wi-fi network that leads to problems which you just described.

Nigel, I don’t know which device you use to run ZCA, but Airplane mode is not a problem on Android. You switch Airplane on, this switches WiFi off, you switch it manually on. Done.
It is the way I always go.
Ride on!

On my Android phone, Settings permits me to have Airplane Mode turned off and also have Wi-Fi turned off at the same time. Having Airplane Mode turned off doesn’t automatically mean Wi-Fi is turned on.

Afternoon Folks,

So after a good while debugging and checking things out I managed to find the real culprit! Fortunately I can now confirm I am back up and running as usual which is great.

In the end - it turned out that, even if my VPN is not actively running it overrides the Windows settings to be invisible on LAN. This was a new update for the tool and is present even if the VPN functionality itself is disabled. I only found this out through staged uninstalling of potentially conflicting tools.

So lesson learned here - even if you think you’ve fully configured your VPN appropriately, Off doesn’t always mean off…

Keywords for those with similar issues are: Visibility on LAN, or invisibility as it may also be.

Thank you all who spent the time to reply to my question - very much appreciated. Have a good remainder of your week!

1 Like