Zwift PC interaction with companion app

There was some update today for the pc app (there was one I promise because the end ride screen has not been there before on the pc platform)


  • Windows pc with Zwift
  • I have an iPhone 11
    ** companion App 3.19.1
  • Apple Watch 6
    ** companion app
  • wahoo kickr core
  • usb ant+ dongle

There are three mayor problems:

  1. Zwift Programm kills itself when a ride is done, this is annoying when you want to do different routes after each other.
  2. Prior to today (8th November 2020) it was possible to connect the companion app to Zwift on the pc. Now it won’t do that anymore (stable WiFi connection is given, pc on lan). No matter what I do (restarting any device, killing all apps, restarting software) companion app will not be able to see that I started a ride.
  3. It is very annoying to set everything up (prior to today) I had to do the following things to get everything connected.
    3.1 start the pc and the Zwift software on it, connect the Wahoo via ant+, check the use companion app to connect devices
    3.2 make sure to kill every Zwift companion or other app on your phone and watch
    3.3 select a ride on the pc
    3.4 start riding slowly
    3.5 open the companion app on your phone
    3.6 click the menu button in Zwift on the pc
    3.7 select pairing
    3.8 the watch will be listed and connected
    3.9 go out of the menu and continue riding
    3.10. Turn the watch towards you (companion app on watch shows heartrate now)
    3.11 done
  4. Zwift Companion App cannot be clicked in the pairing menu of the pc any longer I am just able to use built in Bluetooth

To point 3, if you messed something up start again from scratch.

This is just totally annoying. If you need more Infos on versions and other hardware specific stuff please ask. I am keen to help.

  1. This is by design. They can’t/won’t change it.
  2. Something is preventing your Zwift session and Companion app seeing one another on the same network. Try disabling WiFi Assist on the phone (apologies if you’ve already done this) which uses your mobile network to supplement the WiFi. Disabling this feature works for me, albeit on Android.
  3. My trainer and HRM pair automatically over ANT+ as part of the login process. They just pair and 5secs later the screen progresses by itself to the route selection menu. Not sure why this isn’t the same for you. Delete knowndevices.xml in Documents\Zwift and start again. You should pair the ANT+FE-C option from the controllable search and power/cadence should pair themselves accordingly - though my Neo always pairs itself for everything even on a clean install of Windows/Zwift if I wait for a bit. If you’re not on the latest version of the Kickr Core firmware you should update it; you won’t need a separate speed/cadence sensor then.
  4. This is because of 2.