[SOLVED] Sensor connectivity issues


(Scott Kroodsma) #1

Wondering if anyone can help me understand why i have issues nearly every time i try to ride with my sensors. I use a wahoo kickr, wahoo cadence meter, and wahoo tickr fit heart rate monitor. I display on my tv using my computer through an hdmi cable, and connections are made using a usb bluetooth adapter. I control the game from my phone using the android companion app. The computer itself and my phone never have issues detecting the sensors, but when i open zwift and login i almost always have issues with one or all of them not connecting. I end up getting them to connect by shear luck of turning things on and off, opening and closing zwift, etc. I tried support but their advice (connect first/only to zwift and no other devices) did not help remedy the issues. Any help would be GREATLY appreciated!


(Paul Allen (Watopia Wayfinder)) #2

Are you using a Mac or PC?
If you are using a Mac, make sure that the devices are not connected to any other device or app BEFORE opening Zwift, Bluetooth only allows one connect to a device or app at a time.
If you are using a PC you cannot directly connect your device directly, you would need to use the Zwift Companion App to bridge the signal. The best option is to use a ANT+ dongle and a USB extension for a more robust connection.


(Scott Kroodsma) #3

I’m using a PC. That was essentially zwifts advice also, so i make sure they arent connecting to anything else, open the companion app, then open zwift. When the pairing screen comes up i get random variations of what, if any, of my devices/sensors are connected. If i get annoyed enough i will check to see if they are able to connect to anything else and sure enough they connect just fine.


(Paul Allen (Watopia Wayfinder)) #4

Get an ANT+ dongle and a USB extension, it will make your life easier.


(Vincent W.) #5

Hey @Scott_Kroodsma it looks like we responded to you on 11/11/2018 with advice and we haven’t a response from you yet. Can you check that conversation again when you get a chance?


(Scott Kroodsma) #6

I received the response, yes. The advice to make sure that zwift is the first and only connection these devices make did not resolve my issue. I was hoping the community might have other ideas outside buying the ant+ dongle.


(Paul Allen (Watopia Wayfinder)) #7

But going to ANT+ will not cost much and more than likely solve your issue.


(Lin Alan) #8

If you’re using bluetooth on a PC, then I suggest you get it as close to your bike/sensors as possible. Also, try disabling the WiFi and seeing if that helps. If that’s not an option, then set your WiFi to channel 1,2, or 3 which is further away from bluetooth.

Even better would be to switch to 802.11ac (5Ghz) for your Wifi, thus getting completely out of the same range as bluetooth. Your Wifi and/or laptop depending on age may or may not have 5Ghz support meaning you would have to upgrade if you go that route.


(Scott Kroodsma) #9

The bike is within 10ft of the bluetooth adapter and has direct line of sight (no obstructions), as for the computer it is hardwired to the router. Or do you mean use the 5Ghz on my phone for the companion app? I am able to do that if thats what you mean.


(Lin Alan) #10

I moved all my Wifi to 5Ghz to eliminate it as a source of interference. iPhone, AppleTV, laptop, etc., are all on 5Ghz Wifi. If the laptop is on ethernet, then try disabling the Wifi if it isn’t already.

Do all of your sensors have issues? If you only go with the Kickr, can you get up and running?


(Paul Allen (Watopia Wayfinder)) #11

You spent near $1000 and are hesitant to purchase as $30 ANT+ dongle with a USB extension cable that will make pairing your devices much less of a hassle? You will not regret going to ANT+ for Zwifting.

You can use BLE, but again you need to make sure your devices are not paired to your phone or any apps on your phone before opening Zwift. A Bluetooth signal is more likely to have interference due to its frequency it is on.


(Scott Kroodsma) #12

I’ll try moving everything on wifi to 5ghz band. Ive only had the tickr fit for a week but it seems to have the least issues. The cadence meter has the most. The “fix” each time seems to always be different and no one process ive tried continually works for getting them connected, which is why i am so confused by this. Im not a tech wizard, generally get by just fine, but this has given me more problems than anything ive ever experienced haha. I’ll get back to you after my next ride, probably tomorrow, and let you know if this helped. Thanks for the ideas so far!


(Lin Alan) #13

Ah! Does Zwift actually support directly connecting via Bluetooth on PCs? I seem to remember that it didn’t or it didn’t at one point in time. Maybe that has changed. If not, you’ll need to pair via the Companion App. Have you tried that? or is that what you’ve been doing?

The following should make clear what I describe above: Zwift & BLE


(Scott Kroodsma) #14

Lin i do use the companion app as my control on the bike, the pc and tv is simply for display.

Paul, cycling is expensive so i just try to save some money where/when i can. I’d prefer to try some solutions without buying the ant+, but will if i cant solve it otherwise. I appreciate everyones help


(Lin Alan) #15

I started with ANT+ until I decided to go with an AppleTV 4K for Zwift. One thing is for sure, I have never had an issue with ANT+. Get the dongle and a USB extension cable like Paul mentioned, your problems will be history. Hook it up and place the dongle centered and behind the bottom bracket. Keep it out of harms way (sweat).

The bluetooth issues are a recent thing with Zwift. They broke something over the summer in one of their updates.


(Scott Kroodsma) #16

After following your advice about the wifi Lin, my sensors all connect on startup of zwift everytime. Thank you again for your help, i really appreciate it.


(Lin Alan) #17

That’s great to hear! Ride on! :+1: