Unable to connect to sensors (Win11 & Android companion app)

unable to connect to sensors (Win11 & Android companion app)
literally preventing me from being able to cycle.
Tried restarting computer and android phone, no luck.

these are constant issues, zwift needs to fix, it’s an absolute nightmare trying to get a cycling session in on this app as of recently.


I think this is unlikely to be a Zwift issue (otherwise it would be happening to everyone).

Obviously it’s your Zwift issue but I don’t think it’s the platform causing it.

Tell us how long this has been going on for and some information about your setup, trainer, etc.


Have you tried connecting without using the companion app. Connecting to Ant+

Please give us more information on your setup.

There’s been at least several reports recently about Companion app Bluetooth pairing not working in the the most recent Companion update. Some have reverted to the previous version and fixed their pairing issues.

Wahoo kickr, wahoo tickr, wahoo cadence. (sensors aren’t the issue)
Android Companion (likely the issue)
PC Windows 11 - Zwift 1.22.4 (possibly the issue)

These issues have been absolutely plaguing me to the point of being unable to make any race time or use the app. You never know when it’s just not going to work. Usually a restart of both windows and android would eventually resolve. Today nothing is fixing this. 2h spent trying to figure this out and same deal last weekend as well.

I’ve just reinstalled zwift PC and companion app. still nothing

I don’t have an Ant+ dongle, always use the Android app

interesting. Has this been reported recently. This is likely the issue
@zwift team - can we please report this companion app issue and expedite a fix if this is the case? It’s likely affecting thousands from being able to zwift today

I would suggest using a ANT+ dongle. One less thing to worry about.

I have the same problem. Downgrade Companion App to version 3.31.1


To my knowledge, if all of your devices won’t pair at all using the ZC BLE bridge, then the Location service and privacy settings are perhaps not properly enabled in your Android device settings.

  1. First, double-check that the Location Service is turned ON, and see this article for instructions. There might be a quicker way to enable Location service on Android if you’re savvy with Android, but that article should also get the job done.

  2. On your Android device, go to Settings > Privacy > Permissions Manager > Location > Zwift

  3. Select the option to Allow all the time.

  4. Now, go to Settings > Privacy > Permissions Manager > Nearby Devices > Zwift

  5. Select the option to Allow.

1 Like

those settings were enabled, never had the issue before with the ZC app permissions.
The issue was the app recent version breaks the connection to devices as mentioned by several other helpful users on this thread.


It seems there was a known issue last week, but it was reportedly resolved with last Wednesdays ZC app update (e.g. version 3.33.1) for Android. More info here.

FYI this issue is still partially ongoing. the 3.33.1 helped the issue (in that it can actually connect to the sensors) but disconnections are still occuring.
Most recently lost all connection at 22.5/30km ride. Luckily I was co-tracking with Garmin which has never skipped a beat


Fair enough.

Since the broader scoping known issue has been resolved but you still have connection dropouts when using the ZC BLE bridge, it’s best that we troubleshoot this on an individual basis. I will be sending you an email reply to continue working with you on this. Thanks!

we don’t need to troubleshoot this individually, this is a widespread issue, affecting many users.
Zwift needs to fix the issue and provide an update with bug fixes to the Zwift companion app and… refund userbase for time they are unable to use the platform due to a bug created by your development team


Your support inquiry has been escalated to our Tier 2 tech support team and so our techs are happy to continue working with you.

I understand that you’re asking for refunds, so that and your other concerns can be more appropriately addressed in an email. It looks like we sent you a reply yesterday so if you haven’t seen our team’s latest email reply, please check it out. Thanks!