Companion App Bluetooth pairing issues? [Android] [March 2022]

Is there a more recent thread? The current version is 3.32 but I can’t find a thread for that version.

I don’t think so. No major updates lately, just bug fixes.

I’d assumed this was for a Feb 25th 2022 update but just noticed it was actually 2021. coincidentally, after a Zwift Companion app update almost exactly a year later I’m having the same problems people were having at the beginning of this thread - the complete inability to connect using Bluetooth via the Companion app

Lol, i was just reading through thinking thank ■■■ i’m not the only one, then i got to your post and saw the posts are all from last year. At least there’s two of us i guess

I am also having the same issues. Using companion app on a Samsung Tab A7 with Apple TV. Rode on Monday with zero issues. Tuesday? Couldn’t connect anything. Tried resetting my router, uninstalling and reinstalling companion app, Zwift. Factory reset the tablet this morning. Still nothing. I connected briefly on my phone on Tuesday, but haven’t connected since. VERY frustrating. I can connect to my Wahoo KICKR and Headwind through the Wahoo app with no issues. I can connect my Sterzo steering device using that app - again, no issues. The problem isn’t my network or my bluetooth connections. The issue has to be the companion app.

I also started reading this thread thinking it was a recent posting. However, I’m relieved that I’m not the only person experiencing this issue.

Any luck? I can ride in Zwift just fine, but companion app is not working at all. If I want to communicate it has to be through the computer or iPad. All apple products here.

Hello. I have problems with the ZC application, I don’t see the sensors at the beginning of the game, how should I fix it now, because obviously according to the comments, you have the problem and not me. The app worked quite normally a couple of days ago.I have been connecting via the app normally for months and see no reason for me to have problems.Thank you very much for your help.

1 Like

Fixed one issue and created others​:rage::rage:

I still cannot send a ride on from android notification

I’m going to repeat my post again here in the hope that the Zwift developers will get so hacked-off with reading the same complaint, they will do something to fix it.

I’ve already posted in the “Android” forum, but I think it deserves to be repeated here.

Like lots of other users, I’m currently having big connectivity problems using the Companion app Bluetooth “bridge” (Android) with my Tacx Neo 2T and Apple TV. Everything was working fine until the latest Companion app update (which I performed on Monday 28th Feb).

This issue nearly screwed up my last WTRL-ZRL race when I lost the connection just before the start. I abandoned the Companion app and paired the trainer and HRM directly to Apple TV via Bluetooth without a problem. In fact, since joining Zwift over a year ago my set-up of pairing trainer & HRM directly to Apple TV via bluetooth has been bullet-proof and problem free. It’s only since I acquired a set of Assioma pedals and started to pair everything via bluetooth using the Companion app that frequent connectivity problems have occurred. It makes the Zwifting experience a nightmare, especially when racing.

I tried again yesterday (after clearing the Bluetooth and Comapnion app caches and restarting Apple TV etc.) and managed about 45 mins of a free ride before another “Connection Failure” debacle. If I pair directly without the companion app, everything is stable.

Getting well pi**ed off with this now. Hopefully, Zwift will pull their finger out and get this sorted asap.

Sansung phone app won’t connect either

Hey all - I split off some posts from an older thread to create this one.

We have found the bug that’s causing flaky Bluetooth pairing issues on Android devices, and are working on fixing those ASAP. If you are having issues please tell us:

  • What brand & model of Android device you’re using
  • Which version of the Android OS
  • Which version of the Zwift Companion app.

Thanks all - we’ll update this thread as we have an ETA on a fix.

3 Likes

Samsung Galaxy S20 5G
Android Version 12
Zwift Companion 3.33.0 (1337)

Broken:
Phone => Moto G8 Power XT2041-3
Android => 11
Build => RPES31.Q4U-47-35-12 (RPES-31.Q4U-47-35-11 worked).
Companion => 3.33.0 (1337)

Works:
Phone => Moto G5 XT1676
Android => 8.1.0
Companion => 3.33.0 (1337)
That phone has Bluetooth 4.2 which only works without dropping if I place the phone in a specific way (tilted).

May I suggest (again) adding ANT+ support to the Companion? I have an ANT+ debug app on the G8 Power and it picks my devices up just fine using an ANT+ dongle and OTG cable.

Also 2013 Macbook Pro laptop. It’s running the most recent updates.

Moto Edge 20 Lite - Android 11 - Version 3.33.0

Sony Xperia M2 - Android 5.1 - Version 3.33.0

The Moto Edge is my current indoor ‘headunit’ and has been absolutely fine for the past few months up until this morning where it flat out refused to see anything in the pairing screen. Dusting off my previous Xperia showed exactly the same symptoms so I doubt it’s an Android 11 specific thing.

Meanwhile the iPhone worked immediately with no issues.

On a mildly related gripe with the Android Companion, Is it expected behaviour for the rider pins on the map to move in a stop start fashion, this also seems to cause the map view to spin around in an amusing and quite distracting manner on twisty routes if you set it to turn with you.

I can grab a video of it if needed. Both my Android handsets have the same behaviour whereas the iPhone is fine.

Motorola Moto g8 Power Lite (build No. QODS30.163-3-26)
Android Version 10
Zwift Companion 3.33.0 (updated 02/28/2022)

Xiaomi Mi A2
Android 10
Companion app 3.33.0

BTW, I forgot to say “thanks”. Looking forward to this being resolved. :+1: