Zwift Companion App - Connection Problem

Hello all,

Time for yet another ‘Companion App won’t work’ thread. I have already spoken with Zwift’s support chat, who couldn’t help me over and above “try the Issues with Zwift Companion App support page”, unfortunately. They suggested I post here to see if you guys can help. Apologies, but I am tearing my hair out with this thing currently. Why Zwift can’t just implement a feature to manually connect two devices together rather than rely on automatic pairing (which a quick google search shows has been fraught with issues spanning over many years) is beyond me. But anyway, I’m sure there are technical reasons for it.

My companion app simply doesn’t connect to my Zwift main device and sits on the Home screen. Classic issue experienced by many people over many years. This issue occurs across multiple devices used as host for the main Zwift program and the companion app. So for, no combination of any of the following devices works:

Zwift: Main PC, Laptop, android tablet
Companion: Android tablet, android phone

Just to repeat again, I have tried every single combination of the above and not managed to get the apps to pair.

Please note that I have attempted every single piece of advice found on the Issues with Zwift Companion App support page. Yes, I have properly shut down the apps and force closed them. I have cleared cache. I have uninstalled the apps/programs and reinstalled on all devices, multiple times (which also means that they are all fully up-to-date). I have tried loading up the apps at various different times to see if timing makes a difference. They are both connected to the same network, using the same band and the wifi channel is not congested. None of the devices have active firewalls. No VPNs are being used. I have tried rebooting the router several times. Etc, etc…

Two to three weeks ago, my companion app connected when using my android phone and tablet but its functionality was spotty. I have since been unable to get them to connect. Nothing has changed in my home network setup.

[EDIT] If it helps, the router is a BT Smart Hub 6.

If anyone has any suggestions other than the normal advice given in these posts, I would love to hear it. Apologies if any of the above feels as though it is dripping with disdain for the software; I am not a network engineer by any means, but I have a reasonable amount of tech savviness and the levels of frustration at spending countless hours trying to get this to work are up there. There has got to be a more simple and direct solution that Zwift could implement within their software that would remove these issues for everyone for good.

Thank you. If you need any further information, please feel free to ask.

Have you tried statically assigning an IP addresses to both the PC and the Tablet?

Thanks Paul. All my devices have static IP addresses within my network setup by default. I could try assigning some of the devices dynamic IPs and report back if you think that could help.

Default setup would be dynamic using DHCP, you would need to manually set an IP address on each device for a static address.

Make sure you are using a local DNS address and not a public address on your devices, only your gateway (router) should use a public DNS server on it’s WAN port.

Thanks. DHCP is being used, but what I mean is the router preserves and assigns each device same IP address every time it connects to the network, so they have ‘static’ IP addresses in the sense that the IP address each device uses never changes. I’ll tell it to stop doing that for a couple of the devices and see if it makes a difference later on today.

On the PC and Tablet try statically assigning the IP Address instead of assigning it using DHCP. If they are using DHCP they are not using a static IP address, what you are trying to refer to is Reservations.

Also make sure on your devices you are using your gateway/router as your DNS server. If you use a public DNS server on your local devices there is no way they will be able to find each other.

What is the DNS server that your local devices are using?

BTW, I am a Network Admin.

Thanks. Excellent, hopefully we can find a solution!

I don’t know how to check what DNS server my local devices are using. Can you tell me how? Presumably there’s an ipconfig command for the laptop, but wouldn’t have a clue where to look on an android phone or tablet. I can’t see anything obvious in the settings area. But I can modify the network properties to assign a static IP.

You could look on the router and look at the DHCP settings and see what DNS server it is handing out.

If it is a Win10, in the search at the bottom left type in cmd and hit enter
in the command prompt type in ipconfig/all
You will see all the IP info

Thanks. This is what comes back. The DNS, DHCP server and gateway addresses are the same.

Wireless LAN adapter Wi-Fi:

Connection-specific DNS Suffix . : home
Description . . . . . . . . . . . : Intel® Dual Band Wireless-AC 3165
Physical Address. . . . . . . . . : 00-E1-8C-CF-DE-10
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2a00:23c7:688c:ec01::10b8(Preferred)
Lease Obtained. . . . . . . . . . : 24 October 2020 15:16:01
Lease Expires . . . . . . . . . . : 25 October 2020 15:16:00
Link-local IPv6 Address . . . . . : fe80::9807:b2fc:767:f2c1%19(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.148(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : 23 October 2020 18:40:05
Lease Expires . . . . . . . . . . : 24 October 2020 18:40:00
Default Gateway . . . . . . . . . : fe80::f286:20ff:fe39:d71c%19
192.168.1.254
DHCPv6 IAID . . . . . . . . . . . : 134275468
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-24-CC-7A-2D-00-E1-8C-CF-DE-10
DNS Servers . . . . . . . . . . . : fe80::f286:20ff:fe39:d71c%19
192.168.1.254
fe80::f286:20ff:fe39:d71c%19
NetBIOS over Tcpip. . . . . . . . : Enabled
Connection-specific DNS Suffix Search List :
home

[EDIT] The DNS address stated by my phone is also 192.168.1.254.

Have you disabled Smart Network Switch? Apologies in advance if you did this years ago.

Have you tried setting your WiFi router to a static channel?

Ok, an update. I have now got it working properly using both my main PC and my android tablet for Zwift, with phone running Companion. Having disabled ‘authoritative DHCP’ on my router and changed a wifi setting on my phone (turning ‘private DNS’ from default to off). Unfortunately, my laptop (which is what I actually want to use) still does not work. So it appears the laptop is now the core issue.

The ipconfig log copied above is from the laptop.

Do you mean the ‘smart channel’ setting that most routers use? I have mine set to use a specific channel and not switch. Channel 48 if memory serves, but basically one that no one else is using around here.

I don’t have that option in wifi settings on my Pixel 5. But I have tested with mobile data off too, and I disabled the 2.4ghz band on my router a fair while ago, so there shouldn’t be any switching going on.

I had to set my ip address for my phone and pc close to each other in the wifi router settings. Now all my devices has ip addresses set by the wifi router with only one didget separating them

Assuming you’ve checked for it in the advanced wireless settings? Anyway if you’ve tried with mobile data off then it can’t be that.

Aside from manually choosing my channel, I’m on auto everything. Never had an issue.

1 Like

I had mine on auto for years then I got some smart lights and it messed up every thing :crazy_face::crazy_face::crazy_face::crazy_face::thinking::thinking::thinking::triumph::triumph::triumph:

Don’t ask why.

I’m using a very old (almost a decade) boggo 2.4GHz only ADSL router repurposed as a bridge. Sometimes the cruddy limited old stuff is just fine. :laughing:

1 Like