Zwift Companion app won’t connect

Hi all, I’ve had issues with my ZC app connecting ever since Spectrum “upgraded” my Router. My work around would be to reset my router, then forget and reconnect to the (same) wifi network on both my laptop and phone. That would get chat to work as long as I followed those steps before every ride.

Fast forward to the recent update, my trick isn’t working anymore. Any one experience this issue, and have you found a fix?

I am on 5Ghz WiFi (Zwift set up 6ft away from router), windows 11 laptop, iPhone 15 pro. All latest software installed across devices. Thank you.

I always go to the app store pre-ride and check Companion for updates and if there is one I update and restart my phone (Samsung Android) and then there never is a problem.

Hi Ana, did you ever get this resolved? I’ve been experiencing the same problem. Thanks!

Hey Justin, I found a workaround that makes the ZC app connect but can’t say it’s fully fixed. Here is what I do:

Forget the Wifi Network on my laptop, forget it on my phone as well.
Reset my router (not the modem if yours is separate, only the router)
Reconnect to WiFi on my computer, then my phone as I’m launching Zwift.

I’ve tested not doing the above, or only resetting the router and not actually disconnecting/forgetting the network, and that has led to either the ZC app not connecting or connecting for a few minutes and then failing.

I have Spectrum WiFi, I tried to contact them about this but to no avail. I hope the workaround works for you. If you find a permanent solution please let me know!

Hi Ana,

Thanks for the workaround. Finally had the chance yesterday to try it and it worked. It’s been so long, I almost forgot what it was like to have Companion paired. (Although I quickly remembered how quickly it would drain my phone battery on a 2-hour Zwift ride!)

Will let you know if I come across a permanent solution.