Zwift companion not connecting

I am using Zwift on an iPad Air and Zwift companion on an iPhone 8.
Both units are connected to my private wifi network and are on the same operating frequency.
Zwift works fine on the iPad and records and uploads my rides to Strava just fine.
Zwift companion is working on the iPhone in the sense that I can log on using my Zwift account details and am able to see my previous activities but when I have Zwift running on the iPad Zwift companion on the iPhone never goes into game mode but continues to show the Home button.
I have tried the following:
Make sure ZC is completely closed
Turn off mobile data on OR turn on Airplane mode on your phone
Connect to your Wi-Fi network
Launch ZC
Launch Zwift on your other device
My router is a BT Home hub 4 and I have followed these instructions as best I can:
ZC listens on TCP port 21587. Your router firewall should also allow all incoming/outgoing Zwift TCP traffic on ports 80 and 443 and all Zwift incoming UDP traffic on port 3022.
If you have port blocking enabled, you may need to either turn it off, or port forward to those specific ports, for ZC to work properly.
Zwift companion is still failing to connect to the iPad and I am out of ideas. Help!

Maybe the method I am using to test my setup is not correct?

I am running Zwift on my iPad away from the trainer (different room) so not connected to it. When I reach the stage of seeing my avatar waiting for me to start pedalling I then launch the Zwift companion on my iPhone. At this stage I hope to see the home button change to game but it never happens.

Why don’t you try doing a fresh reboot of your modem and router? I know someone who had a problem similar to yours, and after they did the reboot, Companion and Zwift paired successfully. I’d also check that both apps are up to date. If that doesn’t help, I’d like to invite you to write a support ticket so we can look further into the issue.


Thank you. The router reboot has fixed the problem.

Yaay! Glad to hear it :slight_smile:

Sounds like you fixed the problem with your router reboot. Zwift support encouraged me to reply also (even though your modem reboot fixed your issue) because i had the same problem but fixed it in a slightly different way. I just switched the channel of my wireless signal to one with less traffic on it. Maybe that’s effectively the same as a reboot? I am not a techy person. In any case, if anyone else is having this problem, maybe switching the channel (and/or rebooting as you did) will work for them too.

1 Like

I had the same problem. The iPhone connected, but the map disappeared at once. But when I turned off the “mobile connection” on the iPhone it works as it should.

1 Like

This worked perfectly. Looks like refreshing the wifi signal removes the bottle neck. Thanks for sharing.

Hi I know this is an old thread but it worked perfectly for me today. Thanks for the advice.

In my case, the lack of connection between zwift and zwift companion app was because “local network” was not enabled in the zwift app settings (on my iPad).


I used to connect both my ZG and ZC app using Wi-Fi however when I moved my Turbo trainer to the garage I had loads of problems with my Wi-Fi, sometimes the game wouldn’t save after my rides. This caused lots of jersey unlock problems with large events due to this issue, I also had lots of problems with my ZC app dropping out, all VERY frustrating!

Last year I decided to run an Ethernet cable to my garage from my BT router and purchase the Belkin Lightning to Ethernet + Power Adapter (MFi-Certified) RRP £90 (I paid £62 on Amazon Warehouse) which solved ALL my save issues, however I did still experience a few ZC dropouts.

I decided to purchase another branded FOINNEX Lightning to Ethernet + Power Adapter with OTG that was much cheaper £32 so see if running both the ZG and ZC on the same wired network would work. needless to say it didn’t, I must admit that I did think that the problem was totally down to my intermittent Wi-Fi and the distance my iPad Pro running Zwift was from the router. Frequently I was only connecting with 1 bar. I had even considered getting a BT extender disc for £99 to see if this would help!

Had I spent the time in looking I would have found the easy solution much sooner, I had never even considered it might the mobile data 4G connection interfering with the Wi-Fi as soon as I turned on Airplane mode during all my rides all my ZC drop outs stopped. Needless to say I now have a bomb proof ZC connection all the time for screen prints and the like.

However on the bright side I now have a spare adapter just in case my more expensive Belkin fails, that I can use whenever I want on my other iOS devices, as my Wi-Fi in the garden is also pretty bad.

Thanks for the tip. After trying loads of other ways, this worked for me.

1 Like

That worked for me, thanks

The Companion App does not work properly on my iPad, it immediately loses the connect, e.g. during a workout => there is a short login, you can see everything (heart rate, workout bar, etc.) but after about 1 second you are kicked out again.
The Companion App on the cell phone, on the other hand, works perfectly (the same WiFi network).
Zwift is operated on a laptop with Windows. Companion app and iPad everything at the latest.
I’ve read this problem a couple of times with other users.

See the post pinned to the top of the Forum on this topic. Much more recent and relevant.

I am having the same exact problem! I have tried everything from this forum and I still cannot get it to connect!! I miss using the ipad!!

Have you tried rebooting your router?

I’m having this exact issue. Zwift app on iPhone iOS 15.1.1. Companion on iPad iOS 15.1.

Connects to overview map for one second then craps out.

This is not a router issue.

Revival for anyone that might be facing similar issues.
I had MacOS update lately (Sonoma, 14.0), there was September update (1.49) and what not (Companion 3.51.0) and I had much trouble figuring that stuff out. Made sure VPNs are off. Only WiFi is used. Tried another phone. Checked for listening ports.
I though my network is fine since Windows Samba discovery works perfectly. Alas, it was not the case. I had to go into OpenWRT (router software) and restart my local interface (not even wireless, literally LAN).

I guess the reboot would help as well.