Bug: Companion bridge sensor drops permanently after starting an event

Hi all,

So I am having a major issue at the moment, in that when I start any event in Zwift, as soon as “port” to the event start point, all sensors paired through the companion app and “bridged” switch to “no signal”. This happens pretty much all the time now and makes the game nigh on unplayable for me.

To recreate the scenario, I open the companion app on my phone, then open zwift on my PC. I log in fine, the initial sensor pairing goes fine, and when I start my cycle on whatever map I go for that also goes fine. All up until an event starts. As soon as I “teleport” to the event, whichever map it’s on, all the sensors switch to “no signal” permanently. I waited 3 minutes this morning trying to be patient, trying to pedal then stop, keeping my cadence meter awake and nothing.

Weirder still, when I went into the pairing screen, I disconnected the trainer and cadence sensor, but then I could not re-pair to them. My wahoo kickr bluetooth LED showed as still connected to something but it wasn’t registering in game.

The only way I managed to take part in the event was to fully close the companion app, fully close Zwift on my pc, switch the trainer off at the wall and on again, then use the Zwift app on my phone instead (which is not the way I want to play).

Is there any workaround or known issue about this? I could not find anything in the known issues forum about this.

Thanks for your help!

Hi @Guy_Gisborne

I would suggest getting a ANT+ dongle for your pc or a Bluetooth dongle. It will be more direct communication.

2 Likes

Hey @Gerrie_Delport,

Thanks for getting back to me, and I have seen recommendation for Ant+ as well in my previous thread about a similar issue, and from my team mates as well.

First thing is I have a bluetooth dongle, but it results in drop outs every so often so I was trying to use the bridge to work around it.

I’ll detail what my issue with ant+ is below** (if you feeling like having a look) - it’s for this reason that I am looking for a way to get bluetooth working reliably or the companion bridge working again. Trying to work through the issue instead of around it at this early point :).

**The main problem I have is pet rabbits… And you might need to hear me out here for that to make sense, but from what I hear is you need to have the ant+ really close to the trainer, however my PC is against one wall, hiding the wires behind it, and the trainer is against the other wall with the wires behind it… So the rabbits can’t get to them. If I need to get a USB extension and ant+, the rabbits will completely destroy any wire coming across the carpet. If ant+ is reliable at 4ish meters (which seems to be up for discussion) though, I would be willing to pay the £30 odd for one of the good ones to give it a go.

1 Like

LOL Quote of the day. :rofl: :rofl: :rofl:

I would say even Bluetooth need to be close to the sensor. A Pc has so much interference that you want to move the sensors away from the PC.

If it was up to me I would try to find a way to get the ANT+ close to the trainer, maybe put it in a piece of plastic pipe.

3 Likes

You could just lay a rug over the top of the USB extension and ANT+ dongle.

Cool on the rabbits, I have 2 of my own.

2 Likes

Thanks @Gerrie_Delport! (You would not believe the concessions I have to make for these rabbits, but it’s entirely worth it… After 6 years it is a part of life). I will definitely give that a look and see if I can make it possible :).

Cheers @Paul_Allen! If the state of my gym mat is any indication then a rug probably won’t be a massive deterrent, but might try combining both of your and Gerrie’s ideas and running a shallow pipe under a bit of rug from the desk to the back of the room. One day I’ll have a house with a garage that the rabbits can’t get to… Maybe :thinking:

2 Likes

Do you have the Wahoo app installed on your phone? How about a bike computer on your handlebars? Might one be stealing the Bluetooth signal before the Zwift app can fire up?

2 Likes

Hey @shooj, thanks for your response!

I do not have the wahoo app on my phone, I removed it quite a long time ago. I also don’t have a bike computer (never had one). There wasn’t really anything else that was able to connect to the trainer - I think when I “disconnected” the bluetooth via the pairing screen it just didn’t fully disconnect. When I turned the kickr off from the wall, waited for 15 seconds and turned it back on again it was able to connect fine. For the example from today, just the same issue occurred when I tried to rejoin the event: as soon as I ported over, all sensors went to “no signal” and I stopped moving - even with the catch up to the leader in effect.

@Guy_Gisborne ok, we’ve eliminated those possibilities.
Have you tried updating the firmware on your trainer?

I use an ANT+ dongle on a USB extension cable with a Windows laptop, and I find that my connection is better than BLE.

I’m also a former bunny-dad, so running that extension cable through PVC pipe sounds like a good preventative measure. :rabbit:

2 Likes

Hi @shooj,

I’m hesitant to point at the trainer at the moment as being at fault, the reason being my cadence sensor and heart rate monitor also get the same status of “no signal” - not just the kickr.

Also, when I switched back to directly connecting to the pc Bluetooth, the issue did not repeat itself, although I got my irregular Bluetooth dropouts which prompted me to switch to the companion app as a bridge in the first place (quite bad today, at 3 in 55 minutes, but usually its about once an hour).

Yeah I’ve been looking into maximum usb ranges to see how viable it is to use ant+, and should be fine! I would much rather solve the issue and not need to do that, though :blush:.

Thanks for your replies! I really appreciate it.

I have encountered a similar, probably related issue during workouts.

Search for my thread titled “Permanent sensor drop in Companion app during workouts”

@Guy_Gisborne

Looks like you’re running the Zwift app on Windows 10. Microsoft didn’t include a framework on Win10 that can cause problems with Bluetooth devices.

Go to their support site:
https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads

Download and install the file called vc_redist.arm64.exe
Reboot, and try the pairing process via Bluetooth. Would you let us know if this clears it up?

I have EXACTLY the same issue @Guy_Gisborne! Using Win 10 on laptop and bridging with Companion app.

Hey there Shooj,

Thanks for reaching out and sorry about the long delay on replying, my zwift emails we swept into my spam folder!

I unfortunately can’t install that file as “this installation package is not supported by this processor type” :frowning:

The arm64 package will only be for ARM CPUs. You probably need the x64 package for Intel/AMD.

Thanks for the followup @Guy_Gisborne

By any chance is that Win10 machine a Microsoft Surface Pro X? That’s one of the Surface variants that run an ARM processor instead of Intel, and Zwift does not support it..

ARM architecture is more common in smartphones and tablets, and more typically run with mobile OS’s and apps. The Surface Pro X is an odd duck that runs a version of Windows, but it can not run apps unless they’re specifically ported to work with ARM CPU’s per this Microsoft support article.

Hey there @shooj and @Steve_Hammatt, thanks for the quick responses!

It’s an intel 9600k processor, I’m guessing I should go ahead and download the relevant one from the list then: x64:vc_redist.x64.exe :slight_smile: