No sensors found

Dear Zwifters,

This is my first post as I just signed on zwift after buying an amazing Elite Direto trainer.

As you could easily guess from the title, I tried to follow official guidelines and reading post on (especially this) forums, but yet my zwift cannot see ANY sensors via Bluetooth.

My setup is the following:

  • Elite Direto
  • Zwift companion app , Android version
  • whaoo Bluetooth haert rate monitor
  • windows 10

I’m quite confident the problem is not on the trainer or any other sensors, but most likely the app itself. This was confirmed to me when I tried and saw that other systems (Garmin , Elite app) could as usual connect to the sensors. I also made sure that no pairing was active with these sensors.

But the results didn’t change: zwift cannot see any sensors.

Any tips I could try?

In the meantime I order a USB ant+ dongle hoping to get everything up and running more steadily.



I basically have the same issue, albeit slightly different circumstances.

I’ve got a new laptop (MacBook Pro) and installed Zwift but it won’t detect my smart trainer or HR band via Bluetooth. This worked absolutely fine on my old MacBook Air.

It’s not the trainer because I can connect to it fine from other apps and devices. And it’s not the laptop because I can connect to the trainer via other training apps, e.g. Tacx Desktop.

My guess would be that a recent Zwift update has messed this up. I’ve submitted a support ticket and awaiting a response. For now I’ve borrowed an ANT+ dongle from a friend and that’s working fine.

[UPDATE] So I had to humbly apologise to Zwift’s support guy who helped me with this issue. Despite my being adamant that clearing down my MacBook’s bluetooth config files wouldn’t achieve anything, since other apps were connecting fine, this did in fact solve the problem. It meant I had to re-pair all my BT devices to my laptop, but that’s really not a big deal. Everything working fine again for me using Bluetooth. (There is a troubleshooting guide on the Zwift support site with instructions for clearing down the BT config files on MacOS if you’re wondering how to do it.)

I’m brand new to Zwift. I had to buy the Zwift ANT+ dongle (it wouldn’t work with the Garmin ANT+ dongle). THat was only $38, so not a big deal. It made a big difference. Using windows 10, no companion app, Wahoo HR monitor, Kurt Kinetic Road Machine Smart trainer.

However I now notice that if I had a parallel app also connected to the speed sensor on my trainer (Kurt Kinetic Road Machine Smart, with ANT+ capability) then Zwift could not read it. In the past I could have my Wahoo Elemnt Bolt cycling computer and Sufferfest app both recording the trainer; I think they both “saw” it using ANT+, not bluetooth.

Ordered also an ANT+ dongle, hopefully it will solve my problem, and in the future, eventually, this bug will be fixed.

PS On amazon I paid around 20€ for the dongle plus a 3mtrs USB cable (highly recommended by everyone).

Will post when I will try the updated setup. And @Andy , I am curios to know what they say from ZWIFT development team.

when using a Windows Pc/Laptop you should use a ANT+ dongle, native Bluetooth is in Beta mode. My experience is ANT+ is far better than Bluetooth for this type of application.

I am not using the nativa Bluetooth (which I tried and didint work) but the Android Companion app

Ok, so you are attempting to bridge the trainer with the Zwift companion app. The first thing to check is if you are on the same wifi, this is usually the #1 problem.

I can confimr that we are on the same wifi-network

That is a good start, so you do see the Map on the Companion app. Next will be to check your wifi ports and firewall, see the link below.’t-pair-(cycling)-HJ5WR1ZHX

I have the same issue with my Tickr HR sensor not connecting to Zwift via Bluetooth. It worked fine before I upgraded my MacBook to Mojave OS. It will connect via ANT but I find that ANT drops the signal during my ride. Not as reliable as the Bluetooth pairing used to be. I’ve tried all the known fixes for Mojave Bluetooth issues. Hoping either Zwift or Apple come out with a fix.

So, verified that both devices are on the same network (also the same frequency).

Checked the ports in my router firewall, even tried to fully disable the WIN Firewall.

Still no success. What else can I check ?

To give some more info: after some time I started the Zwidt app on my PC, a notification message (from the squirrel) pops up saying that I should turn on my bluetooth receiver :confused:

Don’t know if it is relevant, but I had the problem that Zwift would not recognize sensors if other applications were also reading them.
Example: I often like to record a ride on Sufferfest (laptop via ANT+) and in parallel on my Wahoo Element Bolt bike computer. In case the app fails I will still have a record.

Sooo… This did not work with Zwift. If I had the Elemnt on, ZZwift would not pick up the sensors (even though it’s on a different device). When I ran Zwift first it DID pick up sensors but then I turned on the Elemnt and it would not pick anything up.

Quick update: the ANT + dongle made my day yesterday, as soon as zwirt was open, this immediately detected everything! Power, cadence,and also HR broadcasted from my Garmin :grin::grin::grin: still no signs from the Bluetooth side :thinking:

1 Like