Zwift not 'seeing' tacx vortex

Hi. I am trying to connect my tacx vortex to zwift on my android phone. Ive tried many different things like reinstalling and shutdowns but nothing. On the pair your device screen is doesnt even appear. It is however in the unnpaired devices under Bluetooth on my phone. It connects immediately to the tacx app and i have updated it.

Any help would be usefull
Thanks in advance

I had all kinds of trouble using the Bluetooth on my Tacx Vortex a few years back.

I changed to Ant+ and that solved all my problems.

1 Like

Hi @andrew_england

Welcome to the Forums!

This sounds like possibly another case where the Location service and privacy settings need to be enabled for Zwift BLE pairing to function on Android.

Check out my reply here on this Forums thread and follow those steps. Hope that helps!

Thanks for your reply. The location is on on my phone and zwift was set to allow. So no joy I’m afraid.

Looks like I may have to go down the ant route… more stuff to buy.



ANT+ can be spotty with Android from what I’ve seen, and I’ve heard that the resistance (like in ERG mode for example) doesn’t always work right when pairing via ANT+ on Android, but maybe others are happy with it. It’s hard to say.

Before you go and spend money on an ANT+ dongle, can you confirm that your Tacx Vortex is the T2180 model? To my knowledge, only the T2180 is compatible to directly pair with Zwift. If it’s an older Taxc Vortex (e.g. T2160, T2170, etc…) then it won’t pair to Zwift.

I hadn’t checked that. However, it is a 2180 model. Thankfully.

You need to be absolutely sure the trainer isn’t still connected to the Tacx app. Bluetooth works on an exclusive basis; if it’s connected to something it’ll disappear from the air and no other apps will be able to see it. Incidentally this is not the case on ANT+, which broadcasts openly to everything all the time.

Force close Zwift on your phone. Then within the Tacx app, ensure you actually click to disconnect the trainer, then force close the app. Turn off the trainer and wait 10mins. Then start Zwift, turn on the trainer and see if it appears for pairing.

Thank you so much for answering and helping me. Unfortunately it is still refusing to play on my phone. So I ‘borrowed’ the wife’s ipad and it’s straight in and connected.
Who knows why it wouldn’t connect but it’s now sorted - and as a bonus I’ve a bigger screen to watch myself suffer.

Thanks again

Hi @andrew_england

It’s good news to hear that the Tacx Vortex paired straight away on the iPad and that you’re back to Zwifting. I’m sure the bigger screen will be a nice bonus :slight_smile:

That’s still quite strange to me why the Zwift app on your iPhone refuses to see the trainer, whereas other apps on the same device (e.g. Tacx app) connect to the trainer, and the trainer connects without issue to Zwift on other devices in your environment (e.g. the iPad). Very puzzling.

I noticed you’ve written in to our tech support team for help with this issue, so we’ll follow up with some additional investigative work to see what can be done to restore your ability to pair the Tacx Vortex to Zwift on your phone. Thanks!