Zwift Companion for Android - No "Game Mode" Screen

Problem:

When Zwifting, the android companion app stays in “Home” mode only. No maps, no power meters no messaging, nothing but Home. I can see that it is connected, as it shows Zwifting Now under the Activities tab.

My Setup:

Computer - Core i5 2500K, 16GB RAM, 1 TB SSD, Nvidia GeoForce 760 GTX graphics, TCL 43" TV/Display, ANT+ USB dongle.

Companion Device: Samsung Galaxy Note 9.

Wireless: 2.4Ghz Wifi with security enabled, Arris router.

Bike - Trek Alpha 2.2, Wahoo rear hub speed sensor, Wahoo cadence crank sensor, Cycleops Fluud 2 trainer.

What I have tried to resolve this:

  • Making sure computer and phone are on the same wifi network.
  • Turn off mobile data.
  • Turn on airplane mode, then enable wifi transceiver only.
  • Uninstall, then reinstalled Companion App.
  • Switching to another device (Galaxy Tab E, Galaxy 8 Active).
  • Turn off bluetooth transceiver on computer motherboard.
  • forcing stop then relogging in to the Companion App during a Zwift session.
  • building a large fire, dancing around it while wearing a speedo and chanting “Lance”!

Is there anything else I might try?

Hey S. Kicker.

I do have a couple of other tricks that might help your Zwift Companion(ZC) connect to Zwift on your Computer.

  • Connect the computer to your home network with an Ethernet cable.
  • Always make sure that boht Zwift and ZC are up to date.
  • Waiting to start ZC until your rider is visible on the screen.
  • If you have the option to use 5 GHz instead of 2.4 GHz that can also help.
  • A less serious suggestion: the next time you do an elaborate ritual to fix Zwift chant “John” instead of “Lance”. Since John created the game, evoking his name is much more likely to get a result.:wink:

Let us know if you find additional workarounds for this problem.

Is there a resolution to this. I’ve tried all these suggestions to no avail.

Try contacting Zwift for support:

https://zwift.com/ca/contact-us

Hi @Adrian_Anastas_BCG, are you sure the device running the companion app is on the same wifi network as your Zwift device? This is required for it to work properly.

1 Like

Try to reset the Router, it can be that the IP address is out of range. Did you manually assign Ip addresses to the zwift pc or phone?

1 Like

It should connect vie Bluetooth, not Wifi

?? the companion app “talks” to Zwift through wifi, not bluetooth.

2 Likes

Sorry, was replying erroneously on the wrong thread.

1 Like

See forums.zwift .com/t/zwift-companion-no-game-mode-on-pixel-slate-chrome-os/224793/13 - I get the impression that the engineers don’t really care much about supporting their customers.

Why not contact Zwift support: https://zwift.com/ca/contact-us

Always feel free to contact us on the support team! We are experiencing heavy conversations flow right now, so it may take a bit of time before you get a response, but the sooner you shoot us an email, the sooner we can respond to it!

The main things to remember about ‘Game Mode’ on the Companion is that both devices need to be on the same network.

If you are having issues with them connecting and have confirmed they are on the same network, turn on Airplane mode on the Companion Device, then selectivly turn on WiFi to make sure BLE and Mobile Data aren’t messing with the signal (if you are pairing through ZC, turn on wifi and BLE, but make sure data stays off).

Power Cycling your router and modem is usually a good idea if you still have issues. Unplug your router, then your modem and wait for several seconds (10 is a good count), then plug in your modem first. Then your router. Once both devices are powered up and functioning, try again.

If you are still having issues, make sure to reach out to us right away!

1 Like

This has not helped. I have turned ble and mobile data off on my android phone, turned on airplane mode, ensured laptop and device are on the same WiFi network and updated both apps.
Still left staring at the companion home screen.
I’ve contacted support who just emailed me to try the forum…

1 Like

Yes, even changed the network name for the N and AC bandwidths to ensure they were the same. Did not help.

You may want to try @Paul_Allen’s suggestion in this other thread:

1 Like

I did. They sent me to the forums.

@Gerrie_Delport was able to solve his issue by using IP Reservations his router.

Gerrie, could you post the steps and/or screenshots of what you did when you have time.

1 Like

Sorry to hear that. It’s a little disappointing.
Hopefully someone with Android can help you. I use iPhone myself, so wouldn’t be able to be of much use here.
In my case it would’t work if I used by accident a different Wifi on my phone than on my game device.

Hi Adrian

Can you post here the network settings of your PC, and the network settings of your phone? Both are likely (hopefully) being assigned IP addresses by your router, and the addresses should be on the same subnet. If they are, you should also be able to ping the devices from each other. Now… if they are mutually pingable and on the same subnet, and if the companion app still doesn’t work, then I would be baffled!

They don’t need to be on the same subnet to ping or for the connection between the ZCA and the Zwift App to work.

1 Like