Companion App issue

companion

(David Bullock (Zbr)) #1

Hi guys and gals.
Having an issue with the companion app, on an Android Samsung Galaxy S8+, not showing the game screen when zwifting on my laptop since the updates.
I’ve installed Zwift on my desktop and another laptop and the companion app works with both of those straight away.
All these machines are on the same network so it must be a problem with my Zwifting laptop but what?
It worked fine last week and I’ve only used the laptop for Zwifting.
Forgot to mention, the app knows I’m Zwifting but doesn’t show the game screen. Both app and program are up to date.
Any ideas?

Cheers in advance
Dave.


(Aaron Zwanzig) #2

When you say it doesn’t show the game screen, do you mean that when you tap on the Map tab, nothing shows up? Maybe a screen shot would help to understand the problem.


(..Troy) #3

I think there are a few problems with the new updated app, see other posts.
Hopefully Zwift will see these problems we are having and sort the issues out.

“Ride On”


(David Bullock (Zbr)) #4

Aaron.
Look at the app when you are not Zwifting and that is what I get when I’m on the game.
I don’t have a map tab BUT the app knows I’m Zwifting as it says I am on the activity feed.


(Aaron Zwanzig) #5

It sounds like the Companion app is functioning properly because it connects with your desktop and the other laptop. Could there be a wifi or firewall issue with your zwifting laptop that keeps the companion app from connecting? I assume you’ve confirmed that both are connected to the same wifi, and that you are logged into the same account on both?


(Mark Dexter *Neo*) #6

I have a s8+ and have had previous problems like this. Try activating “airplane mode” and then deactivate it. Check you’re on the same wifi as PC/Mac? Go into app settings, search for companion check app permissions for location and storage is on. Click storage and clear cache.
Go into app and log out, close app, open app and log back in.
If that doesn’t work, change router channel to number 1. You’ll need guidance as per your router on this and you might have to log back on your wifi via S8+ and any other connected device, but not usually. Check Garmin conect or anything isn’t hogging. Try not to link BT through app and ant+ through hardware (PC)… If all fails, Uninstall app
Don’t do any of this before you’re going to zwift, it’ll end drive you bonkers if you cant resolve straight away or disconnects a sesh.

Good luck


(Joe Daknis) #7

The only time I’ve ever had this problem, it was because my phone and PC were inadvertently on different networks (e.g. if I had wifi disabled on my phone and it was pulling cellular data while my PC was on my home network).


(David Bullock (Zbr)) #8

Been working fine and now not working all week again. Was tearing my bloody hair out with it.
I uninstalled and reinstalled everything. Definitely on same Wi-Fi network. Tried airplane mode force stopping app, clearing cache everything. Nothing worked.
The one thing I hadn’t tried was re-booting the router. Tried it and WAHOO back working again. :grinning:
So guys don’t overlook the obvious like I did if you have problems. :roll_eyes:

:+1::+1::+1::+1: