Can't use companion app

Hello, Please forgive me I’m new on zwift and not very techie to boot!
I’ve got zwift installed on my android tv box and it seems to work fine. I’ve got the companion app installed on my Galaxy s8. They are on the same network although it’s via an access point router set up in a man cave in the garden, don’t know if there’s any issues here?

I can’t get off the home ZC homepage to control the game, any ideas

Hey John, sorry Zwift Companion is giving you trouble! Have you tried turning on your Zwift Companion first, then starting a ride on Zwift and see if your companion app changes screens?

Thanks for getting back to me Vincent,

Just double checked, done as you suggest and it doesn’t solve the problem

Solved it, the game hardware and ZC hardware had some constablity issues. Now I’m finally up and riding would it be possible to start my free trial from now? Just so I can give it a full test before purchase



Hi John. I’m having the same issues. No matter what I try, the ZC app won’t go into game mode. Same network. Router isn’t blocking any ports. May I ask what were the issues between the game hardware and ZC hardware that you mentioned in your last post?

My problem was due to the privacy settings for wifi on my android phone, try having a look there

Thanks John. My issue turned out to be due to a setting in the router (AP Isolation Mode) that I had enabled some time ago (and forgotten all about). Once disabled everything started working again. Thanks for taking the time to reply to my query. Regards.

1 Like