Companion app not sync on android - Zwift Companion v3.54

Hi guys
Any ideas, m companion app works, but it won’t link to game I’ve tried usual stuff ensuring thd WiFi is the same, u installing then re installing etc etc is it me or a bug in companion. My phone is six months old so I doubt the phone is ‘not compatible’, and up till my ride event Sunday early evening it was linking to game OK.

Hi Donald,

If you haven’t done so, make sure your mobile internet is off by setting your phone in Airplane Mode and Location permissions are enabled on your phone. If you’re still having issues, it could be that your router is blocking traffic. We have some additional steps you can take in our Issues with Zwift Companion App guide.

If you’re still having issues after taking those steps, please reach out to Our Support Team.

Sometimes rebooting the phone and all your network equipment helps. The suggestion to use airplane mode and then manually enable Wi-Fi is also sound.

This can sometimes happen if the companion app is not up to date I’ve found.

The other solution I find that is reliable is to do following:

  1. close companion app
  2. disable all connections (wifi, mobile internet, bluetooth)
  3. Load companion app, click on refresh when it says no connections available
  4. Now enable the connections again then click refresh once more

App should now connect properly. Sometimes you have to do that when the connection of the app drops out for no apparent reason. For me this isn’t required too often - but it used to be.

Yes tried all of the above and it still doesnt link to game. Or even a workout.

Hi @Donald_Gino_Howe_Vel, thanks for trying the steps suggested. When you said that the Zwift companion isn’t linking even a Workout, Did you open one in specific? If so, Could you please, confirm which workout you were trying to view?
Also, you mentioned that might be related to phone compatibility, if you have another device, please try to connect the ZC. This can help us to narrow down where the issue is coming from.

Hi Martha
Its definitely NOT the phone or wifi. I have reset the phone back to factory settings and it is still the same. I have even tried on my son’s new phone and its the same.
When i am in game on the tv screen via my pc, I open companion, expecting to see the game on the dropdown menu but it is just not there.
Also the top left of the page looks odd in the headings…see attached phone screenshot pic…as you can see, no game option
It is very annoying as its difficult to txt with full size keyboard whilst pedalling , and missing the other in game features…

Hi @Donald_Gino_Howe_Vel Thanks for your reply. This is Juan here from Zwift. I understand this could get a little annoying. Establishing a reliable Zwift Companion connection is the most important thing to take advantage of the game’s features. There is a few basic things you should check.

  • Same Network: your phone running Companion must be on the same local network as the Zwift device.
  • Same Login: make sure you’re signed into Companion with the same login as the Zwift game.
  • Get the Most Recent Companion Version: make sure you’re running the latest version of Companion by going to your list of app updates. We have launched an update for Android today.
  • Firewalls/VPN/Proxy: You may need to open some firewall ports or make other exceptions so Zwift can function correctly. Learn more on Zwift’s support page.. Anyhow, I encourage you to open a support ticket to provide you with a personalized follow-up on your issue. Please write in zwift.com/contact-us.

All seems to be good again, since update on or about 21/02/2024…funny that.!