Zwift Click does not work


I have a problem with may Zwift Click 30BB. I ordered the Zwift hub 3 weeks ago - I am inexperienced with all this.
I installed the companion app and updated the latest firmware. When I start the Zwift app I can connect my Click with the App. But when I join a race I can’t use my Click. When I press ‘+’ the Click disconnects from the app. After that the LED goes from blue to green to red. When I wait a little bit the Click reconnects with the app again and the LED blinks constantly blue - as long as I don’t press the button.

I am using the Zwift app on my iPhone X and share the Screen via Screen mirroring to my TV.

Do you know this problem?
Thanks you.

Hi @Stephan_Mann
Welcome to Zwift forums. Shuji at Zwift HQ here.

I believe you, but I’m looking at your server logs and the last time I saw a clean connection to your Click on January 3, it was on firmware version 1.0.0. The latest version is v1.1.0.

Please check the Companion app and verify that you’re on 1.1.0. It’s possible the firmware update process may not have completed.

#2 - I’m also seeing you log in from two different iPhones. I imagine that’s because you’re troubleshooting, but what’s happening is that you’re logged in on two different devices at the same time, and the Click can only pair to one device at a time.

Always save & exit (or trash and exit) your Zwift session, then force-close the app. Swiping the app into the background is not the same - the app continues to run if you do that. If you want to completely avoid concurrent logins - install the Zwift app on only one of your phone, and uninstall on other devices.

1 Like

Thanks for your answer, that was really helpful!!!
I will try to fix it tomorrow. How could you see the Version I was using?

Yeah I was using an other phone because I thought this was the problem. I will only use one device in the future - thanks for your help!

I work at Zwift HQ.

1 Like

Hey @shooj

Today I started the companion app to look up which firmware I am using. I connected my iPhone with Zwift click. In the companion app it says I am using Firmware Version 1.1.0, the Zwift hub version was also the current version.
So the problem is not solved yet… The discribed problems have occurred again.

I joined Watopia to give it a new try. But when I press ‘+’ on my click, the connection disconnects. After the LED goes from blue to green to red it reconnects after a few seconds.

I also turned of the second iPhone - so only one could connect with Zwift.

I also took a video of it.

I have the same issue after updating to 1.1.0 - I do see a connection error in Mac swift app!!

1 Like

It worked Friday like a charm but now nothing and it does not matter if I connect through the companion app
Or Bluetooth in the Mac app

1 Like

Please keep me updated if you know how to solve the problem.
I can’t fix it, I tried a lot… unfortunately.

1 Like

I see mine disconnects Everytime I click plus, it happens 100% of the time now!

I have emailed Zwift with a video. I will let you know what they say.

1 Like

Thank you very much!!!

Hey Martin,
Could you fix the problem?
You can add me on companion (Stephan_Manner).

No, I am in contact with the technical support, I need to try a few things - but I am quite sure it’s broken as it disconnects every time i click +. So I am just going to make a video of that as well.

Hi Shuji.I am continuing to have connection failures on my Zwift Click gear shifter. I am using a Zwift Hub via a brand new iPad Pro, with no other added apps, and nothing else connected to the Bluetooth. iPad, Zwift Hub and Zwift Click are all on the latest versions.
The problem has been intermittent, but is getting steadily worse. In the last couple of weeks, it has reached the stage where it works for just a minute or two when starting a route, then drops out and returns for a few seconds at rare intervals. This happens however long I ride.
I have followed all advice and recommendations from Zwift, including making sure all other Bluetooth devices in my house are switched off, no other electrical devices are in the room, any cables are shielded, and the Zwift Click is just 2" from the iPad running Zwift app.
To ensure that the iPad is not the problem, I also tried it on a Windows Surface Pro, with identical results.
Please can you help me. I love the shifter when it works, but it’s ruining the whole game for me ATM!
I know it’s not my set up, as when I first had the Click, it worked for weeks perfectly, and absolutely nothing has changed at my end.

1 Like

Could you fix the problem?

Hi Stephan. No, the problem is still exactly the same. Sometimes it works for a few minutes, mostly it just works intermittently for a few seconds. Sometimes it just goes up through all the gears (without any input), and locks up there.
It’s such a shame, it makes doing climbs impossible!

that’s annoying! I don’t know what else I could do to solve the problem either. I’m a little disappointed

Is it just us having this problem? I saw a few reported at the end of last year, but Zwift are being very quiet about it!

Have you had any response yet? Despite trying everything that Zwift recommends, nothing has changed with my Click connection failures - in fact it seems to be getting worse.

Yes sorry - i filmed the issue and they have shippped med new clicker.