Wahoo Kicker connected via Bluetooth, but no Power and No Movement of rider

Hi!

Joining this thread as I’ve also experienced the same with my Kickr v.5, bought in late 2020. The problem with no power/cadence or power frozen at around 50 watts first occured in november I think, but wasn’t that bad and the Kickr came around in a few minutes to perform just normal.

Recent days though it’s gotten worse, but it still comes around eventually. My thoughts are that the auto-calibrate phase, which alledgedly is around 6 minutes is where the problem lies. Past days I’ve kept pedaling for anything between 8 and 15 minutes, after which the Kickr has come alive and power readings have been normal and consistent.
I haven’t contacted Wahoo yet, but I will reach out to them to see what they make of my observations.

Question to the forum though is whether others are experiencing the same wake up cycle?

It’s well worth contacting Wahoo. To be fair, they were very good with me. My trainer was out of warranty and stopped showing speed / cadence / power data. They have sent me a replacement which is not up and running perfectly. Good luck!

2 Likes

Peter. Kind of experienced the same in December. Good intentions to get back to the fitness levels I had during the Pandemic.
Got a couple of good rides. Then it started to have issues. Delayed connecting to zwift. Then really delayed. Then nothing.
Nothing worked to fix the issue

contacted Wahoo. Provided all the information, testing & checks that they needed

Nothing worked to resolve the problem and a refurbished device was sent to replace the hardware I was instructed to disable, cutting off the power connector.

Replacement All working at the moment. Might just be my imagination, but I think it might be slightly noisier than my old kickr

My advice is: Contact Wahoo to get a solution. You paid $1000+ for a Kickr. It should not be a bad experience. You should be able to hop on and cycle without a 15min diagnostics session to get it working.
Note: That 15mins will be longer and longer till noting works.

Andrew

1 Like

Same situation. V5 kickr. reached out to wahoo and got some troubleshooting steps. Left everything unplugged for a few days, then it worked once, and now failing to work again. Instead of exercising I’m doing bluetooth and computer reboots. Working up my blood pressure but doing nothing for my cardio endurance!

I have had exactly the same problems as described in this topic. Kickr V5 purchased in Jan 21. Lights all on and will connect to Wahoo app and Zwift but power, cadence and speed all reading zero. The device has been working perfectly for 3 years.
Have just started a ticket with Wahoo and I’m awaiting a response.

Similar situation for me. Have spent considerable time this morning trying to rectify. Connects to Zwift and Wahoo App ok but not transmitting power, cadence or speed data so hence useless.
Found this thread and have tried everything suggested to no avail.
Have reached out to Wahoo for next steps.

Hi @Simon_Mann, welcome to Forums. I’m Juan from Zwift. Thanks for sharing your situation here.

Since you mentioned that you could pair it to Wahoo App but not transmit power as well, the issue might be with the trainer itself. While you wait for updates from Wahoo, I think it might be a good idea to try updating the firmware if any are available. Please check for the Wahoo firmware release notes for Kickr.

A firmware is software that physically manages the hardware because it is responsible for activating the different functions that make it possible for the trainer to turn on, as well as executing the commands to start operating.

Hi Juan, running firmware 4.3.0 which I understand is the latest for v5 Kickr.

Cheers.

When you do a ride in the Wahoo Fitness app, with Zwift completely shut down, does it transmit power?

I have the same exact issue today, trainer has been working fine for about 4 or 5 years. Today it stop reading power, it will connect and it reads hr data as well as a cadence sensor but no power at all. I put in a ticket through their website, we shall see how this plays out.

I have a Kickr Rollr. Used it probably 100 times since October and never had an issue. It sat for a month, then last night I turned it on to ride. Zwift did an update first. After that, everything would connect (Power meter to Rollr, Rollr to Zwift) but all zero readings… nothing works. I might still have my old version of Zwift saved on the PC, so I might try and reinstall the old version to see if that helps, if it even works at all. I am NOT sending back a Rollr… I don’t even wanna try and box that thing up. Super bummed as I can’t ride outside currently due to kids etc… so I can ride with zero data and elevation, or just look at it sitting there.

Test it with the Wahoo app. What do you see in that scenario?

When I attempt to connect my wahoo kicker to Zwift, via my iphone, Zwift doesn’t sense speed or cadence. When I use Zwift with my laptop, Zwift does sense speed and cadence, and I can ride. Troubleshooting this issue was very frustrating. My one hour dedicated ride time turned into one hour of troubleshooting. I’ve read the forum threads about this connection issue and realize my troubleshooting effort isn’t over yet. Who own’s this issue; Zwift or Wahoo? Right now; Zwift + Wahoo = Very Frustrating!

1 Like