Wahoo Kicker connected via Bluetooth, but no Power and No Movement of rider

Hi- On Zwift, I have a Wahoo Kicker smart trainer that has been working but not in last week. Bluetooth connects. Cadence works and heart rate works. I’m connected but my power does not read and my rider does not move. I can’t even do a spin down because the mph does not read. Please help. Not sure what happened as this setup used to work great. thanks Scott

Hi @Scott_Duke, welcome to the forums.

With your Zwift app off, and power cycle your Kickr (leave off for 30secs then plug back in). Then try a spin-down on Wahoo app (don’t use Zwift for your spindown). Force close Wahoo app to ensure it’s not grabbing a signal from the Kickr then fire up your Zwift app. Then in the pairing screen, remove Kickr from paired devices and let Zwift rediscover them.

FWIW, with the release of the urgent update in pst few days to fix ERG/resistance problems, I can no longer use Bluetooth but I’m fine with that as I prefer ANT+ (and I didn’t try to troubleshoot the BT issue).

Thanks for the reply. So, I do not see how to do a spin down on Wahoo. I tried doing that on Zwift, but it is not reading speed or power. Same on Wahoo app, not reading mph or power. App is connected but no reading of those two sensors. I have a second bike on a Kickr Core and everything there works great. I’ve shut down all competing items and still nothing from speed and power.

You likely have a more recent Kickr that self-calibrates in which csae you shouldn’t really need to do a spindown however you can still do a factory spindown in the Wahoo app - checkout this article:

The fact that Wahoo app isn’t reading any power suggests that it’s a Kickr problem and not Zwift.

What are the LED’s doing on your Kickr?

yep I agree that it is a Kicker issue, not Zwift. I have referred to the Wahoo website and have sent them an email too. LED lights are solid and connection is made. I even went old school and went ANT+ on a laptop to connect and Speed and Power still not connecting. Luckily I still have receipt! Thanks for the help.

1 Like

This issue is so frustrating especially when you need to get a ride or workout in with limited time.
It makes me pray that someone is creating an easier fix or is creating a company that will fix all of this-we just want it to work.

There isn’t even an easy 24 7 helpdesk to call for people to get automatic help.

So frustrating and not the first time.


Do tell Wahoo about your experience. That’s who needs to take action to improve your experience.

thank you. i have now. thank you!

I’m having this exact problem today after swapping my wife’s bike with my own.

Everything paired and connected, zero speed, cadence or power.

I am having the same issue as of a week ago. Trying to work with Wahoo tech, but process is painstakingly slow.
Please let the string know if anyone figures this out.

I am too. Kickr stopped broadcasting to Zwift and to TrainerRoad.

Same issue today. My kickr V5 just stopped to boardcast power and candance. My 1030P cannot get power data from it now. This is surely a kickr problem, it works perfectly for more than 2 years before even last time i Zwifting

Same issue today. Worked fine just two days ago. Can’t do anything. I followed instructions on the one comment and still nothing. Can’t talk to a human at Wahoo so my optimism is all time low. $900 door stop at the moment.

I updated my own question regarding this issue. I took the approach or deleting the Wahoo app and repairing the trainer. The app registered power, speed and cadence again. Zwift started working again.

So this just happened to me. Have no idea what to do. Trying Wahoo support but of course not a single human to talk on the phone with yet.

Hello all,

Recently my Kickr has had trouble working with Zwift. It will intermittently have an issue where it will connect to the zwift app on my macbook via bluetooth, but once I’m in game the cadence and power read as 0. Sometimes it will read my inputs and cadence will perfectly, but the power numbers will get stuck and won’t go up or down. After, closing the app multiple time, restarting the computer multiple times, and unplugging the kickr and plugging it back in it will seem to work. There doesn’t seem to be any rhyme or reason to this. Seems like it only works when it wants to. The few times I have connected it to the wahoo app on my mobile device the readings seem normal.

I am running:

Kickr 20 (i believe)
Macbook Pro (2016)

Plz help.


Have you ever signed into another device to Zwift? If you are logged in to more than one device at a time, things usually start breaking. Make sure you sign out of all devices, then log back in on your Mac.
Also, maybe try leaving everything powered off overnight. Kickr, Mac, any other Zwift tools. I don’t know if it will help, but I find that leaving all my stuff plugged in for a long time will eventually lead to problems.

I just recently started having the same issue. Has anyone found a solution? Everything was working fine until I came back from out of town last week. Got on my bike and fired up Zwift on my MacBook. KICKR connected just fine (cadence, power meter) but when I start pedaling…nothing. No cadence no watts. If I start the Wahoo app, it reads just fine. But Zwift…nothing. Any ideas?

1 Like

Yup. Same issue here after 3 years of flawless use. I am connected, but no power or resistance. Switched over and tried the wahoo app and it is the same deal - suggests it is the trainer.

Trying to figure out if it is just time to get a new trainer - this one is out of warranty. Frustrating because I have a first gen Kickr my wife is using that still works just fine. My v5 is an expensive paperweight.

1 Like

I have not found a fix yet. I have used two (2) different ANT+ dongles and each connect to Zwift but not Wahoo. The Wahoo app asks for a “Product ID” which doesn’t exist anywhere in the paper work for these dongles (Coospo and Garmin).

I had the exact same issue. Was hooking to my Dell XPS via Bluetooth and all of a sudden it just died. No power, cadence, speed, and my avatar just sits there.

I got it work ONCE by deleting the Wahoo app, repairing, another Spindown which feels off too, and then it worked. It worked once and never again.

I’ve been waiting two weeks for a reply from Wahoo after sending all of my information to them at their request.