Wahoo Kicker connected via Bluetooth, but no Power and No Movement of rider

I had the same problem today. Using a Kickr that has worked for years, a Stages cadence monitor, with Apple TV. Both Kickr and Stages showed connected on Zwift, both read 0 when pedaling. I unplugged the Apple TV and then plugged it back in. All working now. Hope this helps someone.

This is insane - mine literally worked last night flawlessly and tonight same issue as everyone above. Removed Zwift and deleted and reinstalled Wahoo app and it connects on both but no power, speed or cadence. Multiple hard reboots and nada…. Will hop in Wahoo queue tomorrow morning

Thanks all especially Andrew. Wahoo reveresed their decision and wanted severed power cable photo and will send replacement. Good start to the day, Wahoo does right thingvin end.

4 Likes

That is that same outcome I had.

It’s a WIN! all round

Update - Wahoo was johnny on spot with speedy reply and honoring warranty for replacement. Once confirmed I had latest firmware and done their troubleshooting instructions with no resolution they just need picture confirmation of cord being cut and serial number with original receipt of purchase and they are shipping a replacement out. Thanks Wahoo for great customer experience and folks here for helping narrow down the issue and pointing me to Wahoo support.

2 Likes

Are people who purchased second-hand Kicker’s out of luck? It sounds like I’d have to be covered by the warranty and have receipts.

It is worth a try

I think they will want to see an invoice direct from them or a legit reseller.

Not sure what the situation is with the refurbished unit they offer as a replacement.

I hope you succeed.

Just joined the club
New device bought back on December 6, 2023
Same symptoms
Submitted support Ticket
I’m in Kazakhstan so a bit sceptical about replacement Service

1 Like

Same issue for me for my KICKR Core. I actually had this happen a few months after I first bought it back in 2019. I was able to get a replacement through my bike shop at the time, and have religeously unplugged the device after use each time since then, because I had read on a blog that the optical sensors could get too hot and burn out. Don’t know if that’s true, but for the first time I left it plugged in today and it just stopped working. Or maybe it was the firmware upgrade that I loaded? Either way, am hoping that Wahoo will help out. I realize I have had years of use for this thing, but clearly there is a faulty part or design that is contributing to so many similar failures. Sounds like a class action waiting to happen.

I’m having the same issue with a unit that worked flawlessly since I purchased it. Initially received a faulty unit in 2019 that didn’t work out of the box but it was replaced by Wahoo and the replacement worked until today. I reached out to Wahoo and am working with Chad C. on a resolution. Hoping Wahoo does the right thing and replaces the unit.

Exact same here, did not use the Trainer, was out of the country for holidays, came back two weeks ago. No reading. Proper connection, but 0 reading.

Was so happy with my kickr, … very much hope for an understanding support.
My challenge, I am worked the last years all over the world, bought the Kickr in Dubai 3y ago and residing now in the US. So lets see how this goes. Would be a big plus for customer support if supported , fingers crossed.

I know if you have bought the device second hand (ebay, etc) they would not get involved. It had to have been bought direct from wahoo or via a reseller.

Having documentation like a sales invoice is ideal. Not sure what they do if you can’t.

I never had an actual invoice that showed the item. All I had was a credit agreement with a bike shop for the price of a Wahoo Kickr

I too have a Kickr 5 purchased 10/2021 which has performed flawlessly until a little over a month ago. At first just kept rebooting until it worked, which is nerve-wracking being on a racing team in ZRL. I tried various fixes and finally opened a ticket with Wahoo. After troubleshooting with Wahoo I am now waiting to hear from warranty. Right now as a work around (power issues got worse till nonfunctional) I am using my Favero assioma power pedals for power and cadence and Wahoo for resistance only. Sometimes I get a momentary drag in resistance but so far I am able to Zwift until resolution occurs, hopefully soon!!

As someone who rides daily and with a few years now on the kickr V5, I have wracked my brain with this issue for a few months now. My final solution was to adjust the distance of my router/modem and placed it five feet away from the new smart tv so basically I spread out the distance between Apple TV, the TV, and and the kickr and finally have been back to normal.

Whether it was due to additional interference which can happen even if the device is off from what I understand, or some recent update, I’m not sure. Posting this as an additional troubleshooting step, hopefully it works for others as well.

Good luck

I have found the same issue today. Everything is connected properly but my avatar on zwift does not move and there is no power, cadence or speed data. Someone suggested doing a spindown on the Wahoo app but nothing works there either, despite the Kickr showing as connected. I’ve emailed Wahoo so hopefully they will sort it. Very frustrating but it seems I am not alone.

Same. Been fine for two years. Seems problematic after last updates.

What device are you running zwift on? There was a very recent update which helped Mac users, but not people like me running on an iphone.

As another data point, I just ran into this issue with a Kickr Core purchased Nov 2023. Five minutes into a ride, the trainer lost resistance, power went to 0 watts, cadence went to 0 rpm. Same in Wahoo App, and no luck with any of the troubleshooting steps. I upgraded to the latest firmware to get auto spindown and virtual shifting (v1.3.17) about a week ago, so wondering if this is related.