Kickr - Not sending speed, cadence, or power info

So I picked up by Wahoo Kickr, set it up, ran the spindown and all seemed OK. I downloaded Zwift today and tried to get my first ride in, but biker wouldn’t move. Read some ideas on troubleshooting, so shout everything down and just tried to run the Kickr with the Wahoo app. No speed, cadence, or power data showing at all. Unplugged the Kickr, unpaired, made sure all other apps were closed, etc… Still nothing. This is literally brand new and never been ridden. So extremely frustrating. Any thoughts or help appreciated.

If you can’t get the Kickr to show you power and cadence when you’re paired directly to the Wahoo app, then it’s time to contact Wahoo support.

Try uninstalling any Wahoo apps and only having the Zwift one. Too many apps trying to control the Kickr can be an issue. When you first get Zwift open make sure you’ve paired the Kickr, the cadence too (middle bottom row of the symbols on the pairing screen) and it’s also controllable (bottom right).

If it’s not even pairing with the Wahoo app though then either the Bluetooth isn’t on/working or it’s more serious.

@Clint_Cadwallader

Welcome to the Forums!

So, if I’m not mistaken, it sounds like you’re not able to get power, cadence, etc to register on Zwift, nor on the Wahoo app, correct? If so, as Steve suggested, then that’s definitely something you’ll want to contact Wahoo Support about.

Sorry to say, it could very well be a hardware issue with your KICKR. Have you updated the firmware? See this article for more info.