Tacx Neo Smart 2 cadence fluctuating widly or showing no signal

trainer

(Vernon) #41

Pc with ant. But I have tried BT as well. No joy with either.


(Steve Barnard ) #42

A new Neo2 here… arrived with firmware 0.0.0 asked tacx re date and was told fw18 was ok… have bittern the bullet and updated the neo2 and so far all ok via Bluetooth and Ant+ on a Windows pc in zwift with companion app… Have checked bthe power and cadence with wahoo elemnt and they match… hope this helps someone.


(Lewie) #43

iOS update today for Zwift. Cadence fluctuates more than before. 6-15 rpm jumps. Current firmware is 0.0.18. Hopefully TACX gets it fixed soon!


(Milan) #44

I bough Tacx Neo 2 last week, as above mentioned, arrived with FW 0.0.0, upgraded to the last one FW 0.0.18, connected to PC with Windows 10 by ANT+ FE-C and the cadence sensor shows No signal in FE-C mode… I have owned Elite Drivo II before and this type of connection was without any problem.
I can not connect the cadence properly by other protocol in Zwift, controllable trainer and power source are connected OK…

When I have tried another type of connection (I think cadence/power ANT), it was connected and showed figures, but it leaves the connection during the race ride at once and I was stopping on the road… :o/
It was frustrating, so I take Garmin cadence sensor and connected it with success, it shows figures and I can ride on Zwift.

Please, what do you suggest me to connect cadence on Neo 2?