Tacx Neo Smart 2 cadence fluctuating widly or showing no signal

trainer

(Vincent W.) #1

Hey Zwifters,

There have been several reports of the Tacx Neo Smart 2’s cadence fluctuating wildly or showing no signal. This may be occurring over BLE specifically although we are still investigating. Reports have mostly been from iOS and Mac users. This post will be updated as new information is received. Thank you for your patience!

[ZG-5030]


(Saluki MBA) #2

tested with other apps and the Tacx Utility app and cadence works fine. TACX sent a link to a firmware update (Version 1.8) to be released later this week. If you need it send me a message and I will forward link, or contact tech support at TACX.


(Russ Gilbert) #3

I ordered a Tacx Neo Smart 2 yesterday from Zwift. I’ll check what version firmware it comes with. I connect via ATV 4K.

Russ


(Norbert Koch) #4

Hi Kevin, I have also with my combination Tacx Neo 2 Smart Trainer and ZWIFT the Problem, that the cadence fluctuating wildly. I have tried to solve the Problem but without success. So it would be nice, if you sent me the link. What must I do? Sorry but it was the first time, that I commucate in a Blog


(Vernon Mc Nees Cochrane Ab) #5

Could you please send me the link for 1.8.

I’ve tried Zwift, Sufferfest. Tacx desktop and Tacx utility. Same result in each. Wild swings in cadence.

If I use my separate garmin cadence and leave speed, power and control to the Neo, all numbers are solid.

I feel that this is not an app issue but IMO a hardware issue.


(Jennifer Louise) #6

My Tacx Neo 2 the cadence is all over the place and down hill it doesn’t seem to give the push the way the tacx neo 1 does (my partner has next to mine)

Help… would be great to fix the cadence


(Vernon Mc Nees Cochrane Ab) #7

I agree on the downhill. Nowhere near the Neo 1 downhills. I receive a note from Tacx support asking to upgrade to the latest firmware by the Tacx app says I’m already there.


(James Bennie (Team WFPB)) #8

FYI:
I noticed this today that my cadence was wildly fluctuating when I was steady at 90-100rpm’s. It was going into the 140’s and staying in the 110 to 130’s mostly.
Tacx Flux S smart connecting via BLE to Windows 10 on MSI I8 2.2 Ghz brand w/ Nvidia GTX 1070


(Kyle Cressman) #9

I noticed this on day one with the Neo 2. I ended up using a different cadence sensor and it is working fine. Hopefully the update I downloaded to the trainer fixes it. It is now indicating and seems consistent. Will update this if I see any more issues.


(Vernon Mc Nees Cochrane Ab) #10

I have a Neo 2 and downloaded the update to go from 0.0.15 to 0.0.18.

My cadence is now not working at all. It was previously fluctuating as you have described.

I’ve gone back to my garmin for Cadence until the next update.


(Jennifer Louise) #11

I downloaded the update off this forum I found in a link on another topic - it’s not ‘released’ yet but it has solved the cadence issue on the neo 2… :slight_smile:


(Vernon Mc Nees Cochrane Ab) #12

Hi Jennifer,

Can you share the link please?


(Steve Rice) #13

Yes, please share the link. Is the firmware 0.0.18? Are you using Bluetooth or ANT+? Just riding or are you using ERG mode?

Thanks
Steve


(Vernon Mc Nees Cochrane Ab) #14

I have an open case with Tacx on my Neo 2. After the upgrade to 0.0.18 (as above) the cadence does not work at all via BLE or Ant. There response to my issue is below. Your case may be different.

I have one final question into Tacx. I’d like to try a downgrade and then back up to 0.0.18 again.

Update from Tacx suport:

Robert - Tacx support team (Tacx)

Jan 9, 19:46 CET

Dear Vernon,

We are sorry to hear that.

Unfortunately there is nothing else we can offer.
Can you please contact your dealer so that the trainer can be sent for a warranty checkup?

More information about our warranty conditions can be found on our support page:

Kind Regards

Tacx Support


(Jennifer Louise) #15

Here’s what I found on another forum and it worked!

I’m using bluetooth. Haven’t used erg mode, but this has definitely fixed my issues… Cadence and down hills now working properly.

We believe that we found a solution for this by updating the firmware.
This firmware is not available in the Utility app but will be released soon.
You can also upgrade the firmware via the file in the link below:

Can you please try attached download firmware link on your smart trainer with the Tacx Utility app.
Forward his email to an mail address that you can access on your smart phone.
Now open the email on your smartphone and click on the link below:
https://drive.google.com/open?id=1KHYsvoaYeLootSQmjN0dxBl00PWGNN_9
Be sure to click on the download button (marked by a red circle in the image below).

Choose to open this file with the Tacx Utility app and connect your trainer (wait for the circle to become green).
When your trainer is connected choose “Update” to begin the firmware installation.
Wait for the firmware installation to complete and follow the instructions on screen when necessary.
Once the firmware is installed, you can use your trainer again.
Sorry for the inconvenience.

==> The version 0.0.18 for Tacx Neo 2 in the Tacx Utiliy App solves the problem of cadence in Zwift ! :slight_smile:

Thomas


(Vernon Mc Nees Cochrane Ab) #16

Thank you Jennifer,

I tried the link and the update was installed. Unfortunately, I may have a hardware issue. I’ll take the Neo back to the dealer.


(Vernon Mc Nees Cochrane Ab) #17

Update to all on the thread. I hope this helps someone out there.

I heard back from Tacx early this morning. They gave me a new version of the firmware. Version 0.0.19. Following are my results which are the same for both BTLE and Ant+.

Tacx Neo 2 testing complete.

Update to Version 0.0.19 from 0.0.0
no change. Cadence does not function.

Update to Version 0.0.19 from 0.0.18
no change. Cadence does not function.

Downgrade to 0.0.18. from 0.0.19
Still no luck. No cadence.

Downgrade to version 0.0.15 from 0.0.18
all is working including cadence.

Update to 0.0.19 from 0.0.15.
No cadence.

Downgrade to version 0.0.15 from 0.0.19
all is working including cadence.

I should also mention that I took the original Neo 2 back to MEC (Mountain Equipment Co-op. Best outdoor company in the WORLD!!). They replaced the Neo 2 with a new unopened box trainer. I brought it home and firmware version 0.0.0 was what I was looking at. The above is the process from bringing it home.

I do hope that Tacx will be working on a functioning upgrade very soon.


(Mark Donaldson) #18

Thanks for that Vernon - Very Comprehensive testing there which seems to indicate 18 and 19 both broken and 15 the only one that works.

I downgraded to 15 (from 18) after getting a link to it and I can report that it also fixed my cadence issue.

Hopefully TACX can sort it out very soon.


(C Gibbons) #19

Hi mark and vernon i also had this problem so downgraded to 00.15 and cadence was fixed but now have no uphill resistance or Roadfeel how are yours with this


(Vernon Mc Nees Cochrane Ab) #20

Have you checked under the Tacx utility and tested the road feel there? If road feel works there, then there’s a switch in Zwift to turn off or on.