Cadence seems not to work correctly with Tacx Neo 2T Smart

Problem: i have a new Neo 2T - everything seams to work well with Zwift App (and Tacx App) except cadence. Using Tacx (iPhone, Mac) cadence remains cero while riding. So I thought the cadence sensor is broken. (Yes I’m using the metallic crank extension (Garmin)). While testing Zwift to see if the cadence is displayed, the cadence remained in zero in the start/ pairing window while moving the crank, but cadence was correctly displayed in the rinding/ training window.
So what is going wrong? Thanks.

Hi @Johannes_Zaspel welcome to Zwift forums.
Have you tried updating the firmware on the trainer?

I’m not sure what this means, so i googled it and this thread came up on Garmin’s support page. It sounds like other Neo 2T owners have had issues with the cadence signal, so you may want to run your question past our friends at Garmin.

Hi! Thanks for your answer!

Yes, I updated all devices- newest software is running.

And I am in contact with the Garming support. Telling them about my problem with the cadence sensor they send me the crank extension (as described in their support website).
Because this didn’t work with Tacx App I tried Zwift (I wish to keep on using it) and the result is quit interesting.
I thought that may be you have a idea what’s going wrong. As I told you the sensor seams not to be broken because the Zwift Apps are displaying the “rpm” while driving/ training. But it remains in cerro in the pairing window while turing around the crank.

So the problem is quit unclear to me.

Thanks,
Johannes

Mit Spracherkennung erstellt - bitte entschuldigen Sie diesbezügliche Unzulänglichkeiten – von meinem iPhone gesendet

@Johannes_Zaspel
Sounds odd. Any chance you can take a screen capture of where you see / don’t see the cadence RPM in-game and drop it into your next reply?

Hi, thanks again for the quick answer .
Here are some screenshots:

One showing Zwift paired devices screen: rpm cerro

  1. : Zwift training window: rpm 31

  2. & 4. are Tacx Windows - utility App & training app: rpm in cerro.

I can repeat this scenario the times I want with Zwift so a think that this isn’t a fake.
I was driving slow. So rpm isn’t high. When driving faster rpm is going up…

So what could this bee?

Thanks again,
Johannes

image4.jpg

Additional information:
Rpm doesn’t work while using my Edge830… (ATN +)

Sorry, but still I am wondering about the problem I have with the cadence frequency.

Making some other simple tests like passing my hand near by the cadence sensor (Tipp from Garmin support) no rpm is displayed in the Tacx app’s and pairing Zwift window.

No I am wondering if Swift displays a cadence frequents calculated by the program itself when there is no real hardware sensor working or in other equipment simply not existing? This could be in my opinion an explication why Zwift is displaying in the training mode rpm even though my sensor seams not to work.

Thanks

Mit Spracherkennung erstellt - bitte entschuldigen Sie diesbezügliche Unzulänglichkeiten – von meinem iPhone gesendet

@Johannes_Zaspel
Thank you for attaching the photos and the additional backstory w/ your interaction w/ Garmin’s support team (them sending the crank extension).

The photo from the Tacx app show that the trainer’s serial number device is 06508. The picture of the Zwift app shows the Power & Controllable signals are from 06508, while the cadence signal appears to be 04508 (that picture is a little small & blurry), can you verify?
04508

This discrepancy might be due to the extension thing that Garmin sent you? One possibility is that the Zwift app is remembering the previous cadence sensor, and not the current one. There is an XML file on your computer that the Zwift app creates that remembers which signals it’s bonded to in the past.

The easiest way to delete that file is a total uninstall / reinstall

  1. In Finder (noticed you’re on a MacOS) search for “Zwift”
  2. Delete every folder and file that comes up in that search
  3. Download and install Zwift
  4. During the install, you’ll be prompted for permission to write to your Documents folder. Say yes to all the prompts

When you run the app - pay attention to the device numbers for the Power / Controllable / Cadence sensors. They should all be the same 06508. Would you try that and let us know if your cadence is no longer zero in Zwift?

One last thing: most (not all) sensors that broadcast over Bluetooth are only capable of connecting to one app at a time. Some are capable of multiple simultaneous connections. I’m not sure if the Tacx Neo 2T Smart can do that. Unless you’re calibrating the trainer, it’s safer to make sure the Tacx utility is closed (or uninstalled from the phone) to ensure that it’s not robbing the Blluetooth signal from the Zwift app.

Hey again,

After re-instaling all serial numbers are the same — but the problem remains the same. On this pairing side no cadenza frequency displayed. Rpm remains in zero, but while riding there is a rpm displayed but I´m not sure if it is the real rpm frequency. Still a bit strange.

There was no solution from Garmin support. So how ever I’ve to send back my trainer…….

Thanks.

71AFCD74-59CA-4D67-A1FB-9BAFB822AD86.jpeg

[private info redacted]