Tacx neo problems


(Marc Souren) #1

I’ve problems with zwift in combi with iPhone se and Tacx neo.
Ive selected roadfeel but often nothing happens on the cobbles in Innsbruck. Also the sloops dont feel like sloops. I dont need to change gears at all.
For example, i dit 4 laps of the 7,7 km Innsbruck and 2 laps i had roadfeel and the last 2 laps not.
Looks like zwift doesn’t control the trainer at all.
What could be the problem?


(Mike Kelly) #2

Are you in workout mode with erg turned on? That will turn off both of the things that you describe. I have not tried the Innsbruck course, but my Neo responds to road feel on the Watopia course without issues.


(Marc Souren) #3

Hello, no iam not in workout mode.
Just free ride a course.
In workout mode i get feadback of zwift. When i have to increase wattage from eg 100w to 200w i feel the trainer increases the resistance.
But during a not workout spin i dont feel anything when the sloop increases.
The settings are all default


(Mike Kelly) #4

Marc, which course in Innsbruck are you riding? I can try it on my Neo and iPhone and see if it also happens for me.


(Marc Souren) #5

Mike, its the shortest one, called innsbruckring.
In the citycenter is a cobble stone section, where before i had the roadfeel. Today nothing happend during 4 laps. Also after that section a small climb Will appear. Which i took on the biggest gear and a cadance of +100. But ramps where +10%


(Mike Kelly) #6

Marc, I rode Innsbruckring and in my case my Neo worked with gradient, road feel, and drafting effect. Here was my configuration:

Game:
Device: PC, Windows 10
Network: Wifi
World: Innsbruck
Route: Innsbruckring
Workout: Just Ride
Tacx Neo Road Feel: On
Trainer Difficulty: 50%

Pairing:
Device: Companion App, iPhone 6s
Protocol: Bluetooth
Paired Devices: Power source, Cadence, Controllable


(Marc Souren) #7

Hi Mike,

Thanks for testing.
But… me problem occurs when im using an iPhone se as the os source connected to the Tacx. I get powermeasurement from the Tacx into zwift, but the opposite, controling the Tacx during climb or roadfeel section not. So i think theres something wrong with 2-way Bluetooth connection.
Yesterday i rode Innsbruck again but then with my laptop with Windows 10 and ANT+ stick and everything felt ok. I had roadfeel and resistance changing during climb.


(Vincent W.) #8

Hey Marc, thanks for all the details! Can you send us a support conversation with your latest log files? https://support.zwift.com/hc/en-us/requests/new

How to find log files: https://support.zwift.com/en_us/how-do-i-find-my-log-files-running--HkFCtXX8m


(Kevin Lewis) #9

This sounds exactly like the Neo/Zwift/Bluetooth problem that many of us are suffering.

The Neo loses resistance control. No road feel. It works perfectly with Ant+, but with Bluetooth (in my case, with AppleTV4K, and iPad) 80% of my rides with Bluetooth result in riding with an expensive dumb trainer. This has been happening for 3-4 months, after 18 months of zero problems.

I have an open ticket with you. I’d love an update on where you are with this please.


(Marc Souren) #10

Hello Kevin,

Ive send my logfiles where this problem occurs.
They (zwift) is telling me there no problem.
When i open these logs ive seen lots of errors and warnings.

Im not a programmer but this worries me a lot.
Also, i don’t think its something wrong with the neo, in the normal Tacx app or trainerroad ive never had problems during iOS and bluethooth connection.
Do u think its the neo Bluetooth thats the problem? Or where did you sent in a ticket? Tacx or zwift??


(Marc Souren) #11

This was the reaction.

Hi Marc.

Thanks for sending that in!

After taking a look at your log, I’m not seeing anything that could possible explain this issue.

However I’d like you to try turning off, and turning back on the Tacx Road Feel road feel option in the Zwift settings menu to see if that resolves the issue.

If that merits no success, I’ve included some steps below that may help.

  1. Unpair trainer from Zwift.
  2. Log out of Zwift.
  3. Reboot Zwift device (force reboot iOS/Unplug Apple TV [and throw it in the trash]).
  4. Pair trainer to official support app. (in this case, Tacx Utility app)
  5. If SIM is off, turn it on.
  6. If SIM is on, turn it off, then back on.
  7. Unpair from the support app.
  8. Pair in Zwift.
  9. Ba-zinga! You should be all set!

Go ahead and give these a try and let me know how it goes.

Thanks!


(Kevin Lewis) #12

@Marc_Souren I raised a ticket with Zwift.

I’ve done all the steps that Zwift have suggested with no success, including a full factory reset of my AppleTV4K.

80% of my rides result in my Neo being not controlled by Zwift. Other apps control it reliable, as did Zwift until this summer.


(Vincent W.) #13

Hey Kevin, I read your support ticket and see that you’ve made contact with us. As said before we’re collecting data on BLE resistance issues from several trainers including TacX Neo. When we have new updates we will let everyone know!


(Steve Copeland) #14

I am using a TacX Neo with no problems at all so this is a bit of a weird one. Are you running the latest firmware on the Neo?


(Marc Souren) #15

Just to be sure, are you using the neo in combination with zwift running on an Apple IOS with Bluetooth connection?

Its true, im not always in trouble, but more then 70% theres no roadfeel and no control of the resistance. I fact there is powerout from the neo in zwift, but communication backwards to the neo isn’t. ( in- decrease resistance and roadfeel)
On my Very poor pc (sub zwift reconmendation specs) with win10 and ANT+ stick is 100% oké.


(David K) #16

Hey Marc,

I checked your support ticket and noticed something curious. Your account shows you have an ANT+ dongle plugged into your PC, but the logs you sent us in your support ticket show you’re connecting over Bluetooth. Please try disabling Bluetooth on your PC just to ensure you are pairing over ANT+ specifically and let me know if you’re still noticing the resistance inaccuracies afterward.


(Marc Souren) #17

David, i switched to pc with ANT+ on my last rides because of the problems with Bluetooth in combination with Apple iOS.

With pc and ANT+ it works 100% fine for me. With iOS and Bluetooth it doesnt most of the time.

So its true, the logfile you looked at was with Apple iOS and Bluetooth.


(Michael Sambrano (Gf Capital)) #18

I am having the exact same issue. It seemed to start this summer with the Innsbruck update. I have Neo Tacx + Apple TV. Rides start out OK, but usually about 20 minutes into the ride the trainer suddenly feels like it’s in ERG mode (plus I lose road feel). It’s been maddening. No other changes in my setup at all–it’s just been a recent issue.


(Torsten Delta Bike De (C)) #19

Hi at all,
i have the same issues. After my Zwift Summer break :slight_smile: i have updated my Zwift IOS App and the problems began.
The Rides start OK, but after about a few minutes into the ride the tacx Neo trainer feels like its is in Ergo mode.
And also the road feel is gone.
The last 2 Winterseasons i had not this problems, so i think it comes with a Last Zwift update.

My Setup:
APPLE iPad Air 2
Tacx Neo

both connected with Bluetooth and on the latest Firmware and App.


(Johan Tjust) #20

Hi,

I bought the Neo just 2 months ago and in the beginning I had no problems but now the road feel stopped working, I still have resistansen in the hills though. I use iPad with blutooth connection. When I try the road feel in the Tacx Utility app it works fine.

//J