Road Feel


I’m having trouble getting the Roadfeel to work in Zwift on my Neo2.
It worked the 1st time i connected and did a brief test ride… was a little unnerving!

Since then i’m getting nothing, regardless of whether the trainer is connected via Ant+ or Bluetooth. - I have the latest firmware installed.

Within the settings menu road feel is ‘On’, and it works when linking the trainer to the Tacx app outside of Zwift and using the testing function.

Any help appreciated.

Have you turned it on in the tacx utility app? I think any settings in that overwrite zwift’s settings.

Hi, yep all on. - Any idea of the best place in Zwift to test it?

Log into Zwift and choose the Watopia map, then choose the Flat Route to ride. Shortly after you get through the tunnels on Ocean Boulevard, you’ll run into wooden planks and then dirt. You should get the road feel on these sections.

I also have a Neo2, but have noticed the following:

  1. There are a couple of sections of maps throughout the game that do not provide road feel but appear as though they should. This happens at the same sections every time, so you’ll get to know those specific sections.

  2. If you are riding in a crowd, such as a race or a group ride, and there are a lot of people around you, the road feel may be delayed as much as 15-20 seconds. This may be due to my specific setup, but don’t be surprised if it happens.

Hope you get it working!

Right - Sorted.

Turns out if you have the trainer still connected to the Tacx utility app in the background this overrides the Zwift setting. - Suggest only have it on when checking for firmware updates and then roadfeel seems to work just fine.

Thanks for all the firndly help & suggestions :slight_smile:

1 Like